Bug Hunting Session
Bug 58370 - "Send Feedback..." URL invalid in other languages then English
Summary: "Send Feedback..." URL invalid in other languages then English
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: WWW (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta1
Hardware: Other All
: medium normal
Assignee: Rob Snelders
URL:
Whiteboard: target:4.1.0 target:4.0.0.0.beta3
Keywords:
: 58935 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-16 17:20 UTC by Lucas Betschart
Modified: 2014-11-06 04:21 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lucas Betschart 2012-12-16 17:20:08 UTC
When clicking on "Send Feedback..." after I've set my language to German (then it's called "Fehler Melden (Englisch)) my browser wants to open a website that doesn't exist:

https://www.libreoffice.org/get-help/bug/?version=4.0.0.0.beta1&locale=de&module=DrawingDocument


When LO is set to English the website exists (https://www.libreoffice.org/get-help/bug/?version=4.0.0.0.beta1&locale=en-US&module=DrawingDocument).


Solution:
If there is no website for the specific language available take English as default.
Comment 1 Lucas Betschart 2012-12-16 17:58:05 UTC
To make it clear, this link is inside LibreOffice in the "Help"-Menu.
Comment 2 Florian Effenberger 2012-12-16 20:35:40 UTC
Cc'ing Rob, who IMHO is working on the bugzilla assistant. Rob, can you investigate if you can work on that, or if it's better to catch it via mod_rewrite?
Comment 3 Rob Snelders 2012-12-16 22:23:56 UTC
I have send an email to the website-list. To see how we can solve this.
Comment 4 Rob Snelders 2012-12-18 21:43:55 UTC
submit a patch to solve this https://gerrit.libreoffice.org/#/c/1408/
Comment 5 Not Assigned 2012-12-18 22:00:49 UTC
Rob Snelders committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3b87d3dd507cd48286160e62383f48e2f70f0067

fdo#58370 - 'Send Feedback...' URL invalid in other languages then English



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Not Assigned 2012-12-18 22:07:00 UTC
Rob Snelders committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=91a9b1f163fb698a0fae657b7cc6f60a617c5760&g=libreoffice-4-0

fdo#58370 - 'Send Feedback...' URL invalid in other languages then English


It will be available in LibreOffice 4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Rob Snelders 2013-01-03 18:31:11 UTC
*** Bug 58935 has been marked as a duplicate of this bug. ***