Bug 86209 - MENUS: Reorganize the View menu
Summary: MENUS: Reorganize the View menu
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha2
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:4.4.0
Keywords:
Depends on:
Blocks: Main-Menu Impress-UX
  Show dependency treegraph
 
Reported: 2014-11-12 15:45 UTC by Yousuf Philips (jay)
Modified: 2017-05-13 12:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
before and after of the menu (44.33 KB, image/png)
2014-11-12 15:45 UTC, Yousuf Philips (jay)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) 2014-11-12 15:45:38 UTC
Created attachment 109353 [details]
before and after of the menu

After frequent viewing of the impress menubar, i found it quite disorganized when compared to the writer and calc menubars, so here is a suggest reorganization.

The after screenshot doesnt show View > Headers and Footers that should either be in the Edit or Format menus and View > Start from first Slide is removed as its already in the Slide Show menu.
Comment 1 A (Andy) 2014-11-12 23:03:04 UTC
For me this looks very good.  I am surprised that I did not notice this disorganisation before.  With this very good proposal the first section in the menu VIEW is sorted as the tabs above the slides and it is also then consistent with the organisation in CALC and WRITER, but the position of the entry SIDEBAR should be the same in WRITER, CALC and IMPRESS.
Furthermore, if this change would be done it should also be similar done in DRAW.  Then we would have a consistency in the different LO applications.

Note: One difference I have is that I don't have the CLIP ART GALLERY entry in my LO 4.3?  

Regarding the entry HEADER AND FOOTER I agree it should be moved, maybe to INSERT.
In CALC you the find a menu item "Headers & Footers" in the menu EDIT.  In WRITER we have two menu items "Header" and "Footer" in the menu INSERT.  In IMPRESS it is currently a menu item named "Header and Footer" in the menu VIEW.  INSERT seems for me to be logical because with this function you would insert a header or footer.  But the naming should also be similar (-> small typing differences in CALC and IMPRESS). 

Reproducible with LO 4.3.3.2, Win 8.1.
Comment 2 Cor Nouws 2014-11-13 10:22:28 UTC
(In reply to Jay Philips from comment #0)
> Created attachment 109353 [details]
> before and after of the menu

thanks!

> After frequent viewing of the impress menubar, i found it quite disorganized

indeed :)

> when compared to the writer and calc menubars, so here is a suggest
> reorganization.
> 
> The after screenshot doesnt show View > Headers and Footers that should
> either be in the Edit or Format menus 

Edit would be my choice.

> and View > Start from first Slide is
> removed as its already in the Slide Show menu.

Agreed.

Only I doubt a bit about the Ruler. I would think that belongs in the next group, with Grid, since it refers the active slide. But it's more my feeling that a - IMO - strong argument..
What do you think?
Comment 3 Yousuf Philips (jay) 2014-11-13 13:07:44 UTC
(In reply to A (Andy) from comment #1)
> but the position of the
> entry SIDEBAR should be the same in WRITER, CALC and IMPRESS.

Yes i will add a similar reorganization of the sidebar section to calc and writer.

> Furthermore, if this change would be done it should also be similar done in
> DRAW.  Then we would have a consistency in the different LO applications.

Yes it would be good to do it for Draw as well, to bring the consistency with all the apps.

> Note: One difference I have is that I don't have the CLIP ART GALLERY entry
> in my LO 4.3?  

Tools > Gallery has been moved to View > Clip Art Gallery in 4.4.

> Regarding the entry HEADER AND FOOTER I agree it should be moved, maybe to
> INSERT.
> In CALC you the find a menu item "Headers & Footers" in the menu EDIT.  In
> WRITER we have two menu items "Header" and "Footer" in the menu INSERT.  In
> IMPRESS it is currently a menu item named "Header and Footer" in the menu
> VIEW.  INSERT seems for me to be logical because with this function you
> would insert a header or footer.  But the naming should also be similar (->
> small typing differences in CALC and IMPRESS). 

I find this a major problem of having it in different places in different apps. With impress, after editing the dialog, it inserts details into the slide, so INSERT does seem logical here. I think it also seems logical to do the same for calc to keep the consistency between the apps and even there you are inserting.

(In reply to Cor Nouws from comment #2)
> Edit would be my choice.

I was always favoring FORMAT, but after Andy's suggestion of INSERT, i think that is more suitable. I was favoring FORMAT because though you are inserting and editing the header and footer, you are also changing the way it looks and how its is being organized.

> Only I doubt a bit about the Ruler. I would think that belongs in the next
> group, with Grid, since it refers the active slide. But it's more my feeling
> that a - IMO - strong argument..
> What do you think?

I had put Grid separate from Ruler as i was keeping the section with Ruler with entries that change the UI outside of the document area, and the section with Grid with entries that effect things in the document area.
Comment 4 Yousuf Philips (jay) 2014-11-14 04:06:38 UTC
Patch submitted - https://gerrit.libreoffice.org/12421

Will submit a second patch once we have some agreement on where to place the header and footer. :D
Comment 5 Commit Notification 2014-11-18 09:36:13 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7a0b2698b4f92cbc64869e4ff34bcb2fad9e1c98

fdo#86209 reorganized the view menu in impress and draw

It will be available in 4.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Adolfo Jayme 2014-11-26 06:51:17 UTC
Have you thought in updating the help files to reflect the changes?
Comment 7 Cor Nouws 2014-11-28 12:44:06 UTC
(In reply to Adolfo Jayme from comment #6)
> Have you thought in updating the help files to reflect the changes?

Yes, has this massive task already be discussed?
Comment 8 Yousuf Philips (jay) 2014-11-29 10:47:09 UTC
(In reply to Adolfo Jayme from comment #6)
> Have you thought in updating the help files to reflect the changes?

Do you mean of images of the view menu in the help files?
Comment 9 Mike §chinagl 2014-12-20 22:37:28 UTC
This bug fix comes with LibreOffice 4.4 (release notes https://wiki.documentfoundation.org/ReleaseNotes/4.4) 

The View menu was reorganized to better unify its items similar to Writer and Calc.