Bug 86271 - Pasting multiple lines to a line that is bolded makes the last line of the paste bold.
Summary: Pasting multiple lines to a line that is bolded makes the last line of the pa...
Status: RESOLVED DUPLICATE of bug 105352
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-14 03:28 UTC by Mike Overby
Modified: 2020-07-30 14:40 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
An example of the bold issue (25.45 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-03-19 06:45 UTC, rikard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Overby 2014-11-14 03:28:32 UTC
Steps to reproduce:

1) Write some bold text.

2) Write multiple lines (as in pressing enter, not line wrapping) of normal text

3) Cut the lines of normal text.

4) Paste the normal text on the line that is bold.

You should see the bug. I'm including a video.
Comment 1 Mike Overby 2014-11-16 08:42:03 UTC
The video was way too big. I uploaded it to YouTube, instead. See here: http://youtu.be/0bRbbocvEXI
Comment 2 Tim Lloyd 2014-11-16 23:23:53 UTC
I wasn't able to clearly see the problem via the vid. But following the instructions I pasted the normal text (3 lines) to the end of the bolded line.

Voila, the first line is appended to the bolded line in bold.
The second line appears in normal text
The third line is bolded

So I can see the problem Fedora 21

Version: 4.4.0.0.alpha2+
Build ID: b7c4c78a097f76314982d8c1a9f2e58df95080a1

However, if I
1. add a 4th, blank, line after the 3 lines of normal text.
2. Cut & paste the 4 lines

the 3 normal lines are displayed correctly.

Mike, let me know if this is a decent simulation of your problem and we can confirm this for all platforms
Comment 3 Mike Overby 2014-11-17 06:16:44 UTC
(In reply to Tim Lloyd from comment #2)
> Voila, the first line is appended to the bolded line in bold.

This is curious. In mine, the first line was appended in normal.

> The second line appears in normal text
> The third line is bolded

Otherwise, yes this seems to be a decent simulation of what I found. However, I just realized that my initial instructions didn't say to use a list (bulleted or numbered), although that was in the video. Did you do that as well?

While trying to reproduce it again, I learned that the bug does not exist for me in cases where I simply pressed enter to go to the next line, without a list. The list did work again.

> However, if I
> 1. add a 4th, blank, line after the 3 lines of normal text.
> 2. Cut & paste the 4 lines
> 
> the 3 normal lines are displayed correctly.

The three normal lines would be displayed correctly, yes, because the bolding bug only seems to be affecting the last line. Is bolding enabled on that blank line for you?
Comment 4 Tim Lloyd 2014-11-17 21:44:50 UTC
I am setting this to new based on the steps Mike outlines in the original post.

Pasting multiple lines of plain text onto a bolded line produces mixed results as documented in the other posts.

Devs: feel free to ask for clarification as required.
Comment 5 QA Administrators 2015-12-20 16:15:13 UTC Comment hidden (obsolete)
Comment 6 rikard 2016-03-19 06:45:20 UTC
Created attachment 123711 [details]
An example of the bold issue

One of our customer noticed the same thing.

I can fix it if I explicitly remove the bolding in Libre and save it as such. But it behaves differently from MS Office which doesn't have [[beers.brewery]] bolded.
Comment 7 QA Administrators 2017-05-22 13:18:58 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2019-12-03 14:25:42 UTC Comment hidden (obsolete)
Comment 9 Timur 2020-07-30 14:40:21 UTC
Couple of similar bugs after this one, reporters didn't search.
Although they should be duplicated, we already have duplicates on bug 105352 so I also mark this one.

*** This bug has been marked as a duplicate of bug 105352 ***