Bug 86311 - VIEWING: Synthetic bold creates spaces between cursive arabic characters
Summary: VIEWING: Synthetic bold creates spaces between cursive arabic characters
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:5.3.0
Keywords:
Depends on: HarfBuzz
Blocks: RTL-CTL Font-Rendering
  Show dependency treegraph
 
Reported: 2014-11-15 14:27 UTC by Yousuf Philips (jay)
Modified: 2017-10-02 14:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (124.52 KB, image/png)
2014-11-15 14:27 UTC, Yousuf Philips (jay)
Details
Shows space between letter and another related problem! (316.70 KB, image/png)
2015-02-16 07:00 UTC, PHP Learner
Details
with and without harfbuzz (73.06 KB, image/png)
2016-11-07 20:01 UTC, Yousuf Philips (jay)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) 2014-11-15 14:27:36 UTC
Created attachment 109520 [details]
screenshot

Steps:
1) Open attachment 88044 [details]
2) Notice the spacing between character on the first line and on the line of dashes.

Tested on master. This issue doesnt happen on windows.

Version: 4.4.0.0.alpha2+
Build ID: 89db5b5b88508e55bce50240d248dd26053f4e09
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-11-12_20:58:53
Comment 1 PHP Learner 2015-02-16 06:36:54 UTC
I face this bug on LibreOffice Writer 4.2.7.2 On Ubuntu 14.04!
Comment 2 PHP Learner 2015-02-16 07:00:54 UTC
Created attachment 113421 [details]
Shows space between letter and another related problem!

I think the extra white space problem that occurs some times between some Arabic/Persian fonts character is related to another problem that is mentioned as "extra-dash" in the picture!
Comment 3 Yousuf Philips (jay) 2015-02-17 08:41:50 UTC
Looks similar to the kashida problems found in other bug report so adding them to see also.
Comment 4 Khaled Hosny 2015-02-17 22:35:30 UTC
Looks like you don’t have a bold version of this font (AFAIK Arabic Typesetting has only a regular font), so what you are seeing is the effect of fake bold done by FreeType. Can be easily verified by trying to make bold text using this font on onther application.
Comment 5 Yousuf Philips (jay) 2015-02-22 00:52:27 UTC
Tried to make it bold in Calligra Words but it wouldnt allow me to do so and Calligra only listed regular and italics for that font.
Comment 6 tommy27 2016-04-16 07:23:26 UTC Comment hidden (obsolete)
Comment 7 Alex Thurgood 2016-09-06 11:18:03 UTC
*** Bug 97329 has been marked as a duplicate of this bug. ***
Comment 8 Khaled Hosny 2016-10-19 22:00:05 UTC
This is simply a bug in how FT_GlyphSlot_Embolden() works (the FreeType function we use to create synthetic bold) as it increases the glyph width which causing such bugs.

This should be fixed with bug 89870, as we now always use original glyph metrics not FreeType one (that this function changes).
Comment 9 Yousuf Philips (jay) 2016-11-07 20:01:14 UTC
Created attachment 128553 [details]
with and without harfbuzz

Find the extra spacing between characters in the non-harfbuzz engine better than then harfbuzz version.
Comment 10 Yousuf Philips (jay) 2016-11-07 20:01:41 UTC
Verified.

Version: 5.3.0.0.alpha1+
Build ID: 11cab8aba359c655a75791ddbc0f2ffeae8ce206
CPU Threads: 2; OS Version: Linux 3.19; UI Render: default; VCL: gtk2; Layout Engine: new; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-11-06_23:07:09
Locale: en-US (en_US.UTF-8); Calc: group