Bug 97329 - Wrong Spaces Placement Between Arabic Words
Summary: Wrong Spaces Placement Between Arabic Words
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.1.0.2 rc
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.3.0
Keywords:
Depends on: HarfBuzz
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-22 20:26 UTC by Mansour
Modified: 2016-11-06 18:34 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Wrong Spaces Positing for Arabic Text (683.42 KB, image/png)
2016-01-22 20:26 UTC, Mansour
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mansour 2016-01-22 20:26:45 UTC
Created attachment 122162 [details]
Wrong Spaces Positing for Arabic Text

When writing in Arabic, Writer for Mac OS X puts space at the beginning of line not at the end of it. Please see the attached screenshot which visualizes the bug.

This bug mostly affects mixed text, i.e. that contains latin and arabic alphanumeric. For example, a phrase like "test اختبار" appears as "testاختبار" without a space between the two words.

The bug also breaks the right alignment of Arabic text.
Comment 1 raal 2016-02-04 10:11:02 UTC Comment hidden (obsolete)
Comment 2 Alex Thurgood 2016-09-06 11:18:03 UTC

*** This bug has been marked as a duplicate of bug 86311 ***
Comment 3 Khaled Hosny 2016-10-19 21:46:14 UTC
This is not a duplicate of bug 86311, it is a totally different issue.