Bug 86470 - Change case function doesn't work with multiple columns selection
Summary: Change case function doesn't work with multiple columns selection
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other All
: medium normal
Assignee: Kohei Yoshida
QA Contact:
URL:
Whiteboard: target:5.4.0 target:5.2.6 target:5.3.1
Keywords: bibisected, bisected, regression
: 92307 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-11-19 17:52 UTC by s.malacarne
Modified: 2017-02-12 16:09 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description s.malacarne 2014-11-19 17:52:25 UTC
Calc bug

Problem description: 
If multiple columns are selected the change case function works just on 1st column. All the others are uneffected.

Steps to reproduce:
1. write some text on multiple columns
2. select the colums (not the single cells but the whole columns)
3. use change case function under formatting menu

Current behavior:
only the first column get the case changed

Expected behavior:
all selected columns should have case chenged
Comment 1 A (Andy) 2014-11-19 22:05:39 UTC
Reproducible with LO 4.3.3.2, Win 8.1

Steps Done:
1. Open CALC
2. Write "this is a test" in cell A1, B1 and C1
3. Select the columns A, B and C
4. Go to FORMAT -> CHANGE CASE -> UPPER-CASE

Result:
Only column will be changed to upper-case.
Comment 2 tmacalp 2014-12-08 22:43:33 UTC
I've bibisected and this appears to have started around 4.2.0.X, so I'm changing the version to something close.


Bibisect:
83a62c1c1e8e259144e489d9a1f42611eba063c3 is the first bad commit
commit 83a62c1c1e8e259144e489d9a1f42611eba063c3
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Thu Oct 17 14:30:14 2013 +0000

    source-hash-022c54742e7997bf46a608f1ab0b500f2537f7f5    

    commit 022c54742e7997bf46a608f1ab0b500f2537f7f5
    Author:     Tor Lillqvist <tml@iki.fi>
    AuthorDate: Tue Jun 25 07:19:41 2013 +0300
    Commit:     Tor Lillqvist <tml@iki.fi>
    CommitDate: Tue Jun 25 07:19:41 2013 +0300
    
        WaE: private field 'mrCells' is not used
    
        Change-Id: I0ab3fabb82c839f5194b0e20eb834dd86635a609

$ git bisect log
# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect good e02439a3d6297a1f5334fa558ddec5ef4212c574
# bad: [4850941efe43ae800be5c76e1102ab80ac2c085d] source-hash-980a6e552502f02f12c15bfb1c9f8e6269499f4b
git bisect bad 4850941efe43ae800be5c76e1102ab80ac2c085d
# skip: [a043626b542eb8314218d7439534dce2fc325304] source-hash-9379a922c07df3cdb7d567cc88dfaaa39ead3681
git bisect skip a043626b542eb8314218d7439534dce2fc325304
# skip: [aba65c3e4c0df07e4909aeefb758cdb688242bf6] source-hash-827524abfb4b577d08276fde40929a9adfb7ff1a
git bisect skip aba65c3e4c0df07e4909aeefb758cdb688242bf6
# skip: [aba65c3e4c0df07e4909aeefb758cdb688242bf6] source-hash-827524abfb4b577d08276fde40929a9adfb7ff1a
git bisect skip aba65c3e4c0df07e4909aeefb758cdb688242bf6
# skip: [aba65c3e4c0df07e4909aeefb758cdb688242bf6] source-hash-827524abfb4b577d08276fde40929a9adfb7ff1a
git bisect skip aba65c3e4c0df07e4909aeefb758cdb688242bf6
# bad: [c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31] source-hash-c69ed33628ec0b7abf6296539cf280d6c4265930
git bisect bad c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31
# bad: [c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31] source-hash-c69ed33628ec0b7abf6296539cf280d6c4265930
git bisect bad c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31
# bad: [1d4980621741d3050a5fe61b247c157d769988f2] source-hash-89d01a7d8028ddb765e02c116d202a2435894217
git bisect bad 1d4980621741d3050a5fe61b247c157d769988f2
# bad: [ba096f438393091574da98fe7b8e6b05182a8971] source-hash-8499e78ca03c792f4fa2650e02b519094ba0baa8
git bisect bad ba096f438393091574da98fe7b8e6b05182a8971
# bad: [9daa289e178460daaafa4b3911031df5b8736218] source-hash-704292996a3731a61339b1a4a5c90c9403aa095f
git bisect bad 9daa289e178460daaafa4b3911031df5b8736218
# good: [69bf614869471f46413fe1d2af5976b2e6d85084] source-hash-76dea8b2db906156e77f78738a68f932a15afd4b
git bisect good 69bf614869471f46413fe1d2af5976b2e6d85084
# good: [502c05c771cd993b237febc2d8a20140fe589488] source-hash-462df4920ef50032c8f99a9db2ca34c9cc928657
git bisect good 502c05c771cd993b237febc2d8a20140fe589488
# bad: [567bfa79fb5ad4f9dfa05f0dea7666208d6129b2] source-hash-4d5fc661d37d03129b8054e494c03bed1933231d
git bisect bad 567bfa79fb5ad4f9dfa05f0dea7666208d6129b2
# good: [7d878017eaa2fc1d2eab72689a5e453622d474a2] source-hash-b139f6fedfcf3cbed0eadeb007e2155b576413d2
git bisect good 7d878017eaa2fc1d2eab72689a5e453622d474a2
# bad: [83a62c1c1e8e259144e489d9a1f42611eba063c3] source-hash-022c54742e7997bf46a608f1ab0b500f2537f7f5
git bisect bad 83a62c1c1e8e259144e489d9a1f42611eba063c3
# first bad commit: [83a62c1c1e8e259144e489d9a1f42611eba063c3] source-hash-022c54742e7997bf46a608f1ab0b500f2537f7f5
Comment 3 Matthew Francis 2014-12-24 04:38:38 UTC
(Commented during a sweep of bugs that are bibisected but not source bisected)

Narrowed the commit in question down to the range c7bdee8dbd1cf260a8513a0d31b36f90daa70f1c..ec0080c40cfdb26896537f47a4c2e0439f9afdb1

Unfortunately that still contains quite a few potentially relevant commits, and they all suffer from various build breakages (and are not easy to cherry-pick only the corresponding build fixes onto)
Comment 4 jose.velez 2015-02-25 09:45:58 UTC
If you select a set of cells "change case" doesn't work either.
Comment 5 Robinson Tryon (qubit) 2015-12-13 11:11:10 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]
Comment 6 Xisco Faulí 2016-10-06 21:02:25 UTC
*** Bug 92307 has been marked as a duplicate of this bug. ***
Comment 7 raal 2016-11-20 05:20:56 UTC
This seems to have begun at the below commit.
Adding Cc: to Kohei Yoshida ; Could you possibly take a look at this one?
Thanks

8e7bade4e7314a340c77edd9042e230f61f0323d is the first bad commit
commit 8e7bade4e7314a340c77edd9042e230f61f0323d
Author: Matthew Francis <mjay.francis@gmail.com>
Date:   Sat Sep 5 18:33:36 2015 +0800

    source-hash-4c99a427ee4adaeddb2682c192384bad21d9d09b
    
 
    
    commit 4c99a427ee4adaeddb2682c192384bad21d9d09b
    Author:     Kohei Yoshida <kohei.yoshida@gmail.com>
    AuthorDate: Mon Jun 24 16:19:02 2013 -0400
    Commit:     Kohei Yoshida <kohei.yoshida@gmail.com>
    CommitDate: Mon Jun 24 16:51:45 2013 -0400
    
        Fix incorrect merge.
    
        Change-Id: I1337413e1ee49b7d90671ac517dbb2bd918dbebf

git bisect log
# bad: [8775b1622f226e863b864de7e208226cbfb914e3] source-hash-22ea573b7417db0392c006dff06cde50ddbcd469
# good: [b3c6cf289ff72449408fa01958092d9e482e82bd] source-hash-a2c9d4f8bbde97f175bae4df771273a61251f402
git bisect start 'latest' 'oldest'
# bad: [be115ebaad667aefcc0366ce23d6bc7013060424] source-hash-5e6b2d0e4a55be8a4f57ecfe55248d7924d4f0b7
git bisect bad be115ebaad667aefcc0366ce23d6bc7013060424
# skip: [5ebca0edc8770a0f1d11b8a88c0dd2b389c189e3] source-hash-15cf5afea05f0539035a1393b3150121489eb561
git bisect skip 5ebca0edc8770a0f1d11b8a88c0dd2b389c189e3
# skip: [8efcbbea77314696f7c387be28eb1afe8618c1c8] source-hash-9e8e5568e2a566119ab57e1653f72f59f7169e94
git bisect skip 8efcbbea77314696f7c387be28eb1afe8618c1c8
# skip: [c6b9f724813937430f86e13dbd59afb8339e29e1] source-hash-a86af5919e19d989ee9344071b1bb13140cb83ef
git bisect skip c6b9f724813937430f86e13dbd59afb8339e29e1
# bad: [e873164df2e9e79aacd8885d624fe65bb6cb7812] source-hash-608dec14f1fd7b46b294da9341a6da6a24caef91
git bisect bad e873164df2e9e79aacd8885d624fe65bb6cb7812
# skip: [87fb9795a9f58ec025d35edeb28557125a27f9a0] source-hash-85ce60d4c43d35b9673ed22f4a4adaa4928349be
git bisect skip 87fb9795a9f58ec025d35edeb28557125a27f9a0
# bad: [b8a30355bea6922acde16c08b8742d2f629e9913] source-hash-942501b6e49c6c9e19556d9ec132a458e5fef6c3
git bisect bad b8a30355bea6922acde16c08b8742d2f629e9913
# good: [f14480891d2a26b9d427442664ee4230f1fda84f] source-hash-5fcd67d436d3a3a0f5332b5a5078e135e40c898b
git bisect good f14480891d2a26b9d427442664ee4230f1fda84f
# skip: [99e1a6455944a4fb2b38a7cd9fa48bd7c11d4654] source-hash-fd2bd50bb4fbe139cd1ed9332c0d2eeaebc7dabe
git bisect skip 99e1a6455944a4fb2b38a7cd9fa48bd7c11d4654
# bad: [ab6280d4af81165f85c9bbec9cd2d71edaf73526] source-hash-1ec3fac48866c27d0c4b6ffb44befcba66d1f229
git bisect bad ab6280d4af81165f85c9bbec9cd2d71edaf73526
# good: [f86a411f1828013fbcd0e8c7760d3638034078a9] source-hash-ddddfe8d6ffa05c467bddb3480e43d7043a3d3c9
git bisect good f86a411f1828013fbcd0e8c7760d3638034078a9
# bad: [b3f71f863dd07cc964617405c1a9fe6f15c90707] source-hash-bfe6d9f7ee31e4516a9116cac870d29d5c10990e
git bisect bad b3f71f863dd07cc964617405c1a9fe6f15c90707
# skip: [1fb28df89d6c2223d460bb4d6e7922552a465f47] source-hash-df0ac37929a1ae1bd72279242194d51693a91a8c
git bisect skip 1fb28df89d6c2223d460bb4d6e7922552a465f47
# bad: [8d0fcc52ffa6c49fca54682d2e8be5cbede32fa0] source-hash-bc8f89931ab4cc0537e7710b6bc375c844ba6e68
git bisect bad 8d0fcc52ffa6c49fca54682d2e8be5cbede32fa0
# skip: [660d47f3dc13b470f509a7900944be4a15d4ed7c] source-hash-1b0a43142b27286e717f63c90363625a1aeff74c
git bisect skip 660d47f3dc13b470f509a7900944be4a15d4ed7c
# bad: [cdf60b88d5c43328eba73c660b28096e1c0e6e79] source-hash-ab030f75deafad4aab33ac47bfb36dd252e3515e
git bisect bad cdf60b88d5c43328eba73c660b28096e1c0e6e79
# bad: [5cdb5d4f6c20304e486e3413ca4f74ed96edf48c] source-hash-7a22c4c51980691146cff9c8c72a8a215fef0848
git bisect bad 5cdb5d4f6c20304e486e3413ca4f74ed96edf48c
# skip: [78bd06f5d2eefdbc58287020cacb6531909379b6] source-hash-902a65ffb571fa69853440051765313b805ebad1
git bisect skip 78bd06f5d2eefdbc58287020cacb6531909379b6
# good: [64081c12bfedc2ee6fde8c8edd3926e6fb5105d3] source-hash-3d4603e641daf75916648a3e3f1d8f60232efc9d
git bisect good 64081c12bfedc2ee6fde8c8edd3926e6fb5105d3
# skip: [cdf097e2632da2bcc5d15c3065fca5e52246b41d] source-hash-bd50bbe0c81a750b844f1c59ff3112fff6549704
git bisect skip cdf097e2632da2bcc5d15c3065fca5e52246b41d
# skip: [79778484bc49e582d47eb29ee3878794dba0febd] source-hash-06cf194af710d82e441d9cfcc05ed44cffcb5c41
git bisect skip 79778484bc49e582d47eb29ee3878794dba0febd
# skip: [763af4904dfa3650c61632d45fbe06b0a41e8d8b] source-hash-96456205067220cc73bffae6ae860dd120641660
git bisect skip 763af4904dfa3650c61632d45fbe06b0a41e8d8b
# skip: [641a7dc49d3ac6526c5e0efe0990ffc68e9ded52] source-hash-26a45c1886d9167d8f9ae9aad6234a3702768d8a
git bisect skip 641a7dc49d3ac6526c5e0efe0990ffc68e9ded52
# skip: [3079151127e8ae734821227bf7ffe866c3e68642] source-hash-fcae9bf3b14ef294c54751705d2532c6447b095a
git bisect skip 3079151127e8ae734821227bf7ffe866c3e68642
# skip: [4462c3dc3c69eebd281a231a3cf66a76fb262d14] source-hash-f9704bf73dfba50421132e5379165912a2779906
git bisect skip 4462c3dc3c69eebd281a231a3cf66a76fb262d14
# skip: [9188e74fde72bd35ea10017c803949fffbb113f8] source-hash-90ffe25cdda7f7922ea7def4a5bf99ff1671b0d3
git bisect skip 9188e74fde72bd35ea10017c803949fffbb113f8
# skip: [c3c4f5d4502c36561bc702e9d4350c9aa57ffae9] source-hash-cf6adeaf1c7f765c83481cff0311b9817ac4cbc1
git bisect skip c3c4f5d4502c36561bc702e9d4350c9aa57ffae9
# skip: [e720093454110a9d5c1af5ac945d4c1cedba7e3c] source-hash-96329b45a8b19beb84a67c13c8fbc0f96ac72d68
git bisect skip e720093454110a9d5c1af5ac945d4c1cedba7e3c
# good: [d7eaeac2e0fa1d803d0a1f6a2f88613522ca2e34] source-hash-f657ac9e7f0a078a31d9abfb0f1609d84abc0ffe
git bisect good d7eaeac2e0fa1d803d0a1f6a2f88613522ca2e34
# skip: [b7ab8807c17166455ecb066a0e491cefa97e7635] source-hash-a8ee2ee7529900628b1c533d77c039618917bc97
git bisect skip b7ab8807c17166455ecb066a0e491cefa97e7635
# skip: [70eec05415dbfa4ad984f45b66caa3fdc296722e] source-hash-9384f4d2c7c20ffe8ffa193af5d771248353f1dc
git bisect skip 70eec05415dbfa4ad984f45b66caa3fdc296722e
# skip: [783b37d184f89383587ebdf2368bf2efa32a25c8] source-hash-bc120d18144a78d42f9bbb017133e1da92e004ef
git bisect skip 783b37d184f89383587ebdf2368bf2efa32a25c8
# bad: [517058e89dab002d4258d7dd448c9aa0d1eb2e38] source-hash-3c87f574f7487d94f05cd95ac1cc26a4953dc6ec
git bisect bad 517058e89dab002d4258d7dd448c9aa0d1eb2e38
# bad: [821bc7eb6f1b1b1dee9fbb9aee563cbc7ff5f75b] source-hash-51daa4de4fbb86903aeb9cdfefbb089e8d00c001
git bisect bad 821bc7eb6f1b1b1dee9fbb9aee563cbc7ff5f75b
# bad: [8e7bade4e7314a340c77edd9042e230f61f0323d] source-hash-4c99a427ee4adaeddb2682c192384bad21d9d09b
git bisect bad 8e7bade4e7314a340c77edd9042e230f61f0323d
# good: [690230ca11ab32c64f94f842e6b56aacc881e201] source-hash-ac84ffb3c90bb5788608eadf2177f587021daaad
git bisect good 690230ca11ab32c64f94f842e6b56aacc881e201
# first bad commit: [8e7bade4e7314a340c77edd9042e230f61f0323d] source-hash-4c99a427ee4adaeddb2682c192384bad21d9d09b
Comment 8 Kohei Yoshida 2017-02-11 18:29:03 UTC
I'm looking into this.
Comment 9 Commit Notification 2017-02-11 22:02:22 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bcdde13996e3e33f9d4c41be25d062560c72636b

tdf#86470: Let's not forget to move onto the next column.

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2017-02-11 22:03:48 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5fea81e4bfc2372563c0612f95406ca34fdd2c96

tdf#86470: add unit test for this.

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Kohei Yoshida 2017-02-11 22:08:36 UTC
Fixed now, on the master branch.
Comment 12 Commit Notification 2017-02-12 00:14:02 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0771e099882229c4fb6c8553ed525a6556a52832&h=libreoffice-5-2

tdf#86470: Let's not forget to move onto the next column.

It will be available in 5.2.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2017-02-12 01:27:00 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0d3b87795f14d826810deacb9f460011f88181dc&h=libreoffice-5-3

tdf#86470: Let's not forget to move onto the next column.

It will be available in 5.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.