Download it now!
Bug 86486 - Find function has hardcoded keybinding
Summary: Find function has hardcoded keybinding
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Shortcuts-Accelerators Find-Toolbar
  Show dependency treegraph
 
Reported: 2014-11-20 09:47 UTC by Georg Altmann
Modified: 2017-10-24 12:24 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Georg Altmann 2014-11-20 09:47:58 UTC
After unbinding 'CTRL+F' in Tools->Customize->Keyboard 'CTRL+F' still triggers the find function (not find&replace).
With find function I am refering to the little find box that appears at the bottom of writer.

Expected behavior: after unbinding 'CTRL+F', pressing 'CTRL+F' does nothing
Proposed fix: Make the find function avaible as a key binding in Tools->Customize->Keyboard and bind it to 'CTRL+F' by default.
Comment 1 Urmas 2014-11-20 15:30:59 UTC
Confirmed in 4.4 -- Ctrl+F3 opens Find panel instead of the mapped (in)action.
Comment 2 Matthew Francis 2015-04-09 12:41:09 UTC
Also occurs in LO 3.3.0

-> Version: Inherited from OOo
Comment 3 tommy27 2016-04-16 07:26:02 UTC Comment hidden (obsolete)
Comment 4 Georg Altmann 2016-04-16 09:17:42 UTC
Still present in 

Version: 5.0.5.2
Build-ID: 5.0.5.2 Arch Linux build-3
Gebietsschema: de-DE (de_DE.UTF-8)

% uname -a
Linux gurke 4.4.5-1-ARCH #1 SMP PREEMPT Thu Mar 10 07:38:19 CET 2016 x86_64 GNU/Linux
Comment 5 QA Administrators 2017-10-23 14:12:17 UTC Comment hidden (obsolete)
Comment 6 Georg Altmann 2017-10-24 07:46:57 UTC
Confirmed in 
Version: 5.3.6.1
Build-ID: 5.3.6-2
CPU-Threads: 4; BS-Version: Linux 4.12; UI-Render: Standard; VCL: kde4; Layout-Engine: neu; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group
Comment 7 Maxim Monastirsky 2017-10-24 09:09:42 UTC
The find function was never hardcoded, it just that Writer required a restart after changing a global keybinding. And in 5.4 this problem seems to be fixed -> RESOLVED WORKSFORME (actually I suspect a particular commit, but didn't verify it).

Feel free to reopen, if you can still reproduce with 5.4 or master.
Comment 8 Georg Altmann 2017-10-24 12:08:49 UTC
Maxim, this seems not to be the case.
I just installed the newest libreoffice available on arch linux.

To replicate the problem:
* Tools->Customize->Keyboard
* Edit "CTRL-F" to "Styles/Character/Emphasis" (just for demonstration)
* -> "CTRL-F" changes emphasis of selected text
* Tools->Customize->Keyboard Delete "CTRL-F", i.e. unbind "CTRL-F"
* close writer (verfied that no process is running with "ps ax |grep libre")
* start writer
* "CTRL-F" opens find dialog in the bottom pane
  expected: "CTRL-F" does nothing


Version: 5.4.2.2.0+
Build ID: 5.4.2-2
CPU threads: 4; OS: Linux 4.12; UI render: default; VCL: kde4; 
Locale: en-US (en_US.utf8); Calc: group
Comment 9 Maxim Monastirsky 2017-10-24 12:21:42 UTC
(In reply to Georg Altmann from comment #8)
> Maxim, this seems not to be the case.
> I just installed the newest libreoffice available on arch linux.
> 
> To replicate the problem:
> * Tools->Customize->Keyboard
> * Edit "CTRL-F" to "Styles/Character/Emphasis" (just for demonstration)
> * -> "CTRL-F" changes emphasis of selected text
> * Tools->Customize->Keyboard Delete "CTRL-F", i.e. unbind "CTRL-F"
This is not enough. With this step you removed the CTRL-F binding on the Writer application level, but the find keybinding is defined on a global LO level. So you should do this:

1) Tools->Customize->Keyboard
2) In the right top corner there are 2 radio buttons. Choose there the "LibreOffice" context instead of "Writer".
3) Select CTRL-F from the list, and click "Delete".
Comment 10 Georg Altmann 2017-10-24 12:24:21 UTC
Doh! Got it, thanks!