Download it now!
Bug 86905 - EDITING outline level on non-heading paragraphs does not respect setting in Paragraph > Outline and Numbering > Outline level..
Summary: EDITING outline level on non-heading paragraphs does not respect setting in P...
Status: RESOLVED DUPLICATE of bug 62032
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Chapter-Numbering
  Show dependency treegraph
 
Reported: 2014-12-01 14:22 UTC by Yury
Modified: 2018-01-19 07:56 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
sample with level 1 and level 4 selected (13.40 KB, application/vnd.oasis.opendocument.text)
2014-12-01 14:22 UTC, Yury
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yury 2014-12-01 14:22:21 UTC
The non-heading paragraph, e.g., having 'Text body' style applied to it, can't be set to have its outline level other than 1. To be precise, one can select the, say, 'Level 4' in the Format // Paragraph // Outline & numbering // Outline level, and the 'Level 4' will stay selected, and the 4th level is displayed for this paragraph in Navigator // Content view panel.

However, the Numbering style // Options are raken from the settings for 'Level 1' .

Doesn't matter whether you change numbering via numbering style or straight  through the corresponding paragraph options dialogs. Same misfunction in 3.6.7.2 and in 4.3.4.1 on linux-x86_64.

To replicate (one of the variants, sample attached):

1) Create empty file and make two paragraphs in it.
2) Set paragraph style on the 1st paragraph to 'heading 1', on the 2nd paragraph - to 'Text body'.
3) Create numbering style, say, 'Custom 1'.
4) In 'Custom 1' set something obviously distinct both for, say, level 1 and level 4. You may set 'numbering' in Numbering style // Options // Numbering to letters for level 1 and to numbers for level 4.
5) Apply numbering style 'Custom 1' to both paragraphs
6) Set 'Level 4' in the Format // Paragraph // Outline & numbering // Outline level for the 2nd paragraph.

Result: The 2nd paragraph has its numbering style shown in the same way as if it was level 1.
Comment 1 Yury 2014-12-01 14:22:58 UTC
Created attachment 110299 [details]
sample with level 1 and level 4 selected
Comment 2 Cor Nouws 2014-12-01 14:52:57 UTC
Hi Yuri,

I can confirm the bug.

Thanks for filing this.

When you set the cursor at the beginning of your paragraph with level 4 and use TAB 3 times, it will be there...
But I agree it's no good behaviour.
AFAICR this is already from the OpenOffice-times.

Regards,
Cor
Comment 3 Yury 2014-12-01 19:03:42 UTC
Thank you! In all years I never knew this trick with TABs, so (hopefully) will be able to create a stop-gap macro, until this (hopefully) gets fixed.
Comment 4 Yury 2014-12-02 11:53:12 UTC
Unfortunately, that TAB trick works weirdly for me in a document instantiated from template (in which the numbering style resides). This may or may not be connected with the original issue.

What happens (right now tested only in 3.6.7.2/linux/amd64) is when I apply numbering style and outline level to an individual paragraph, and then try to TAB at the start of numbering (to get the numbers structure reflecting the level), every upper outline level (of the same numbering style) gets its 'Position' parameter indented by the textual tabulation amount!

More strange, these changes somehow go into the numbering style definition itself! Like it was having an analog of 'AutoUpdate' option active.

In the template where the numbering style is actually defined, the TAB tricks works fine.
Comment 5 Yury 2014-12-02 11:55:25 UTC
...forgot to add the numbering still looks as if being at level 1 !
Comment 6 Yury 2014-12-03 05:27:19 UTC
Unfortunately, I can't post the document in which this weirdness is definitely happeningm even after reboot. :)
I can only say this document might have been created from the 'default' template, and then had been changed with add-on "Template Chnager 1.2.5 by André Schnabel (andreschnabel@openoffice.org)" to refer to another (specific) template.
Comment 7 Cor Nouws 2014-12-03 09:38:31 UTC
Yuri, thanks for the updates, but maybe it's better to find peers at ask.libreoffice or users@ to discuss possibilities and details of documents.

In the mean time, IMO this bug report is simply valid and having it fixed would be great :)
Cor
Comment 8 Yury 2014-12-03 10:22:38 UTC
I'm just sort of piling on the evidence, to the end that the management of numbering styles needs serious looking into. My own specific problem I will solve myself, somehow.
Comment 9 Cor Nouws 2014-12-03 10:48:35 UTC
(In reply to Yury from comment #8)
> I'm just sort of piling on the evidence, to the end that the management of
> numbering styles needs serious looking into. 

Great. When possible, pls post a brief summary when finished.

> My own specific problem I will solve myself, somehow.
Comment 10 Regina Henschel 2017-07-02 00:37:07 UTC
With this tool the paragraph gets an outline level and a list level. You need to manually keep them in sync.
Comment 11 Justin L 2017-08-17 22:37:19 UTC
NOTABUG: As Regina notes in comment 10, outline levels and list levels are not the same thing.  The user's example is trying to equate the two. To make the document work as intended by design:
1.)  apply "Heading 4" paragraph style to paragraph 4.
2.)  apply "Custom" list style to paragraph 4.

In terms of being able to use a style OTHER than Heading 4 for the 4th level, that is possible under "Tools - Chapter numbering".  So in keeping with this example, you could re-assign level 4 to be paragraph style 'Text body'.

Basically, styles and list numbering are completely separate. Chapter numbering is a special feature designed to handle a specific use case.
Comment 12 Justin L 2017-08-18 01:09:35 UTC
(In reply to Justin L from comment #11)
> Basically, styles and list numbering are completely separate.

Just to clarify - in a paragraph style, you CAN assign the LIST-STYLE that will be used by default so in that way there is a connection, but nothing in the style affects the LEVEL that the list will be at.
Comment 13 Regina Henschel 2017-08-18 11:10:10 UTC
Building a chapter numbering via paragraph style (determine outline level and assign numbering style) is a valid way. Of cause you only need it, if you need a second chapter numbering range for e.g. an appendix. The problem is, that the UI does not provide an automatic changing of numbering level, if the outline level is changed. You need to adapt the numbering level manually. There exists already bug 62032 for that problem.

In theory a binding between level and style should be possible via conditional styles. But that is broken for outline levels; that is bug 108907.

*** This bug has been marked as a duplicate of bug 62032 ***