Download it now!
Bug 75748 - FILEOPEN: incorrect display of some numbering styles in .DOC and .DOCX
Summary: FILEOPEN: incorrect display of some numbering styles in .DOC and .DOCX
Status: RESOLVED DUPLICATE of bug 106541
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc, filter:docx
Depends on:
Blocks: DOCX-Bullet-Number-Outline-Lists DOC-Bullet-Number-Lists
  Show dependency treegraph
 
Reported: 2014-03-04 10:18 UTC by wabik
Modified: 2020-02-14 17:47 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Numeration styles broken (23.01 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-03-04 10:18 UTC, wabik
Details
MS Word version (275.33 KB, image/png)
2014-03-05 06:32 UTC, wabik
Details
LO version (280.46 KB, image/png)
2014-03-05 06:32 UTC, wabik
Details
Test docx (50.16 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-03-05 06:42 UTC, wabik
Details
DOC file saved from DOCX in MS Office 2003 (1.07 MB, application/msword)
2014-03-05 09:52 UTC, wabik
Details
DOC opened in LO (207.41 KB, image/png)
2014-03-05 09:56 UTC, wabik
Details
Test docx compared in MSO, OO, LO (210.15 KB, image/jpeg)
2015-10-06 09:34 UTC, Timur
Details
Test document saved as .doc in MSO 2010 (159.50 KB, application/vnd.ms-word)
2015-10-06 09:35 UTC, Timur
Details
Test document saved as .doc compared in MSO, OO, LO (250.20 KB, image/jpeg)
2015-10-06 09:37 UTC, Timur
Details
new screenshot in 5.2.3.3 and 5.3.0.0 alpha (155.83 KB, image/jpeg)
2016-11-10 05:44 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description wabik 2014-03-04 10:18:04 UTC
Created attachment 95083 [details]
Numeration styles broken

Document DOCX prepared in MS Office does not open properly in LO concerning the numeration styles.
Please look at the attached example.
Comment 1 tommy27 2014-03-05 05:14:08 UTC Comment hidden (obsolete)
Comment 2 wabik 2014-03-05 06:32:14 UTC Comment hidden (obsolete)
Comment 3 wabik 2014-03-05 06:32:53 UTC Comment hidden (obsolete)
Comment 4 wabik 2014-03-05 06:42:31 UTC Comment hidden (obsolete)
Comment 5 tommy27 2014-03-05 09:39:37 UTC
thanks for screnshots.
bug reproducible under WinXP 32bit with LibO 4.1.5.3

subnumbers like 1.2.1, 1.2.2, 1.2.3 etc. are not displayed in LibO which only shows 1.2 and 1.3 etc. numbers.

reworded sumamry notes

@wabik
could you please try saving the original document in .DOC format under MSO and tell if the numbering issue is present as well or just limited to the .DOCX format?
Comment 6 wabik 2014-03-05 09:52:22 UTC Comment hidden (obsolete)
Comment 7 wabik 2014-03-05 09:55:56 UTC
DOC opened in LO 4.2.2.1 is a complete mess :( No numbering at all and the file size is huge over 1MB ... See the attached DOC file and screen shot from LO
Comment 8 wabik 2014-03-05 09:56:36 UTC
Created attachment 95153 [details]
DOC opened in LO
Comment 9 tommy27 2014-03-05 10:14:59 UTC
I confirm issue on 4.1.5.3 with .doc format too and I confirm issue is even worse
Comment 10 wabik 2014-07-30 10:11:25 UTC Comment hidden (no-value)
Comment 11 tommy27 2014-07-30 20:39:50 UTC
bug still present in 4.3.0.4 and 4.4.0.0.alpha0+
Build ID: 9f803ee4b64e11e481ae9bf92ffac7cbf568675a
TinderBox: Win-x86@42, Branch:master, Time: 2014-07-28_06:27:11
Comment 12 Timur 2015-10-06 09:34:15 UTC
Created attachment 119336 [details]
Test docx compared in MSO, OO, LO

Test docx didn't show outline numbering from OO to LO 4.3. 
Then, LO 4.4 to 5.1+ shows some incorrect numberings.
Comment 13 Timur 2015-10-06 09:35:12 UTC
Created attachment 119337 [details]
Test document saved as .doc in MSO 2010
Comment 14 Timur 2015-10-06 09:37:14 UTC
Created attachment 119338 [details]
Test document saved as .doc compared in MSO, OO, LO

Test document saved as doc doesn't show outline numbering from OO to LO 5.1+.
Comment 15 QA Administrators 2016-11-08 11:24:30 UTC Comment hidden (obsolete)
Comment 16 tommy27 2016-11-10 05:44:58 UTC
Created attachment 128634 [details]
new screenshot in 5.2.3.3 and 5.3.0.0 alpha

bug still present but somehow evolved and improved.
we still not have the same formatting of MS Word but looks like some work has been done. check the new screenshot.
Comment 17 tommy27 2016-11-10 05:51:55 UTC Comment hidden (duplicate, no-value)
Comment 18 tommy27 2016-11-10 05:54:07 UTC Comment hidden (obsolete)
Comment 19 Justin L 2017-08-17 18:15:31 UTC Comment hidden (no-value)
Comment 20 Justin L 2017-10-17 19:17:50 UTC
Looks like a duplicate of bug 106541. Using that newer bug since that test document is very simple, and the bug report is clean.

*** This bug has been marked as a duplicate of bug 106541 ***
Comment 21 Timur 2020-02-14 17:47:12 UTC
DOCX is verified fine with 7.0+ and we'll see for DOC in duplicated bug.