Bug 106541 - FILEOPEN: Numbering from custom style based on Heading 1 is not considered in this DOC
Summary: FILEOPEN: Numbering from custom style based on Heading 1 is not considered in...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: interoperability target:7.3.0
Keywords: filter:doc
: 87053 129579 (view as bug list)
Depends on:
Blocks: DOC-Bullet-Number-Lists 123405
  Show dependency treegraph
 
Reported: 2017-03-15 00:01 UTC by Aron Budea
Modified: 2021-06-24 05:17 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample DOCX (18.71 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-03-15 00:01 UTC, Aron Budea
Details
Sample DOC (same as DOCX) (31.00 KB, application/msword)
2017-03-15 00:02 UTC, Aron Budea
Details
Screenshot comparing Writer and Word (DOCX sample) (54.53 KB, image/png)
2017-03-15 00:03 UTC, Aron Budea
Details
tdf106541.diff: patch that adds re-numbering to inheriting style (3.49 KB, patch)
2018-02-13 04:53 UTC, Justin L
Details
Screenshot comparing Writer and Word (DOC sample) (24.23 KB, image/png)
2020-02-14 17:08 UTC, Timur
Details
Appendices DOC (137.00 KB, application/msword)
2020-02-14 17:43 UTC, Timur
Details
Appendices DOC compared MSO 2013 LO 7.0+ (50.78 KB, image/png)
2020-02-14 17:43 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2017-03-15 00:01:29 UTC Comment hidden (obsolete)
Comment 1 Aron Budea 2017-03-15 00:02:18 UTC
Created attachment 131892 [details]
Sample DOC (same as DOCX)
Comment 2 Aron Budea 2017-03-15 00:03:51 UTC Comment hidden (obsolete)
Comment 3 Xisco Faulí 2017-03-15 01:19:30 UTC
Confirmed in

Version: 5.4.0.0.alpha0+
Build ID: d3b5bd4a07a619db6bee1c39c32280ac3c620532
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 4 Justin L 2017-10-17 19:17:50 UTC
*** Bug 75748 has been marked as a duplicate of this bug. ***
Comment 5 Timur 2018-01-19 10:06:44 UTC
MSO shows this "TOC Level 1" style is based on "Heading 1" but it's style Numbering is None, while Numbering is set. 
Result is " Based on: Heading 1;H1;R1;TOC 11;1;h1;section;Header 1;II+;I;1st level;..."
LO has 2 issues: doesn't recognize it's "1st level" outline nor "1." numbering style.
If Numbering style is set in MSO, it's shown in LO, while outline level is still wrong.
Comment 6 Commit Notification 2018-02-13 04:34:40 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ed8221aa0b1550834f8ca18ca3af21f2a41e678d

tdf#106541 preventative unit test: don't force inheritance

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Justin L 2018-02-13 04:53:43 UTC Comment hidden (obsolete, writerfilter)
Comment 8 QA Administrators 2019-02-14 03:49:26 UTC Comment hidden (obsolete)
Comment 9 Timur 2019-09-06 10:02:11 UTC Comment hidden (obsolete)
Comment 10 László Németh 2020-02-13 08:24:47 UTC
Removed DOCX part (it was solved in Bug 95495).
Comment 11 Timur 2020-02-14 17:08:38 UTC
Created attachment 157878 [details]
Screenshot comparing Writer and Word (DOC sample)

Repro 7.0+ for sample DOC.
Comment 12 Timur 2020-02-14 17:43:27 UTC
Created attachment 157879 [details]
Appendices DOC

Since this is now DOC bug, I add DOC version of attachment 126453 [details] DOCX from bug 95495. Saved in MSO 2013.
Comment 13 Timur 2020-02-14 17:43:57 UTC
Created attachment 157880 [details]
Appendices DOC compared MSO 2013 LO 7.0+
Comment 14 Buovjaga 2020-04-24 06:41:28 UTC
*** Bug 87053 has been marked as a duplicate of this bug. ***
Comment 15 Justin L 2021-03-17 08:37:44 UTC Comment hidden (obsolete)
Comment 16 Justin L 2021-04-21 17:17:21 UTC Comment hidden (obsolete)
Comment 17 Commit Notification 2021-04-22 12:02:30 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/75213d163b53e7002404c26fcd9cd63776a53eae

tdf#106541 doc import numbering: pre-emptive inheritance unit test

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Justin L 2021-04-22 12:03:54 UTC
I have rough patches for this at https://gerrit.libreoffice.org/q/tdf%2523106541,
but I don't intend to merge them until 7.3 master.
Comment 19 Commit Notification 2021-04-23 05:39:15 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/38a01322a5e02432965f5a619124a6966bab065f

tdf#106541 doc import numbering: default nListLevel to MAXLEVEL

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Aron Budea 2021-04-25 20:27:04 UTC
*** Bug 129579 has been marked as a duplicate of this bug. ***
Comment 21 Commit Notification 2021-06-19 17:59:40 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ce762a7ab170aa1115cfb0dd68f1c50abf5a86f3

tdf#106541 doc import: inherit style numbering from parent

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2021-06-21 04:04:47 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/10dbee56f7cf9a19b04f484b8a4b2465323ec622

tdf#106541 doc import: always register listLevel

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 23 Commit Notification 2021-06-22 16:00:25 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ce20614b630e50fbfcc82e4cd2f565b04dfb788e

tdf#106541 doc import: prevent inheriting when LFO == 0

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 Commit Notification 2021-06-23 16:50:32 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/8d248914f13b3b665431c70f0192fa967e0b7717

tdf#106541 doc import: allow listLevel to be inherited

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 25 Justin L 2021-06-24 04:13:46 UTC
Also see additional facets to this DOC series of patches in bug 123405 and more importantly in bug 104239.

I have no intention of backporting any of this. It needs a lot of QA review.

A similar set of patches is going into DOCX. See bug 141966 and bug 141964 which it depends on.
Comment 26 Justin L 2021-06-24 05:17:01 UTC
comment 1: numbering.doc: good. [Chapter Numbering is basically empty - same as in 7.1.]

comment4: 75748 test1 MS2010.doc: not yet fully fixed. [Actually a duplicate of bug 104239 now.]

comment 12: 95495 Windows PowerShell - APPENDICES MSO.doc: good.

comment 14: simple-template.doc: 

comment 20: test_docx_filter_multilevel_numbering.doc: good.