Download it now!
Bug 95495 - Fileopen: List levels not recognized in .docx custom outline numbering
Summary: Fileopen: List levels not recognized in .docx custom outline numbering
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Szabolcs Toth
URL:
Whiteboard: target:7.0.0 target:6.4.2
Keywords: filter:docx
: 129531 (view as bug list)
Depends on:
Blocks: DOCX-Bullet-Number-Outline-Lists
  Show dependency treegraph
 
Reported: 2015-11-01 15:31 UTC by Paul
Modified: 2020-05-18 17:25 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Failing document (538.51 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-11-01 15:31 UTC, Paul
Details
Failing document - reduced (132.86 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-07-28 17:02 UTC, Timur
Details
Screenshot of the example document in LO 6.4 and Word (109.81 KB, image/png)
2019-09-17 12:17 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul 2015-11-01 15:31:07 UTC
Created attachment 120162 [details]
Failing document

When opening the attached file, "Windows PowerShell Language Specification Version 3.0.docx", The appendix on Grammar has quite different outline labels.

=== Microsoft Office Word 2007

B. Grammar
This appendix contains summaries of the lexical and syntactic grammars found in the main document.
B.1 Lexical grammar
input:
input-elementsopt   signature-blockopt
input-elements:
input-element
input-elements   input-element
input-element:

=== LibreOffice Writer

O. Grammar
P. This appendix contains summaries of the lexical and syntactic grammars found in the main document.
Q. Lexical grammar
R. input:
input-elementsopt   signature-blockopt
S. input-elements:
input-element
input-elements   input-element
T. input-element:
Comment 1 MM 2015-11-01 16:52:46 UTC
Confirmed with v4.4.6.3 under windows 7 x64.
Confirmed with v3.3.4 under windows 7 x64.
Confirmed with v5.0.3.2 under mint 17.2 x64.
Comment 2 Paul 2016-07-18 02:25:57 UTC
Confirmed with 5.1.4.2 (x64) under Microsoft Windows [Version 10.0.10586]
Comment 3 Timur 2016-07-28 17:02:21 UTC
Created attachment 126453 [details]
Failing document - reduced

Looks like custom numbering in the multilevel list. 
Easier to see on the reduced document. Even shorther, it's like this:

 === Microsoft Word 
A. Comment-Based Help
A.1 Introduction
A.2 Help directives
A.2.1 .DESCRIPTION
... Section-Break (Next Page)
B. Grammar
B.1 Lexical grammar
C. References

=== LibreOffice Writer
A. Comment-Based Help
B. Introduction
C. Help directives
D. .DESCRIPTION
... Page Break
E. Grammar
F. Lexical grammar
G. References
Comment 4 QA Administrators 2019-01-20 03:47:09 UTC Comment hidden (obsolete)
Comment 5 Roman Kuznetsov 2019-01-20 17:51:39 UTC
still wrong in

Version: 6.3.0.0.alpha0+ (x64)
Build ID: eca59b6b8a0cf826ac59f77aec9acf045340c23f
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-01-16_03:48:12
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 6 Paul 2019-01-21 19:00:57 UTC Comment hidden (obsolete)
Comment 7 Timur 2019-09-06 12:45:57 UTC
Paul, thank you for following your bug. But we test with master version from https://dev-builds.libreoffice.org/daily/master/ or using SI-GUI program. Current master is 6.4 and we may use + to indicate it. 
Repro with 6.4+.
Comment 8 Xisco Faulí 2019-09-11 13:24:29 UTC
Don't see why it should be a high severity bug. Reported in 2016 and inherit from OOo
Comment 9 Gabor Kelemen 2019-09-17 12:17:15 UTC
Created attachment 154223 [details]
Screenshot of the example document in LO 6.4 and Word

Still present in

Verzió: 6.4.0.0.alpha0+ (x64)
Build az.: 4883da6fd25e4645a3b30cb58212a2f666dae75a
CPU szálak: 8; OS: Windows 10.0; Felületmegjelenítés: GL; VCL: win; 
Területi beállítások: hu-HU (hu_HU); Felület nyelve: hu-HU
Calc: CL
Comment 10 László Németh 2020-02-13 07:49:52 UTC
*** Bug 129531 has been marked as a duplicate of this bug. ***
Comment 11 Commit Notification 2020-02-13 08:38:43 UTC
Szabolcs Toth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/125dd0be473d15681049814c3982f1ae2c66660f

tdf#95495 DOCX import: fix inherited list level of custom styles

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Timur 2020-02-14 17:35:55 UTC
Verified for DOCX:
attachment 120162 [details] and attachment 126453 [details] from this bug 
attachment 102915 [details] from duplicated bug 129531 
attachment 131891 [details] from bug 106541 (that's left for DOC)
attachment 106541 from bug 75748

Great this was fixed.
Szabolcs, thanks and please always comment on a plan to backport.
Comment 13 Xisco Faulí 2020-02-14 17:40:39 UTC
(In reply to Timur from comment #12)
> Verified for DOCX:
> attachment 120162 [details] and attachment 126453 [details] from this bug 
> attachment 102915 [details] from duplicated bug 129531 
> attachment 131891 [details] from bug 106541 (that's left for DOC)
> attachment 106541 from bug 75748
> 
> Great this was fixed.
> Szabolcs, thanks and please always comment on a plan to backport.

backport? why ?
Comment 14 Szabolcs Toth 2020-02-17 13:48:57 UTC
Thanks a lot Timur.

So, to backport or not to backport?
Comment 15 Xisco Faulí 2020-02-17 14:00:33 UTC
I'd prefer not to backport it. it's not a regression not a highest/high priority bug. Besides, inherit from OOo bug, thus better to wait for next major release and have more time to test it. My 2 cents
Comment 16 Timur 2020-02-18 12:06:05 UTC
Since I asked, and thank you for your inquiry ,here is a response, not insisting on this one, but giving general explanation.

My view is that any bug fix should be considered for backport. 
Best practice is that a developer makes a comment during the initial commit "I will backport to Fresh (and Still)" or "Will not backport (because..)", accessing potential impact. So avoiding questions and discussion.
Long-time devs do both regularly.

Reason is to have fix sooner, because current version will take a ti to coe to Fresh and a lot of time to come to X.Y.last of Still, which is a preferred version in deployments.
And to have more people test Fresh while fix is hot.
I don't think that "inherited from OO" is a reason not to do backport or not to consider a bug a bigger deal.
I personally much value those, as a big step forward.

Anyway, all this is just my opinion. 
But I think there should be a "backport" link and policy determined by ESC and explained at https://wiki.documentfoundation.org/Development.
Comment 17 Szabolcs Toth 2020-02-19 07:45:40 UTC
Thank you for your thoughts.

After considering both of your responses, I consulted my team and we decided to backport the fix. Main reason is: this bug has a few duplicates.
Comment 18 Xisco Faulí 2020-02-19 09:37:10 UTC
(In reply to Szabolcs Toth from comment #17)
> Thank you for your thoughts.
> 
> After considering both of your responses, I consulted my team and we decided
> to backport the fix. Main reason is: this bug has a few duplicates.

fair enough!
Comment 19 Xisco Faulí 2020-02-19 10:04:07 UTC
(In reply to Timur from comment #16)
> Since I asked, and thank you for your inquiry ,here is a response, not
> insisting on this one, but giving general explanation.
> 
> My view is that any bug fix should be considered for backport. 
> Best practice is that a developer makes a comment during the initial commit
> "I will backport to Fresh (and Still)" or "Will not backport (because..)",
> accessing potential impact. So avoiding questions and discussion.
> Long-time devs do both regularly.
> 
> Reason is to have fix sooner, because current version will take a ti to coe
> to Fresh and a lot of time to come to X.Y.last of Still, which is a
> preferred version in deployments.

I do agree, in fact, I backported most of the the fixes between the branch off and the first RC1. the problem at this point it: we backport it now, it makes it to the next minor release ( 6.4.2 to be released on week 12 ). if the fix caused a regression, it would take at least 1 months ( in the best case scenario ) to be reported, triaged, fixed and backported, which makes it too late to be backported to 6.4.3. Finally, it makes it to 6.4.4 which is already a still version. what happens if the second fix introduced a second regression at this point ?

> And to have more people test Fresh while fix is hot.
> I don't think that "inherited from OO" is a reason not to do backport or not
> to consider a bug a bigger deal.

My point was: it's inherit from OOo, any user having this issue has had it for years, I don't think it's a problem for this user to wait a few more months...

> I personally much value those, as a big step forward.
> 
> Anyway, all this is just my opinion. 
> But I think there should be a "backport" link and policy determined by ESC
> and explained at https://wiki.documentfoundation.org/Development.

Yes, I agree, it should be better explained in the wiki. I can create a draft and then propose it in the ESC meeting
Comment 20 Commit Notification 2020-02-21 16:17:03 UTC
Szabolcs Toth committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/7c339186b4b41ce22229a591cb8fb14ec3120567

tdf#95495 DOCX import: fix inherited list level of custom styles

It will be available in 6.4.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2020-05-18 17:25:03 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c50315c55dbb5daf86ccb2a91468c05a53e926e9

tdf#95495 ooxmlexport3: less implementation-specific unit test

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.