Bug 129579 - Level not recognized correctly in multi-level numbered paragraph imported from MS Word
Summary: Level not recognized correctly in multi-level numbered paragraph imported fro...
Status: RESOLVED DUPLICATE of bug 106541
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: DOCX-Bullet-Number-Outline-Lists DOC-Bullet-Number-Lists
  Show dependency treegraph
 
Reported: 2019-12-23 12:20 UTC by Tomáš Hajný
Modified: 2021-06-24 16:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Test file in .DOCX format allowing to reproduce the issue (46.00 KB, application/msword)
2019-12-23 12:21 UTC, Tomáš Hajný
Details
Screenshot from MS Word displaying the test file (161.28 KB, image/png)
2019-12-23 12:22 UTC, Tomáš Hajný
Details
Screenshot from LO Writer 6.2.8.2 displaying the test file (125.95 KB, image/png)
2019-12-23 12:23 UTC, Tomáš Hajný
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomáš Hajný 2019-12-23 12:20:07 UTC
See attached test file in format .DOCX plus screenshots from MS Word (version 2010) and LibreOffice 6.2.8.2 (I tried LO 6.3.4.2 as well and the issue is reproducible there as well). The same problem exists if saving the test file to .DOC in MS Word and opening this .DOC in LibreOffice.

Note that the dialog window displayed in the screenshot from MS Word shows the information related to "Chapter 1, level 2" (unlike LO Writer, MS Word doesn't keep highlighting the selection when opening the numbering and indentation formatting dialog box, but exactly the same content was selected as on the screenshot from LO). As visible there, MS Word shows correctly that the paragraph is at level 2, whereas LO Writer shows level 1 (as observed from the paragraph numbers in the text as well).
Comment 1 Tomáš Hajný 2019-12-23 12:21:50 UTC
Created attachment 156751 [details]
Test file in .DOCX format allowing to reproduce the issue
Comment 2 Tomáš Hajný 2019-12-23 12:22:54 UTC
Created attachment 156752 [details]
Screenshot from MS Word displaying the test file
Comment 3 Tomáš Hajný 2019-12-23 12:23:44 UTC
Created attachment 156753 [details]
Screenshot from LO Writer 6.2.8.2 displaying the test file
Comment 4 Timur 2019-12-24 10:35:02 UTC
I confirm the bug with LO master 6.5+.
There are similar ones like bug 95495 or bug 129531 so this is probably a duplicate. But, we may keep it until confirmed.
Comment 5 Timur 2019-12-24 12:02:22 UTC
Numbers weren't there before, but in 4.2 and 4.3 they appeared fine.
And since LO 4.4 they are wrong as in 6.5+. So I set regression.
Comment 6 Xisco Faulí 2019-12-27 16:28:45 UTC
Regression introduced by https://cgit.freedesktop.org/libreoffice/core/commit/?id=c99f264be5eaf481f88606e2606c34170675c1b4 which is already reported in bug 94326

*** This bug has been marked as a duplicate of bug 94326 ***
Comment 7 Justin L 2021-03-17 08:37:44 UTC
bug 106541 seems like a better duplicate.
This bug focuses on inheriting from a heading style and that is likely the problem since the level of the heading isn't inherited/used.

*** This bug has been marked as a duplicate of bug 106541 ***
Comment 8 Justin L 2021-04-19 12:43:57 UTC
Not a duplicate. test_docx_filter_multilevel_numbering.doc has a different problem from  bug 94326 - an inheritance problem. It inherits from Heading 2. So in Word it would be at level 2, but in Writer, there is no level inheritance from "Chapter Numbering" styles - so in this case a  special effort would need to be made to copy the OutlineLvl setting from the parent style, I think.
Comment 9 Justin L 2021-04-21 17:17:21 UTC
Ahh!  I'm being careless. This is not a duplicate of bug 94326, but that was already identified in a prior comment.

*** This bug has been marked as a duplicate of bug 106541 ***
Comment 10 Tomáš Hajný 2021-04-25 20:20:43 UTC
Since this issue was marked as duplicate of bug #106541 and that was marked as resolved in master, I tried opening the attached test file in the today's (April 25) daily snapshot. Unfortunately, the bug reported in this ticket and reproducible with the test file attached here is _not_ fixed. Please, note that the issue is apparently restricted to the .doc format now - when I reported it back in 2019 for LO 6.2.8.2, the issue was reproducible with both .docx and .doc formats, but this isn't the case any longer. However, this isn't due to the patch provided for ticket #106541, because I cannot reproduce it for .docx format with 7.0.4.2 either (unlike for .doc).
Comment 11 Aron Budea 2021-04-25 20:27:04 UTC
(In reply to Tomáš Hajný from comment #10)
> Since this issue was marked as duplicate of bug #106541 and that was marked
> as resolved in master, I tried opening the attached test file in the today's
Thanks for retesting! Please note bug 106541 comment 18. Since there are still unmerged patches that won't be merged for another month (until version 7.2 branches off), and bug 106541 isn't closed yet as fixed, let's wait until those happen. Feel free to reopen if the bug still occurs afterwards.

*** This bug has been marked as a duplicate of bug 106541 ***
Comment 12 Justin L 2021-06-24 05:20:06 UTC
(In reply to Tomáš Hajný from comment #10)
> Since this issue was marked as duplicate of bug 106541
This bug was fully fixed yesterday, so you should be able to re-test with today's daily build.
Comment 13 Tomáš Hajný 2021-06-24 16:54:39 UTC
I can confirm, that the issue has been resolved in the daily build, thank you!