Download it now!
Bug 94819 - Fileopen: outline numbering not continued in docx
Summary: Fileopen: outline numbering not continued in docx
Status: RESOLVED DUPLICATE of bug 95848
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other All
: low normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Bullet-Number-Outline-Lists
  Show dependency treegraph
 
Reported: 2015-10-06 10:02 UTC by Timur
Modified: 2019-09-10 10:13 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Numbering simplified (36.42 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-08-02 16:20 UTC, Timur
Details
Numbering sample compared (105.09 KB, image/png)
2019-09-06 08:21 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2015-10-06 10:02:49 UTC
When opening attachment 115706 [details] in Bug 91384, some outline numbering is not continued, but rather restarted, for example "Fragebogen und Planausschnitte" instead of being 4 starts from 1, etc.
As noted by Oliver Specht: The .docx uses the same "<w:numId w:val="1"/>" while the .odt applies WWNum17 to the first headings while the next use WWNum1
Comment 1 Buovjaga 2015-10-08 12:24:38 UTC
Confirmed Fragebogen und Planausschnitte on page 5.
One might actually see the numbering be 4. for a short moment before it changes to 1.
This happened when I quickly used find to jump to it.

Win 7 Pro 64-bit, Version: 5.0.2.2 (x64)
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: fi-FI (fi_FI)

Version: 5.1.0.0.alpha1+
Build ID: f830600ece806ec365a4839e79afabe183c5e36d
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-06_22:49:09
Locale: en-US (fi_FI)
Comment 2 Timur 2016-08-02 16:20:50 UTC
Created attachment 126520 [details]
Numbering simplified

<w:p w:rsidR="00636BB0" w:rsidRPr="005B7848" w:rsidRDefault="00636BB0" w:rsidP="00636BB0">
<w:t>Gegenüberstellung Übersichtsplan Basisplan - OK</w:t>
<w:p w:rsidR="00636BB0" w:rsidRPr="005B7848" w:rsidRDefault="00636BB0" w:rsidP="00636BB0">
<w:t>Zie dieser Umfrage - OK</w:t>
<w:p w:rsidR="003A179A" w:rsidRPr="005B7848" w:rsidRDefault="003A179A" w:rsidP="003A179A">
<w:t>Fragebogen und Planausschnitte - NOK</w:t>
<w:p w:rsidR="00E6486D" w:rsidRPr="006A1AFF" w:rsidRDefault="006A1AFF" w:rsidP="00351B36">
<w:t>Kontakt - OK</w:t>

Looks like Bug 95848 is a duplicate.
Comment 3 Timur 2018-01-19 10:56:26 UTC
In MSO we see that Heading 1 is based on "BVE Fett" style. 
In LO Heading 1 inherits from "None".
Can't say if it's relevant to numbering, seems not.
Comment 4 Justin L 2018-02-13 05:36:01 UTC
This is a challenging bug. The problem is that for unidentified reasons,  PROP_NUMBERING_RULES are written directly into the paragraph. But there are no identifying marks on PROP_NUMBERING_RULES - so it is impossible to tell whether they came from numId=1/WWNum1 and thus whether one or the other is redundant.

This is complicated by the fact that Heading X is treated differently by LO - a secret "Outline" list style is used by Tools->Chapter Numbering which on docx import can only be associated with Heading X.

I think that PROP_NUMBERING_RULES ought to be replaced by PROP_NUMBERING_STYLE_NAME in most cases. Attempting this led to a lot of failed unit tests however.  PROP_NUMBERING_RULES existed already in OOo.
Comment 5 QA Administrators 2019-02-14 03:49:46 UTC Comment hidden (obsolete)
Comment 6 Timur 2019-09-06 08:21:30 UTC
Created attachment 153977 [details]
Numbering sample compared

Fixed
Comment 7 Timur 2019-09-06 08:21:42 UTC

*** This bug has been marked as a duplicate of bug 95848 ***