Bug Hunting Session
Bug 86926 - FILEOPEN: DOCX - page size/dimensions/format ignored
Summary: FILEOPEN: DOCX - page size/dimensions/format ignored
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: All All
: high major
Assignee: Justin L
URL:
Whiteboard: interoperability target:5.3.0 target:...
Keywords: bibisected, bisected, filter:docx, regression
: 101568 (view as bug list)
Depends on:
Blocks: DOCX Page
  Show dependency treegraph
 
Reported: 2014-12-02 09:43 UTC by Juang Dse
Modified: 2017-05-18 18:19 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Juang Dse 2014-12-02 09:43:56 UTC
- create a new file, perhaps write some text.
- modify page format, e.g. A4 -> A3
- save as .docx.
- close and reopen LO.
- format is A4.
Comment 1 raal 2014-12-10 14:38:23 UTC
I can confirm wit LO 4.3.4.1, win7. Proble is in file read because word can read A3 property in file.
Comment 2 QA Administrators 2015-12-20 16:17:10 UTC Comment hidden (obsolete)
Comment 3 Juang Dse 2015-12-21 09:02:30 UTC
bug still present in 5.0.4.2 / Linux x86_64.
Comment 4 Joel Madero 2016-01-03 17:33:00 UTC
Bumping this:
Major - I'd say that page size is major functionality, not retaining it plus this being a regression major seems appropriate.
High - default for major bugs.


What's strange is the issue doesn't appear at all in bibisect package (35all). I've confirmed the issue on 5.2 dev build, also confirmed it's a regression (problem doesn't exist in 3.3) yet I can't get a bibisect package to show the bug.

Requesting bibisect expert's advise here.
Comment 5 raal 2016-01-15 13:57:53 UTC
correcting keyword
Comment 6 Michael Weghorn 2016-08-12 21:16:45 UTC
Bibisect result, using the "bibisect-43all" repository:

55ada127406ba21ae3f9175f96f62b18646527d6 is the first bad commit
commit 55ada127406ba21ae3f9175f96f62b18646527d6
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Thu Apr 26 18:51:33 2012 +0200

    source-hash-0a8596dd8ebbbc80e87d4bdfafe3cf53355b7d43
    
    commit 0a8596dd8ebbbc80e87d4bdfafe3cf53355b7d43
    Author:     Fridrich Štrba <fridrich.strba@bluewin.ch>
    AuthorDate: Thu Mar 22 14:46:02 2012 +0100
    Commit:     Fridrich Štrba <fridrich.strba@bluewin.ch>
    CommitDate: Thu Mar 22 14:47:06 2012 +0100
    
        Revert "fix debug build"
    
        This reverts commit 0589dd3fb5c5bf2fdcdbccfab31fbe26c0a9727d.
    
        Given the find above, this assert will never be triggered anyway

:100644 100644 09b185b44d24949130a35fff7790bed6dd31e027 ee476730ef68b2e109c3376e843f2d07a9878936 M	autogen.log
:100644 100644 84687229596d9065f137d8035183a6fef9b814aa 1c009e9aa03b50cbee0a67eb5bb59f2915ce3729 M	ccache.log
:100644 100644 d176b5b76e6ab6ac43ed9bd0e2d639cae069fa9e 14f96dc765d5d3bcb6ddddb459542bf93d089698 M	commitmsg
:100644 100644 a073ac8fcb7999e9515e46aff5478b95012467d1 33a0a7a1e03267cb9456d3a7cb36d04213dcd98c M	dev-install.log
:100644 100644 b1cdb43d8174226b023134dfb382edc31baf0372 cb83f1ba72ccf211eefa318227fe0c7f7eb924a4 M	make.log
:040000 040000 064e8dca936585df8564dac25865691ad0b06401 040d6661f6de6bc4e057c0a31d52b31bdacffc5d M	opt


---

$ git bisect log
# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# bad: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect bad e02439a3d6297a1f5334fa558ddec5ef4212c574
# bad: [8f4aeaad2f65d656328a451154142bb82efa4327] source-hash-1885266f274575327cdeee9852945a3e91f32f15
git bisect bad 8f4aeaad2f65d656328a451154142bb82efa4327
# bad: [369369915d3582924b3d01c9b01167268ed38f3b] source-hash-45295f3cdceb4c289553791071b5d7f4962d2ec4
git bisect bad 369369915d3582924b3d01c9b01167268ed38f3b
# good: [351622aec2dff3cc3bbbb020ad0097c4322d2a21] source-hash-2c4537471c932b65e6f72e41881b505c4bbad12c
git bisect good 351622aec2dff3cc3bbbb020ad0097c4322d2a21
# good: [378efb6e51212a05d1bd4b85c916eec5753c1744] source-hash-d453788ac0476cc02b929b0907718ca771d6d956
git bisect good 378efb6e51212a05d1bd4b85c916eec5753c1744
# good: [6fb876793ee949d0a22a542f7782be301d67ebb4] source-hash-4171bfefa788f539cf1f1ef327586e4319722b02
git bisect good 6fb876793ee949d0a22a542f7782be301d67ebb4
# good: [07963512e1ce0b4d7f3a9baab88fc00036df2903] source-hash-cf1e9315aae7c1c67f795aa9e4f0ea724303cd9a
git bisect good 07963512e1ce0b4d7f3a9baab88fc00036df2903
# bad: [67914732398be551fcfc6afcb4787711bac493e1] source-hash-c0a99301f5d854cad8baeaca798549424937598d
git bisect bad 67914732398be551fcfc6afcb4787711bac493e1
# bad: [55ada127406ba21ae3f9175f96f62b18646527d6] source-hash-0a8596dd8ebbbc80e87d4bdfafe3cf53355b7d43
git bisect bad 55ada127406ba21ae3f9175f96f62b18646527d6
# good: [3e99d5d862f2be5e9a7ca8ccfd4db29fa6693146] source-hash-3daf8164323a3ccf3365d433ad5706ff3f6c470c
git bisect good 3e99d5d862f2be5e9a7ca8ccfd4db29fa6693146
# first bad commit: [55ada127406ba21ae3f9175f96f62b18646527d6] source-hash-0a8596dd8ebbbc80e87d4bdfafe3cf53355b7d43
Comment 7 Yousuf Philips (jay) (retired) 2016-08-18 20:22:01 UTC
*** Bug 101568 has been marked as a duplicate of this bug. ***
Comment 8 Cor Nouws 2016-08-22 10:37:41 UTC
confirmed with daily 290160816 ..
Comment 9 Justin L 2016-09-09 07:26:54 UTC
commit causing the regression:
author	Michael Stahl <mstahl@redhat.com>	2012-03-21 09:37:46 (GMT)
commit	cc99bb9f383a65912d004e227a5b6a88b401bbba (patch)

writerfilter: PropertyMap: speed this up a bit
Using XMultiPropertySet reduces the number of SwTxtNodes created for the
bugdoc from rhbz#789022 from ~5k to ~3k.

which now looks like:
    if (xMultiSet.is())
    {
        try
        {
            xMultiSet->setPropertyValues(comphelper::containerToSequence(vNames), comphelper::containerToSequence(vValues));
        }
        catch( const uno::Exception& )
        {
            OSL_FAIL( "Exception in SectionPropertyMap::ApplyProperties_");
        }
        return;
    }
Comment 10 Yousuf Philips (jay) (retired) 2016-09-09 07:53:56 UTC
@Michael: Your patch cc99bb9f383a65912d004e227a5b6a88b401bbba was identified related to this regression. Any thoughts?
Comment 11 Commit Notification 2016-09-09 12:59:42 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bdd4a238a1d8a0cbbebbd759011050659668f92b

tdf#86926 writerfilter allow fallback if exceptions

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2016-09-12 06:49:56 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c97f1aff7077959e65852f65e3217e5dffd262ce&h=libreoffice-5-2

tdf#86926 writerfilter allow fallback if exceptions

It will be available in 5.2.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2016-09-12 09:58:49 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3943147ab341f1e4d1c6db34405010085488b0b1

tdf#86926 writerfilter prevent PROP_GRID_LINES exception

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.