Bug 86928 - Calc warns of macros, but there are no macros in the XLS
Summary: Calc warns of macros, but there are no macros in the XLS
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: Other All
: low normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xls
Depends on:
Blocks: XLS
  Show dependency treegraph
 
Reported: 2014-12-02 10:07 UTC by Roman Polach
Modified: 2019-03-23 14:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
XLS causing the problem when open (247.00 KB, application/vnd.ms-excel)
2014-12-02 10:07 UTC, Roman Polach
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Polach 2014-12-02 10:07:21 UTC
Created attachment 110352 [details]
XLS causing the problem when open

Attached XLS document does NOT contain any macro, but it contains
an empty structure for macros. There is no danger from that,
but Calc 4.3.3 (.2-final) warns and asks for enabling/disabling
macros every time the file is opened.

There was no such problem in 4.1.4 or 4.2.0 versions of LO.
There was similar problem in 4.0.0-4.1.3 - see bug 61059.

Attaching the XLS document which causes problem in 4.3.3.2.
Comment 1 Roman Polach 2014-12-02 10:10:32 UTC Comment hidden (obsolete)
Comment 2 Roman Polach 2014-12-02 10:11:20 UTC Comment hidden (obsolete)
Comment 3 Roman Polach 2014-12-02 10:12:48 UTC Comment hidden (obsolete)
Comment 4 Roman Polach 2014-12-02 11:02:06 UTC Comment hidden (obsolete)
Comment 5 raal 2014-12-02 20:50:21 UTC
 Markus Mohrhard 2014-12-01 02:21:45 UTC comment 18 in bug 61059
The new problem is totally different as the VBAProject is actually no longer empty after some other fixes. We import more data now which results in the old check not being enough. However I'm not sure if there is an easy fix for this problem and if we want to fix it.

Setting as NEW.

Markus,
if we don't want to fix it, please set another status.
Comment 6 m.a.riosv 2015-02-09 21:01:58 UTC
*** Bug 89269 has been marked as a duplicate of this bug. ***
Comment 7 Roman Polach 2015-04-22 12:06:11 UTC
Still the problem in LO 4.4.3.1.
Annoying.
Comment 8 Roman Polach 2015-05-11 15:55:26 UTC
Problem is still present in LO 4.4.3 final.
Comment 9 Roman Polach 2015-05-25 12:08:32 UTC
The problem is still present in 5.0.0.0beta1.
Comment 10 Roman Polach 2015-07-01 14:29:01 UTC
This annoying problem is still present in LO 4.4.4 final.
Comment 11 Roman Polach 2015-08-04 13:34:49 UTC
Problem is still present in LO 4.4.5 final.
Comment 12 Roman Polach 2015-08-05 14:12:44 UTC
This regression bug is still present in LO 5.0.0 final.
Comment 13 QA Administrators 2016-09-20 10:20:44 UTC Comment hidden (obsolete)
Comment 14 Roman Polach 2016-09-21 06:55:35 UTC
Yes, the problem is still present
in latest version.
Tested on attachment 110352 [details] with
LibreOffice Calc 5.2.1.2.
Comment 15 Xisco Faulí 2017-09-29 08:48:28 UTC Comment hidden (obsolete)
Comment 16 Roman Polach 2017-10-10 08:49:14 UTC
The problem is still present in 5.3.6.1 (Windows; x64)
Comment 17 Roman Polach 2017-10-10 09:10:46 UTC
The problem is also present in 5.4.2.2 (Windows; x64)
Comment 18 QA Administrators 2018-10-11 03:03:04 UTC Comment hidden (obsolete)
Comment 19 Roman Kuznetsov 2019-03-23 14:35:41 UTC
still repro in

Version: 6.3.0.0.alpha0+ (x64)
Build ID: de024e572dd7a588f82b84c68daa2051ec6b20e9
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-03-18_01:13:57
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded