Download it now!
Bug 87440 - SVG import/render not handling line markers correctly
Summary: SVG import/render not handling line markers correctly
Status: CLOSED DUPLICATE of bug 47446
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:svg
Depends on:
Blocks: SVG-Import
  Show dependency treegraph
 
Reported: 2014-12-18 12:16 UTC by rogern
Modified: 2016-02-23 16:47 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Line with dot and arrow markers (2.90 KB, image/svg+xml)
2014-12-18 12:16 UTC, rogern
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rogern 2014-12-18 12:16:31 UTC
Created attachment 110984 [details]
Line with dot and arrow markers

Importing the attached SVG file from Inkscape, which contains a line with dot and arrow markers, into Writer (or other component) results in the right-hand arrow on the line missing and the left hand filled dot being rendered as an open circle. PDF export displays the same fault.

4.2.x rendered the markers correctly.
Comment 1 Robinson Tryon (qubit) 2014-12-24 04:49:06 UTC
Comment on attachment 110984 [details]
Line with dot and arrow markers

Fix mimetype
Comment 2 Robinson Tryon (qubit) 2014-12-24 05:05:20 UTC
(In reply to rogern from comment #0)
> Importing the attached SVG file from Inkscape, which contains a line with
> dot and arrow markers, into Writer (or other component) results in the
> right-hand arrow on the line missing and the left hand filled dot being
> rendered as an open circle. PDF export displays the same fault.
> 
> 4.2.x rendered the markers correctly.

(Testing with Ubuntu 14.04 and attachment 110984 [details])

In Firefox 34: Appears as a horizontal line segment, with a filled dot on the left end, and a right-facing arrow on the right end.

In Inkscape 0.48: Same as Firefox

In LO 4.4.0.1 (Draw): Appears as a horizontal line segment (nothing special on either end)
In LO 4.4.0.1 (Writer): Open circle on the left (with line extending into the center), and nothing on the right

In LO 4.2.6.3 (Draw and Writer): Same as in LO 4.4.0.1

The rendering in LO has never been great, and I don't see a regression. But it's still a bug that needs to get fixed.

Status -> NEW
Comment 3 rogern 2015-01-06 11:39:17 UTC
The file renders correctly in 4.2.8.2, so it appears to have regressed since that version.
Comment 4 Regina Henschel 2015-01-11 02:13:02 UTC
It fails with
 OSL_ENSURE(false, "OOps, could not prepare given marker as primitives (!)");
in line 953 in file svgstyleattributes.cxx in method SvgStyleAttributes::add_markers.
Comment 5 Robinson Tryon (qubit) 2015-12-10 03:43:24 UTC
Moving/clarifying Whiteboard filter:svg tag -> Keyword filter:svgInsert
Comment 6 Regina Henschel 2016-02-23 16:47:09 UTC
Same root cause, for the missing fill property the default value "black" has to be used.

*** This bug has been marked as a duplicate of bug 47446 ***