Bug 47446 - SVG: line marker should be filled black, if property fill is missing
Summary: SVG: line marker should be filled black, if property fill is missing
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
QA Contact:
URL: https://www.w3.org/TR/SVG/painting.ht...
Whiteboard: target:5.2.0
Keywords: filter:svgInsert
: 64460 87440 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-03-17 10:00 UTC by Valek Filippov
Modified: 2016-10-25 19:07 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Testing file (2.53 KB, image/svg+xml)
2012-03-17 10:00 UTC, Valek Filippov
Details
Screenshot of the file opened and inserted in lodraw 3.5.1 (9.99 KB, image/png)
2012-03-17 10:01 UTC, Valek Filippov
Details
How it looks in Libreoffice 5.0.1.2 (18.40 KB, image/jpeg)
2015-09-09 15:27 UTC, Xisco Faulí
Details
The default fill color black is not used in markers. (1.85 KB, image/svg+xml)
2016-02-23 16:34 UTC, Regina Henschel
Details
fill inherited (1.93 KB, image/svg+xml)
2016-03-09 14:36 UTC, Regina Henschel
Details
fill inherited from g (1.95 KB, image/svg+xml)
2016-03-11 10:00 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Valek Filippov 2012-03-17 10:00:43 UTC
Created attachment 58613 [details]
Testing file

How to reproduce
----------------
1. Open attached SVG file.
2. Insert attached SVG file into the same document
("Insert->Picture->From file...").

Expected results
----------------
Both pictures look the same.

Results with lodraw 3.5.1 release
---------------------------------
1. stroke-dasharray was ignored.
2. Line marker was placed separately at 0,0 position.
Comment 1 Valek Filippov 2012-03-17 10:01:33 UTC
Created attachment 58614 [details]
Screenshot of the file opened and inserted in lodraw 3.5.1
Comment 2 sasha.libreoffice 2012-06-12 02:09:38 UTC
Thanks for bugreport
result on Fedora 64 bit:
in 3.3.4: Insert->Picture->From file and File->Open shows bug
(both lines solid, arrow in upper left corner of page, no text)

in 3.5.4: Insert->Picture->From file works correctly
File->Open show bug
(Windows not tested, expected the same result)
Comment 3 Jorendc 2013-05-22 17:55:46 UTC
*** Bug 64460 has been marked as a duplicate of this bug. ***
Comment 4 Xisco Faulí 2015-09-09 15:27:47 UTC
Created attachment 118550 [details]
How it looks in Libreoffice 5.0.1.2

This issue is still present in

Version: 5.0.1.2
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Locale: es-ES (es_ES)

on Windows 7 (64-bit)
Comment 5 Robinson Tryon (qubit) 2015-12-09 18:52:36 UTC
Migrating Whiteboard tags to Keywords: (filter:svgOpen)
Comment 6 Regina Henschel 2016-02-23 16:34:12 UTC
Created attachment 122919 [details]
The default fill color black is not used in markers.

Please write a new bug report, in case dashes are rendered wrong, so that this issue is only about the missing marker. Two different problems in one report cannot be handled well.

The marker is missing, because it has no fill attribute. The property 'fill' has the initial value 'black', but LibreOffice treats it as 'none'.

In the middle example in the attached file, the marker should be totally filled black.
Comment 7 Regina Henschel 2016-02-23 16:47:09 UTC
*** Bug 87440 has been marked as a duplicate of this bug. ***
Comment 8 Regina Henschel 2016-02-23 16:50:40 UTC
Edit subject to reflect the root cause
Comment 9 Commit Notification 2016-03-09 11:44:08 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=644ace4143fe2576bfd71c8ab3da9d666d6523bb

tdf#47446: SVGIO: Set marker's fill attribute to black...

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Regina Henschel 2016-03-09 14:36:24 UTC
Created attachment 123434 [details]
fill inherited

I think, that the solution is wrong. It prevents, that an inherited fill can be used.

In the attached example the marker in the middle inherits its fill from the ancestor, so it should be filled yellow.
Comment 11 Xisco Faulí 2016-03-09 14:48:17 UTC
Hi Regina,
Thanks for reviewing. I didn't take that case into account, I'll fix it. However, it didn't work before my patch either.
Comment 12 Xisco Faulí 2016-03-11 10:00:38 UTC
Created attachment 123491 [details]
fill inherited from g
Comment 13 Commit Notification 2016-03-11 10:05:36 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1868a62a32cff30e3ba214cbd03917d2c6518073

tdf#47446: SVGIO: Take markers' parents into account too

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2016-04-12 22:03:28 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=de32fe50299a8891102528379e291919d2b66f56

SVG: Add unittest for tdf#47446 and tdf#98599

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.