Bug Hunting Session
Bug 87648 - 'Spelling' or 'Spelling and Grammar'
Summary: 'Spelling' or 'Spelling and Grammar'
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.0.0
Keywords:
Depends on: 112015
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-23 19:38 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-08-27 00:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-12-23 19:38:48 UTC
Writer uses 'Spelling and Grammar' (.uno:SpellingAndGrammarDialog) in its Tools menu and standard toolbar, while other modules use the 'Spelling' (.uno:SpellDialog). I remember someone mentioning that most languages do not have grammar checking, but the dialog spelling dialog has a grammar checkbox in it whether a user uses a language which has grammar checking or not. So shouldnt we stick with 'Spelling and Grammar' over 'Spelling'.
Comment 1 Yousuf Philips (jay) (retired) 2015-03-29 13:13:46 UTC
Well it seems only Writer has grammar check capabilities as the spell dialog in other modules doesnt have a grammar checkbox.

In order to unify the label in all modules, i suggest we change them both to 'Spelling', 'Spelling Check', 'Spellcheck', 'Spell Check', 'Spell Checking' (similar to the 'Automatic Spell Checking' which was previously 'AutoSpellcheck'), 'Spell Checker' (has a wikipedia page).

The dialog title would also be needed to be changed to reflect this change.
Comment 2 Robinson Tryon (qubit) 2016-08-25 05:26:52 UTC Comment hidden (obsolete)
Comment 3 Heiko Tietze 2017-01-23 13:48:35 UTC
How is the status here? Resolved/Fixed, I guess.
Comment 4 Yousuf Philips (jay) (retired) 2017-02-04 13:30:04 UTC
(In reply to Heiko Tietze from comment #3)
> How is the status here? Resolved/Fixed, I guess.

Nothing has been done since comment 2, so a decision needs to be agreed on for the change.

@Cor, @Stuart, @Adolfo: What's your take?
Comment 5 V Stuart Foote 2017-02-04 16:57:34 UTC
Of the two UNO commands found in toolbars, menus and .UI, uno:SpellingAndGrammarDialog is unique to the sw Writer module. 

It alone includes the option to toggle the Grammar check active if supported.

The uno:SpellDialog is resident in the other modules.  

I have not read through the two modules to identify the differences, but assume addition of the Grammar check support for Writer requires the unique UNO command.

However, I would agree with removing the "and Grammar" from the dialog title and associated command label, and make them all consistently "Spelling", or "Spell Check", or "Spell Checker" across the UI for all dialogs, menus and toolbar entires.

Agree with Jay that we do not gain anything by distinguishing the uno:SpellDialog from the uno:SpellingAndGramarDialog in our labeling--availibility of the Grammar checker will depend on which UNO command is associated with the control.  

In future if Grammar Check can be implemented for sd or sc modules then we would change the associated UNO command(s) keeping the same labeling.
Comment 6 Heiko Tietze 2017-08-03 13:24:45 UTC
Decision was done in the design meeting to go with just 'Spelling', confirmed by l18n.
Comment 7 Commit Notification 2017-08-24 15:04:20 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1098fba99acb8c8cc7e87c55ece12ef175593147

tdf#87648 Spelling and Grammar

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.