Bug 87651 - SIDEBAR: Addition of bullet commands in Impress
Summary: SIDEBAR: Addition of bullet commands in Impress
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: medium enhancement
Assignee: Maxim Monastirsky
QA Contact:
URL:
Whiteboard: target:5.1.0 target:5.0.0.1
Keywords:
: 89457 (view as bug list)
Depends on:
Blocks: Bullet-Number-Outline-Lists Sidebar-Properties-Paragraph
  Show dependency treegraph
 
Reported: 2014-12-23 22:31 UTC by Yousuf Philips (jay)
Modified: 2016-10-24 17:03 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) 2014-12-23 22:31:18 UTC
In Impress's sidebar next to the bullet and numbering buttons, there is an empty space that could be filled with bullet functions found in the toolbar like promote, demote, move up and move down. In Writer, that space is taken by the paragraph background color.
Comment 1 Commit Notification 2015-06-10 11:06:56 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ef530d397b021a9606bb3b3abe8c2290a1d94c59

tdf#87651 Add outline buttons to impress sidebar

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 2 Yousuf Philips (jay) 2015-06-11 08:27:59 UTC
*** Bug 89457 has been marked as a duplicate of this bug. ***
Comment 3 Yousuf Philips (jay) 2015-06-14 00:01:16 UTC
It functions great, but can we have the buttons aligned to the right, so they look in place with the vertical alignment buttons above it. Also can we sort them as demote, promote, move down, and move up, as i recently found out that is the correct order for these buttons based on the usage metrics.

It would then be great to push this into 5.0, along with the fix to the indent buttons (bug 91944), so it can be added to the release notes. Thanks again for the help/fix.
Comment 4 Commit Notification 2015-06-15 07:51:43 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4331aa3cbab9ea7505e1d31ac674ee8ca5d9c314

Related: tdf#87651 Swap buttons and align to the right

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2015-06-16 11:42:19 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5ea3e979216fee5b9ceb6c42b2770d32bde0ae16&h=libreoffice-5-0

tdf#87651 Add outline buttons to impress sidebar

It will be available in 5.0.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2015-06-16 11:42:27 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8ca4e26a693986ae198c2182102aacbb399c91f2&h=libreoffice-5-0

Related: tdf#87651 Swap buttons and align to the right

It will be available in 5.0.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.