Download it now!
Bug 87718 - FILEOPEN: DOCX - Detection of embedded videos links
Summary: FILEOPEN: DOCX - Detection of embedded videos links
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: needsWord
Keywords: filter:docx
Depends on:
Blocks: DOCX-Limitations DOCX Media-Online
  Show dependency treegraph
 
Reported: 2014-12-25 22:15 UTC by Yousuf Philips (jay) (retired)
Modified: 2020-11-18 18:54 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
sample web video doc (32.35 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-12-25 22:15 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-12-25 22:15:09 UTC
Created attachment 111336 [details]
sample web video doc

When opening the attached document in LO, all it shows is an image, but when opened in MS Word, you can ctrl+click on the image to load the video url into browser.

In /word/_rels/document.xml.rels you have the following xml:

<Relationship Id="rId5" Type="http://schemas.openxmlformats.org/officeDocument/2006/relationships/hyperlink" Target="https://www.youtube.com/watch?v=OXeOs9EOnPw&amp;feature=youtube_gdata_player" TargetMode="External"/>

And in /word/document.xml you have the following xml in the <w:drawing> tag:

<wp:docPr id="1" name="Video 1"><a:hlinkClick xmlns:a="http://schemas.openxmlformats.org/drawingml/2006/main" r:id="rId5"/></wp:docPr>

Version: 4.5.0.0.alpha0+
Build ID: e570cd7a293ceee175949dcc9656cdf776ae3c37
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-12-12_18:49:54
Comment 1 Cor Nouws 2014-12-28 20:10:56 UTC
I can confrim - at least that the video is not started in LibreOffice
Comment 2 Yousuf Philips (jay) (retired) 2014-12-28 20:30:14 UTC
Yes ctrl+clicking it wont work as LO didnt understand that a hyperlink should have been associated with it.
Comment 3 Robinson Tryon (qubit) 2015-12-14 06:02:41 UTC Comment hidden (obsolete)
Comment 4 Xisco Faulí 2017-09-21 20:53:30 UTC
Still reproducible in

Version: 6.0.0.0.alpha0+
Build ID: 86f256596c8566e80993e1cf6035bc3534b6f816
CPU threads: 4; OS: Linux 4.10; UI render: GL; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 5 QA Administrators 2018-09-23 02:50:25 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2020-09-23 03:59:34 UTC Comment hidden (obsolete)
Comment 7 Buovjaga 2020-11-18 18:54:22 UTC
Ctrl-clicking now works as expected, closing

Arch Linux 64-bit
Version: 7.1.0.0.alpha1+
Build ID: bd3aeaefff5e7bdef10c4702d1f388083557614e
CPU threads: 8; OS: Linux 5.9; UI render: default; VCL: kf5
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 15 November 2020