Bug 87914 - UNO: Small caps uno command
Summary: UNO: Small caps uno command
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: medium enhancement
Assignee: Miklos Vajna
QA Contact:
URL:
Whiteboard: target:5.3.0 target:6.0.0
Keywords: needsDevEval, topicUI
: 81901 (view as bug list)
Depends on:
Blocks: UNO-Command 40329
  Show dependency treegraph
 
Reported: 2014-12-31 15:58 UTC by Yousuf Philips (jay)
Modified: 2017-07-20 14:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) 2014-12-31 15:58:04 UTC
Stumbled on this AskLibO question ( http://ask.libreoffice.org/en/question/21809/small-capitals-shortcut-or-icon/ ) where the suggested means of achieving the adding of small caps font effect is to create a macro, then assign the macro to the toolbar. We have other font effects in Format > Change Case, and it would be useful to have this also included there.
Comment 1 Yousuf Philips (jay) 2014-12-31 21:33:39 UTC
A twitter user also asked about this same feature ( https://twitter.com/sjhuskey/status/550313519217139714 ) as microsoft word has it as well as shortcut key.
Comment 2 V Stuart Foote 2014-12-31 23:30:36 UTC
@Jay, *,

No need for a macro, Small Capitals are already available for all fonts that support it. Would just need a button and .uno command to add to an appropriate toolbar or menu.

It is already easily applied:
Select text, or paragraph, to be formatted--then from main menu...

Format -> Character dialog, 
Font Effects tab: Effects drop down as "Small capitals" 

Should be able to link to that. It is in .UI already, so it may even be available as an .uno command, couldn't find it with a quick look though.

-=ref=-
http://opengrok.libreoffice.org/xref/core/cui/uiconfig/ui/effectspage.ui
http://opengrok.libreoffice.org/xref/core/cui/source/tabpages/chardlg.cxx
http://opengrok.libreoffice.org/xref/core/sw/source/core/txtnode/swfont.cxx
Comment 3 Yousuf Philips (jay) 2015-01-01 00:29:36 UTC
Hey Stuart,

Yes i was aware that it was in the character dialog, but i didnt find it as an uno command when i searched for it, which lead me to suggest for its creation. :D

I was initially going to tell the twitter user to create a character style and then apply it when needed, but there isnt an easy means of selecting character styles unless you always have the styles window/sidebar open. :D
Comment 4 Yousuf Philips (jay) 2016-04-28 14:28:49 UTC
@Szymon: I believe this maybe one of the commands needed for the notebookbar.
Comment 5 Miklos Vajna 2016-09-25 14:58:50 UTC
The implementation of similar uno commands (like superscript) is independent in each application (Writer, Calc, Impress). It's not realistic to implement support for smallcaps in each in one shot, I think. So I'm limiting the scope of this particular bug to Writer text.

BTW, the option in the char format dialog is disabled in Calc, and in Impress (shape text) it's there, but the effect is only respected during editing (editeng rendering), not after text edit is finished (drawinglayer rendering). So plenty of opportunities for follow-up bugreports. ;-)
Comment 6 Commit Notification 2016-09-27 09:03:28 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d378cd2f766eeb1fd1c98f62c9ae6b5b59fd00f1

tdf#87914 sw: add an initial .uno:SmallCaps command

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Miklos Vajna 2016-09-27 09:40:47 UTC
I'll mail the design list, so that other icon themes can be updated as well for the new icon.
Comment 8 andreas_k 2016-10-09 12:27:10 UTC
would it be possible to write the icon names that it would be easier to add them to the other icon sets.
Comment 9 Yousuf Philips (jay) 2016-10-09 15:15:36 UTC
(In reply to andreas_k from comment #8)
> would it be possible to write the icon names that it would be easier to add
> them to the other icon sets.

cmd/lc_smallcaps.png
cmd/sc_smallcaps.png
Comment 10 Yousuf Philips (jay) 2016-10-09 15:17:45 UTC Comment hidden (no-value, obsolete)
Comment 11 V Stuart Foote 2017-01-13 18:28:05 UTC
*** Bug 81901 has been marked as a duplicate of this bug. ***
Comment 12 andreas_k 2017-05-08 19:39:46 UTC
added to breeze icon sets

https://gerrit.libreoffice.org/#/c/37404/
Comment 13 Commit Notification 2017-07-20 14:15:47 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=63c30408ba735139a88c3bddd242e320100c82cf

tdf#87914 Add small caps command to Format menu

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.