Bug Hunting Session
Bug 108902 - Small caps only rendered when editing text Draw and Impress
Summary: Small caps only rendered when editing text Draw and Impress
Status: RESOLVED DUPLICATE of bug 105307
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.3.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2017-07-02 15:11 UTC by Eyal Rozenberg
Modified: 2017-07-02 16:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Document manifesting the bug (9.03 KB, application/vnd.oasis.opendocument.graphics)
2017-07-02 15:11 UTC, Eyal Rozenberg
Details
screenshot of unfocused state rendering (62.80 KB, image/png)
2017-07-02 15:12 UTC, Eyal Rozenberg
Details
screenshot of focused, editing state rendering (63.16 KB, image/png)
2017-07-02 15:12 UTC, Eyal Rozenberg
Details
Writer document manifesting the bug (9.27 KB, application/vnd.oasis.opendocument.text)
2017-07-02 15:14 UTC, Eyal Rozenberg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eyal Rozenberg 2017-07-02 15:11:06 UTC
Created attachment 134429 [details]
Document manifesting the bug

Reproduction instructions:
1. Create new LO Draw document
2. Create a large-ish text area (but any object with text should do)
3. Type in "Hello world" (but any bit of text should do)
4. Set the font size to 50 (should really matter)
5. Select the first word ("Hello")
6. Set its font effects to "Small capitals"
7. Now look at the text box when it's out-of-focus, and when it's focused and you're editing the text

When focused and editing you see the small-caps text rendered, but too much space; when unfocused you see all-caps rendering with the right amount of space.
Comment 1 Eyal Rozenberg 2017-07-02 15:12:18 UTC
Created attachment 134430 [details]
screenshot of unfocused state rendering
Comment 2 Eyal Rozenberg 2017-07-02 15:12:37 UTC
Created attachment 134431 [details]
screenshot of focused, editing state rendering
Comment 3 Eyal Rozenberg 2017-07-02 15:14:38 UTC
Created attachment 134432 [details]
Writer document manifesting the bug

Apparently it's not just Draw.
Comment 4 V Stuart Foote 2017-07-02 16:45:51 UTC

*** This bug has been marked as a duplicate of bug 105307 ***