Bug 98367 - Draw/Impress Small capitals preview correct but result as Capitals, including with Text box in Writer
Summary: Draw/Impress Small capitals preview correct but result as Capitals, including...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: low normal
Assignee: Caolán McNamara
URL: https://caolanm.blogspot.com/2023/08/...
Whiteboard: target:24.2.0 inReleaseNotes:24.2
Keywords:
: 99540 105307 106530 108902 117338 122869 147732 (view as bug list)
Depends on:
Blocks: Font-Rendering Font-Effects
  Show dependency treegraph
 
Reported: 2016-03-03 00:16 UTC by Emily Bowman
Modified: 2024-02-12 17:51 UTC (History)
14 users (show)

See Also:
Crash report or crash signature:


Attachments
Display while editing (2.59 KB, image/png)
2016-03-03 00:16 UTC, Emily Bowman
Details
Display after clicking away (2.38 KB, image/png)
2016-03-03 00:16 UTC, Emily Bowman
Details
While editing, with the actual "Networks" selected (2.75 KB, image/png)
2016-03-03 00:17 UTC, Emily Bowman
Details
Broken underline with different font size manual workaround (21.87 KB, image/png)
2022-08-07 13:22 UTC, Theodore Brown
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Emily Bowman 2016-03-03 00:16:03 UTC
Created attachment 123169 [details]
Display while editing

Small caps were added to Draw/Impress in Bug 91932, but they seem to be broken. It will display small caps while editing, but as soon as you click out, it reverts to displaying regular caps.

Also, while displaying small caps while editing, the displayed text is much too small, but the cursor and selections are for the actual size, and don't match the displayed text.

Still present in 5.1.1.1rc.
Comment 1 Emily Bowman 2016-03-03 00:16:35 UTC
Created attachment 123170 [details]
Display after clicking away
Comment 2 Emily Bowman 2016-03-03 00:17:09 UTC
Created attachment 123171 [details]
While editing, with the actual "Networks" selected
Comment 3 Usama 2016-03-03 15:17:02 UTC
I confirm this bug on LO Version: 5.2.0.0.alpha0+ Ubuntu 15.10

To access that feature:
Format menu >> Character... >> Font effects >> effects >> Small capitals
Comment 4 V Stuart Foote 2016-04-27 23:49:13 UTC
*** Bug 99540 has been marked as a duplicate of this bug. ***
Comment 5 moebius20 2016-05-15 10:54:06 UTC Comment hidden (off-topic)
Comment 6 moebius20 2016-09-05 15:55:23 UTC
Bonjour,

This very annoying bug is still present in 5.2.0

cordialement,
Comment 7 bugs.documentfoundation.org 2017-02-20 16:45:11 UTC Comment hidden (obsolete)
Comment 8 bugs.documentfoundation.org 2017-02-20 16:48:01 UTC
(Also still in 5.3rc3 - the current version in Ubuntu Zesty)
Comment 9 V Stuart Foote 2017-03-14 20:59:11 UTC
*** Bug 106530 has been marked as a duplicate of this bug. ***
Comment 10 Callegar 2017-03-15 17:18:36 UTC
Still present in 5.3.1 RC 2
Comment 11 V Stuart Foote 2017-03-15 18:06:23 UTC
Caolán, *

for bug 91932, http://cgit.freedesktop.org/libreoffice/core/commit/?id=ff178cca3384a1d15dcf51491df6196e487f47f4 provides UI for setting case effects, but as noted here as soon as you leave a Text box with Small Caps formatting applied it shifts and just a Capitals effect results.

Lowercase and Title effect apply and are retained along with Capitals effect on leaving the Text box. So CaseMap is mostly correct, but for some reason the Small Caps does not remain intact.
Comment 12 Colin Finck 2017-07-30 16:24:20 UTC
Still present in current stable 5.3.4.2.
Quite annoying that this makes it impossible to apply nice typography through SmallCaps in Impress :(
Comment 13 V Stuart Foote 2018-04-30 13:34:53 UTC
*** Bug 117338 has been marked as a duplicate of this bug. ***
Comment 14 Johnny_M 2018-05-19 10:56:02 UTC
*** Bug 105307 has been marked as a duplicate of this bug. ***
Comment 15 roumanet 2018-05-19 14:57:31 UTC
Is someone working on this bug ? It's a 2 years old bug and seems not to be hard to solve (I'm not angry and I know it's easier to say, rather to do).
Thanks :)
Comment 16 apq 2018-05-19 18:29:49 UTC
+1
Comment 17 Jennifer Cormier 2018-08-16 01:52:25 UTC
Confirmed - still present in 6.0.6.2 - in Writer text box and in Impress.
Comment 18 Timur 2019-01-22 09:25:26 UTC
*** Bug 122869 has been marked as a duplicate of this bug. ***
Comment 19 Xisco Faulí 2019-12-03 10:18:19 UTC
Changing priority to 'high' since the number of duplicates is higher than 5 or the number of people in CC higher than 20
Comment 20 John Kaufmann 2021-07-09 05:09:29 UTC
Still present in 7.1.4.
Comment 21 John Kaufmann 2021-07-09 05:58:27 UTC
Is this related to the lack of Small Caps in Calc?

The most interesting question is why Small Caps function is OK in Writer except for text in boxes, and the behavior in Base/Draw/Impress is the same as Writer text boxes -- where the preview is right but the execution fails.  IOW, if the question is confined to the Writer module, what is the difference in character handling between text in boxes (where SC fails) and out of boxes (where it's OK)?

Presumably that would lead to solution for other modules, and might open up Calc for Small Caps.
Comment 22 MarjaE 2021-12-03 16:49:37 UTC
Still broken in 7.2.3.2.
Comment 23 John Kaufmann 2021-12-03 21:01:51 UTC
This bug was first reported in LO 5.1.0.3, a bit under six years ago. Two years ago Xisco Fauli wrote: "Changing priority to 'high' since the number of duplicates is higher than 5 or the number of people in CC higher than 20".

Today (two years later, to the day), with no explanation, Caolán McNamara reduced priority from 'high' to 'low' [or 'normal'? - I'm hazy on the relationship between "Priority" and "Importance"] immediately following a report that the bug remains in 7.2.3.2 -- though the number of dups remains at 5 and the number on CC (for all dups) is 21. 

This prompts an observation, not a complaint, with accompanying question: How is this supposed to work?
 - Presumably Priority (or Importance?) affects resource assignments?
 - Is explanation required to raise, but not reduce, Priority?
 - After two years at high priority, and two major releases (and numerous minor releases) with no change, what is the effect of reducing priority?
Comment 24 Marco Mazza 2022-02-18 08:19:14 UTC
I don't know if this could be of help, but I do believe this bug for Write and Draw is somewhat related to how Text Boxes are handled. I say so because if you create a Text Box in Write, you can't make the text in it Small Caps no matter what, but if you use the Frame structure there are no such issues, you can create Small Caps text as much as you. Since Draw uses Text Box too that's how this bug show there. Maybe if the Text Box were made more similar to the Frame structure this bug could be fixed. This aside I can Confirm it still exists in 7.3.0.
Comment 25 Buovjaga 2022-06-06 16:08:42 UTC
*** Bug 147732 has been marked as a duplicate of this bug. ***
Comment 26 Theodore Brown 2022-08-07 13:22:18 UTC
Created attachment 181650 [details]
Broken underline with different font size manual workaround

I'm also seeing this issue in LibreOffice 7.4.0.2 when using text boxes in Impress. Sometimes I have been able to work around it by making a word all caps myself and manually reducing the font size of all but the first letter. However, this doesn't work when text is underlined, as changing the font size results in the position of the underline changing and not lining up with the rest of the text. Is there any way to make the text appear correctly when underlined?
Comment 27 John Kaufmann 2022-08-07 20:43:48 UTC
(In reply to Marco Mazza from comment #24)
> I don't know if this could be of help, but I do believe this bug for Write
> and Draw is somewhat related to how Text Boxes are handled. I say so because
> if you create a Text Box in Write, you can't make the text in it Small Caps
> no matter what, but if you use the Frame structure there are no such issues,
> you can create Small Caps text as much as you. Since Draw uses Text Box too
> that's how this bug show there. ...

Yes. This comment replicates comment #21, which is slightly more general.
Comment 28 John Kaufmann 2022-08-07 20:54:16 UTC
(In reply to Theodore Brown from comment #26)
> Created attachment 181650 [details]
> Broken underline with different font size manual workaround
> 
> I'm also seeing this issue in LibreOffice 7.4.0.2 when using text boxes in
> Impress. ...
Yes. This comment replicates comment #21.

> ... Sometimes I have been able to work around it by making a word all
> caps myself and manually reducing the font size of all but the first letter.
> However, this doesn't work when text is underlined, as changing the font
> size results in the position of the underline changing and not lining up
> with the rest of the text. Is there any way to make the text appear
> correctly when underlined?
I'm afraid that questions involving prospective work-arounds would be more appropriate on the user forum than in this bug thread, which is oriented toward identifying and fixing operating problems rather than working around them.
Comment 29 Commit Notification 2023-08-22 13:29:35 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/97469c2cac442fc3231694e35a8cd7a0f8d16af4

Related: tdf#98367 export editeng EE_CHAR_CASEMAP the same as writer does

It will be available in 24.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 30 Commit Notification 2023-08-22 13:29:38 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ffaed5cae29d6bb14faf870cb935ccd3c35d4a3c

tdf#98367 implement rendering of draw/impress small capitals

It will be available in 24.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 31 Peter Milbradt 2023-08-22 13:35:38 UTC
The bug is NOT Fixed in LibreOffice 7.5.5.2 on MacOSX, Windows and Debian
Comment 32 Xisco Faulí 2023-08-22 13:39:18 UTC
(In reply to Peter Milbradt from comment #31)
> The bug is NOT Fixed in LibreOffice 7.5.5.2 on MacOSX, Windows and Debian

of course it's not. it's fixed in master ( LibreOffice 24.2.0) only at the moment. That's why it's marked as RESOLVED FIXED.
Comment 33 Commit Notification 2023-08-22 14:31:45 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e46e663cc350d89e4997095466d675b875eb2e04

Related: tdf#98367 allow drawing shapes in calc to have smallcaps

It will be available in 24.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 34 Nate Graham 2023-08-22 15:17:12 UTC
Nice, thank you so much!
Comment 35 Stéphane Guillou (stragu) 2024-01-11 14:13:57 UTC
In the 24.2 release notes: https://wiki.documentfoundation.org/ReleaseNotes/24.2#Impress

Verified in:

Version: 24.8.0.0.alpha0+ (X86_64) / LibreOffice Community
Build ID: a2ccc25ccb2e94f5990d6d413541dbcdd3a72338
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded
Comment 36 Stéphane Guillou (stragu) 2024-01-11 14:32:47 UTC
*** Bug 108902 has been marked as a duplicate of this bug. ***
Comment 37 Eyal Rozenberg 2024-01-12 13:28:15 UTC
(In reply to Stéphane Guillou (stragu) from comment #36)
> *** Bug 108902 has been marked as a duplicate of this bug. ***

Thank you Caolan for the fix, and Stephane for noticing the duplication :-)
Comment 38 Stéphane Guillou (stragu) 2024-01-12 13:49:24 UTC
(In reply to Eyal Rozenberg from comment #37)
> Thank you Caolan for the fix, and Stephane for noticing the duplication :-)
It was more Stuart than me, I just can't leave dupe-of-dupes alone :)