Bug Hunting Session
Bug 99540 - in a text box when selecting format->character->effects->small capitals lost and becomes capitals when deselected
Summary: in a text box when selecting format->character->effects->small capitals lost ...
Status: RESOLVED DUPLICATE of bug 98367
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2016-04-27 20:29 UTC by moebius20
Modified: 2016-04-27 23:49 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description moebius20 2016-04-27 20:29:19 UTC
Bonjour,


in a text box when selecting format->character->effects->small capitals, we obtains only caps.

After selecting text in the box and then clicking on "small caps", we obtain small caps but, clicking outside the text box produce text to become only in caps, not small caps ; strane, isn't it ?

I've experimeted this bug with the interface in french, but, I've delete the french components to obtain the name, in english of my "zone de texte", the "text zone" ; the bug remain with the english interface.

cordialement,
Comment 1 V Stuart Foote 2016-04-27 23:37:57 UTC
On Windows 8.1 Ent 64-bit en-US with
Version: 5.1.2.2 (x64)
Build ID: d3bf12ecb743fc0d20e0be0c58ca359301eb705f
CPU Threads: 8; OS Version: Windows 6.29; UI Render: GL; 
Locale: en-US (en_US)

Reproduce.

In Writer both a paragraph of text, as well as a text-box of the same text, will take Character -> Font Effects: Effects of "Samll caps" and lower case letters of all words are changed to capital letters. Initial letter of the sentence is slightly larger.

This appears to be the correct handling of Small Caps--absent "true" small-caps/pettite-caps support for OpenType metrics in fonts that offer it.

However, the issue does seem to be that on leaving the text box and returning to the document canvas, the text rendered in "Small caps" changes to simple all capitals--no reversion to lower case just different size.

Reselecting the text in the Text box, it again shows the "Small caps" direct formatting. Deselecting the text it shows simple capitals.

Same mis-handling of Text Box in Draw, when directly formatted to Small caps selected text looks correct, but on deselection it expands to full caps.
Comment 2 V Stuart Foote 2016-04-27 23:49:13 UTC

*** This bug has been marked as a duplicate of bug 98367 ***