Bug Hunting Session
Bug 105307 - FORMATTING : Small Caps (Little capital) doesn't work in draw boxes
Summary: FORMATTING : Small Caps (Little capital) doesn't work in draw boxes
Status: RESOLVED DUPLICATE of bug 98367
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.2.4.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 108902 (view as bug list)
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2017-01-13 10:15 UTC by roumanet
Modified: 2018-05-19 10:56 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Video with bug (2.64 MB, video/avi)
2017-01-13 10:15 UTC, roumanet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description roumanet 2017-01-13 10:15:20 UTC
Created attachment 130385 [details]
Video with bug

Step-by-step :
1) In Impress, create a box (draw tools)
2) Double-clic and write a "long" text (but still in the box)
3) Select this text and right clic to select Caracters menu
4) Choose Effects > Small Caps

Two bugs appears :
1) the text is shifted to the left (as if it has some hidden spaces on the right
2) when the box is released, the text is in full caps

Check on Impress first, but found in Writer too.
Check first with default font (Liberation Sans) and tested with Calibri too. Consolas font and Liberation sans impacted too (mono font).

It's not usable at all.
Comment 1 V Stuart Foote 2017-01-13 20:00:35 UTC
Confirmed on Windows 8.1 Ent 64-bit en-US with
Version: 5.3.0.1 (x64)
Build ID: 3b800451b1d0c48045de03b5b3c7bbbac87f20d9
CPU Threads: 8; OS Version: Windows 6.29; UI Render: default; Layout Engine: old; 
Locale: en-US (en_US); Calc: group

But as Miklos pointed out in https://bugs.documentfoundation.org/show_bug.cgi?id=87914#c5 there are two modes while editing the Draw box--one is editeng rendering, i.e. while the draw box has edit cursor focus; and the other is drawinglayer rendering.

The small cap font effect only applies when the drawing object is held by the edit engine. On release the drawing layer drops the effect.

However, with implementation of HarfBuzz we now have improved handling of OTF/Graphite smart font features.  To the extent that a font supports SmallCaps and other features--believe the font will be rendered in the Draw box.

So, not sure how much effort should be made to improve the simulated SmallCap / DropCap effects within a Draw object when using :smcp=1 flag for a font with actual Small Capital metrics.
Comment 2 roumanet 2017-01-14 16:15:51 UTC
If there is a workaround, I really need it :)
As I'm teacher, Presentation is one of my most used tools : it's really annoying !

Since few time (from LO4) transitions have problems (see bug https://bugs.documentfoundation.org/show_bug.cgi?id=99685)
Now I cannot use Small Caps... I feel more and more bugs :(

Please help us : how could I use drawinglayer rendering ?
Comment 3 roumanet 2017-01-14 16:39:43 UTC
I've tested with LO5.3 but problem still here :(
and I don't find smcp in Advanded configuration...

Version: 5.3.0.0.beta2
Build ID: a7e30712ad6d8bc9286007b37aa581983e0caba3
Threads CPU : 4; Version de l'OS :Windows 6.2; UI Render : GL; Moteur de mise en page : nouveau; 
Locale : fr-FR (fr_FR); Calc: group
Comment 4 V Stuart Foote 2017-01-14 17:35:48 UTC
(In reply to roumanet from comment #3)
...
> and I don't find smcp in Advanded configuration...


For fonts that have an Opentype or Graphite metric defined, simply append ":smcp=1" to the font name in the droplist.
Comment 5 roumanet 2017-04-14 15:06:35 UTC
I'm afraid but that doesn't works as expected.
What you're explaining to me is how to learn to live without this function ? ;)

Be serious, if this function is there, it should works as expected, else remove it (less bug is better than lot of unsatisfaying functions).
It's same problem in writer and Liberation Sans or Arial font.
Comment 6 V Stuart Foote 2017-07-02 16:45:51 UTC
*** Bug 108902 has been marked as a duplicate of this bug. ***
Comment 7 Johnny_M 2018-05-19 10:56:02 UTC

*** This bug has been marked as a duplicate of bug 98367 ***