Bug Hunting Session
Bug 88747 - Scroll bar slider moves the other direction (Use OpenGL for all rendering)
Summary: Scroll bar slider moves the other direction (Use OpenGL for all rendering)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-23 12:47 UTC by Dimitry Prihodko
Modified: 2015-08-08 01:35 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Last slide has scroll bar at the bottom (508.31 KB, image/png)
2015-02-03 11:12 UTC, Liam Smit
Details
Screenshot where first slide results in scroll bar at the top. (329.44 KB, image/png)
2015-02-03 11:13 UTC, Liam Smit
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dimitry Prihodko 2015-01-23 12:47:07 UTC
The slider in the right vertical scrollbar is initially in the bottom. 
when the document is scrolled with mouse wheel? the slider moves up.
However, if you wish to move the slider using left mouse button, you have to cllick NOT on the slider, but in the place where the slider would be if it worked normally.
Comment 1 Buovjaga 2015-01-29 19:06:15 UTC
Could not reproduce. Maybe attach a video capture?

Ubuntu 14.10 64-bit Version: 4.5.0.0.alpha0+
Build ID: 784d069cc1d9f1d6e6a4e543a278376ab483d1eb
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-01-25_23:58:40
Comment 2 Dimitry Prihodko 2015-01-29 19:32:26 UTC
(In reply to Beluga from comment #1)
> Could not reproduce. Maybe attach a video capture?
> 
> Ubuntu 14.10 64-bit Version: 4.5.0.0.alpha0+
> Build ID: 784d069cc1d9f1d6e6a4e543a278376ab483d1eb
> TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time:
> 2015-01-25_23:58:40

The video is available at https://cloud.mail.ru/public/ff7272ee3ba5/out.ogv
Comment 3 Dimitry Prihodko 2015-01-29 19:33:13 UTC
(In reply to Beluga from comment #1)
> Could not reproduce. Maybe attach a video capture?
> 
> Ubuntu 14.10 64-bit Version: 4.5.0.0.alpha0+
> Build ID: 784d069cc1d9f1d6e6a4e543a278376ab483d1eb
> TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time:
> 2015-01-25_23:58:40

btw, the same bug is observed in LO 4.4
Comment 4 Liam Smit 2015-02-03 11:12:26 UTC
Created attachment 113088 [details]
Last slide has scroll bar at the bottom

This is seen on 4.4.0 release (3)

If you ignore where the scroll bar is displayed and click where it actually is then you can manipulate it normally.
Comment 5 Liam Smit 2015-02-03 11:13:57 UTC
Created attachment 113089 [details]
Screenshot where first slide results in scroll bar at the top.

First slide has scroll bar at the top.
Comment 6 Liam Smit 2015-02-03 12:22:58 UTC
The inverted display problem for this scrollbar goes away if I disable the option:
"Use OpenGL for all rendering" 
under Options -> LibreOffice -> View -> Graphics Options.
Comment 7 raal 2015-03-14 20:50:39 UTC
I can confirm with Version: 4.4.3.0.0+
Build ID: 8106e522c4ea2ae4441ec571579a38eeb6d9af04
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-4-4, Time: 2015-03-13_12:39:32

The same as in comment 6
The inverted display problem for this scrollbar goes away if I disable the option:
"Use OpenGL for all rendering" 
under Options -> LibreOffice -> View -> Graphics Options.
Comment 8 Rpnpif 2015-04-02 16:37:12 UTC
*** Bug 88831 has been marked as a duplicate of this bug. ***
Comment 9 John L. ten Wolde 2015-04-07 00:01:37 UTC
I too get the inverted scrollbars and checkmarks with OpenGL activated.

I've seen this sort of thing before... something to do with a reversed or erroneous assignment to the matrix equation of a graphics object (like -x instead of x)... but it's been years and my memory is hazy.

Anyway, in addition to the inverted objects, I also get crashes to desktop and a weird screen freeze sort of error when using Writer.  Full description in bug 90493.
Comment 10 ch 2015-04-26 16:06:52 UTC
(In reply to Liam Smit from comment #6)
> The inverted display problem for this scrollbar goes away if I disable the
> option:
> "Use OpenGL for all rendering" 
> under Options -> LibreOffice -> View -> Graphics Options.

With "Use OpenGL for all rendering," in addition to the inverted scrollbars, I also see inverted checkmarks in checkboxes in the options.
Comment 11 Adolfo Jayme 2015-08-08 01:35:07 UTC
AFAICT this is already fixed by this commit: http://cgit.freedesktop.org/libreoffice/core/commit/?id=f7f0486376adbabf3ea66bfd8a7b692c335ec3c8