Bug Hunting Session
Bug 88774 - Feature request: simpler possibility to add text at the background of a page, as a watermark
Summary: Feature request: simpler possibility to add text at the background of a page,...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Page-Watermark
  Show dependency treegraph
 
Reported: 2015-01-24 12:15 UTC by Yan Pas
Modified: 2017-10-16 17:14 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
A watermark done with rotated text box (29.94 KB, application/vnd.oasis.opendocument.text)
2015-07-19 12:40 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yan Pas 2015-01-24 12:15:10 UTC
There is no option to set a text on the background of the page in Calc, Writer, Impress and Draw. (Only color or an image) It is useful for watermarks. Now the process is to complicated. You are to make an Image in draw with correct size etc. It is easy to implement. The good implementation in MS Word, but featureless.
Comment 1 raal 2015-01-29 05:23:00 UTC
duplicate of bug 75261?
Comment 2 Yan Pas 2015-01-29 05:35:37 UTC
No. I just suggest interface where you may enter text, set color and angle, select mosaiqe or extend to page size, press ok - and this text will be on the backgroung of your sheet. This interface would be in page format, bacground menu, in dropdown menu, where currently are only "Picture" and "color"
Comment 3 Buovjaga 2015-01-31 11:22:21 UTC
Well, this needs a lot of interface design, so I'll punt it over to the design team.
Comment 4 Cor Nouws 2015-02-03 09:57:32 UTC
Good idea - thanks.
Maybe even within reach of GSoC students?
Comment 5 Yan Pas 2015-02-03 10:09:06 UTC
Well if you are taking about me, I have not written any program longer  then 100 lines of code, so it is difficult for me:( But in my opinion LO already has tools for such tasks. Programmers are just to combine them into gui-script.
Comment 6 V Stuart Foote 2015-07-19 12:40:36 UTC
Created attachment 117331 [details]
A watermark done with rotated text box

There are multiple ways to do this "simply" now.

1. Use Draw (or Gimp, or Inskscape) and create the desired text and rendering at a suitable scale and size for the water mark.  Then save to a raster or vector image format. Insert that into LibreOffice to "watermark" each page. Position as desired. Use Arrangement to push the image to the background. Set the wrap properties as prefered, e.g. "in background"

2. Do the same into a document template, to apply to all pages of a document.

3. From 4.3 forward (with Text Box frames and rotation better sorted) insert a Text Box. Enter desired text for the Watermark. Use Arrangement to push to background. Rotate text box. Set wrap properties as preferred, "in background" for a watermark.

See attached example of a rotated Text box.

These steps can be captured into a macro currently, or an UNO tool could be implemented to do the same.
Comment 7 Yan Pas 2015-07-19 13:13:03 UTC
Text box beside the main text could be accidently clicked. Gimp etc surely give wider range of possibilities, but people always need a few types of WatermarkS: top secret,  example or Name+Surname (I may look which ms word suggests). All they are made with grey serif font that fits to diagonal, font may be 80% transparent.
Comment 8 Roeland 2016-05-28 13:42:15 UTC Comment hidden (obsolete)
Comment 9 Cor Nouws 2016-05-28 13:54:17 UTC
(In reply to Roeland from comment #8)
> Isn't this a duplicate of  Bug 54053?

Not precise. That one is about PDF export.
But the relation is clear. Thanks for notifying!
Comment 10 Robinson Tryon (qubit) 2016-08-25 05:49:46 UTC Comment hidden (obsolete)
Comment 12 Timur 2017-05-18 10:22:05 UTC
I hope it will be added to https://wiki.documentfoundation.org/ReleaseNotes/5.4.
Comment 13 Cor Nouws 2017-05-18 11:36:23 UTC
(In reply to Timur from comment #12)
> I hope it will be added to
> https://wiki.documentfoundation.org/ReleaseNotes/5.4.

Feel free ;)
Comment 14 Szymon Kłos 2017-05-18 11:46:43 UTC
This is not finished yet, I will extend Watermark dialog. It will be possible to change font etc.
Comment 15 Yan Pas 2017-05-18 12:17:27 UTC
Great news! Thanks!
Comment 16 Thomas Lendo 2017-05-27 21:23:44 UTC
For the sake of completeness, the watermark feature is available (in 5.5 alpha0) via menu Insert > Watermark or with the Customization dialog where you can add the command to toolbars, context menus, etc. (without an icon).

FYI I created a follow-up bug 107996 "FORMATTING: Watermark feature in page style dialog".

BTW thank you for your work, Szymon Kłos!
Comment 17 Yousuf Philips (jay) (retired) 2017-06-14 22:26:36 UTC
(In reply to Thomas Lendo from comment #16)
> For the sake of completeness, the watermark feature is available (in 5.5
> alpha0) via menu Insert > Watermark or with the Customization dialog where
> you can add the command to toolbars, context menus, etc. (without an icon).

Insert > Watermark isnt the correct location, as the dialog is for both inserting and modifying the watermark, so this should be moved near other page style level modifying dialogs (i.e. under Format > Columns).

> FYI I created a follow-up bug 107996 "FORMATTING: Watermark feature in page
> style dialog".

This is the correct location for the feature, inside the Format > Page dialog, as it is a property of the page style.
Comment 18 Timur 2017-10-16 16:22:59 UTC
https://wiki.documentfoundation.org/ReleaseNotes/5.4:
Custom Watermark inserting in Format ▸ Watermarks  (Szymon Kłos - Collabora)

Also: 
http://eszkadev.blogspot.ba/2017/10/interoperability-of-writers-features.html

How watermark works?
● Shape inserted into header → enables header
● Thanks to that appears on each page
● Placed in the background to not cover text
● Have to be applied to all page styles

(In reply to Yan Pas from comment #2)
> I just suggest interface where you may enter text, set color and angle,
available, also font and transparency
> select mosaiqe or extend to page size
not available

(In reply to Szymon Kłos from comment #14)
> This is not finished yet, I will extend Watermark dialog. It will be
> possible to change font etc.
Not sure what's not finished. Font change is possible. Can we close this one as Fixed?
Comment 19 Yan Pas 2017-10-16 17:06:45 UTC
A great work was done, thanks to all contribtors. Sure it may be closed.
Comment 20 Szymon Kłos 2017-10-16 17:14:25 UTC
Yes, can be closed