Bug Hunting Session
Bug 88847 - EDITING: Fields (column) of query design can be moved to the left, but not to the right
Summary: EDITING: Fields (column) of query design can be moved to the left, but not to...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.5.0 target:4.4.2 target:4.3.7
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-28 09:50 UTC by Lionel Elie Mamane
Modified: 2019-01-30 19:42 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lionel Elie Mamane 2015-01-28 09:50:42 UTC
+++ This bug was initially created as a clone of Bug #54021 +++

edit a query in the graphical designer (not in SQL mode)

try to move a column to the left by drag'n drop. Works.

try to move a column to the right by drag'n drop. An arrow appears giving the impression it will happen, but it does not. Nothing happens when one releases the mouse button.
Comment 1 Julien Nabet 2015-01-29 20:28:40 UTC
On pc Debian x86-64 with master sources updated today, no drag'n drop work at all. letf to right or right to left
In both cases:
warn:legacy.osl:2627:5:svx/source/fmcomp/fmgridcl.cxx:265: FmGridHeader::ExecuteDrop: somebody started a nonsense drag operation!!
Comment 2 Julien Nabet 2015-03-05 21:50:14 UTC
My previous comment is nonsense. Indeed I gave a new try to this one, I reproduced exactly the behaviour you indicated Lionel.
Reading the console message I quoted, I suppose I tested form instead of query.
Comment 3 Julien Nabet 2015-03-05 22:25:55 UTC
Code pointers
when it's ok:
#0  dbaui::OSelectionBrowseBox::ColumnMoved (this=0x300d7c0, nColId=2, _bCreateUndo=true)
    at /home/julien/compile-libreoffice/libreoffice/dbaccess/source/ui/querydesign/SelectionBrowseBox.cxx:284
#1  0x00002aaad8b4a1f7 in dbaui::OSelectionBrowseBox::ColumnMoved (this=0x300d7c0, nColId=2)
    at /home/julien/compile-libreoffice/libreoffice/dbaccess/source/ui/querydesign/SelectionBrowseBox.hxx:134
#2  0x00002aaaaf99f083 in BrowserHeader::EndDrag (this=0x3151630) at /home/julien/compile-libreoffice/libreoffice/svtools/source/brwbox/brwhead.cxx:97

when it's ko, it goes in EndDrag but never in ColumnMoved because it never enters in block if (nOldPos != nNewPos), see http://opengrok.libreoffice.org/xref/core/svtools/source/brwbox/brwhead.cxx#94
Comment 4 Julien Nabet 2015-03-07 08:06:18 UTC
Patch submitted here: https://gerrit.libreoffice.org/14777
Comment 5 Commit Notification 2015-03-07 19:14:54 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=63050dccbc50f148cd788730faa53d822d37e54f

tdf#88847: Fields of query design can be moved to the left only

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2015-03-07 19:17:20 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a598a553ad98e5bfc5fedf03cc704e09601dab55&h=libreoffice-4-4

tdf#88847: Fields of query design can be moved to the left only

It will be available in 4.4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2015-04-09 23:25:11 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0dbc0f95d2d0a8ded4ee98e7cd07f217537305c2&h=libreoffice-4-3

tdf#88847: Fields of query design can be moved to the left only

It will be available in 4.3.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.