Download it now!
Bug 88972 - Record navigation Bar icons not visible in Form on opening
Summary: Record navigation Bar icons not visible in Form on opening
Status: RESOLVED DUPLICATE of bug 88836
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: x86-64 (AMD64) All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-01-31 09:42 UTC by Rodolfo
Modified: 2015-02-04 22:01 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screen capture of navigation bar (11.60 KB, image/png)
2015-01-31 09:42 UTC, Rodolfo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rodolfo 2015-01-31 09:42:56 UTC
Created attachment 112984 [details]
screen capture of navigation bar

Icons in navigation bar are there, but not visible in all applications where you insert the control. Is very annoying as you have to slowly pass the mouse through them to read the description text which works. Buttons in the bar actually work.
Comment 1 A (Andy) 2015-01-31 09:54:46 UTC
Could you please give more information how I can get to this screenshot.
Comment 2 safa alfulaij 2015-01-31 10:16:11 UTC
View > ToolBars > Form Navigation
I can see all the icons in the Breeze (Kde4) theme.
Comment 3 Rodolfo 2015-01-31 10:18:55 UTC
(In reply to A (Andy) from comment #1)
> Could you please give more information how I can get to this screenshot.

Hello, I have several databases and bar is displayed like that, but just to test it, I opened a writer document went to View -> ToolBars -> Form Controls
Then selected the icon more controls, and the last one is the navigation bar

If you do it in any previous version all icons are grayed there. In 4.4.0.3 you just see gray.

Best regards
Comment 4 Alex Thurgood 2015-02-01 14:12:53 UTC
Confirming, still present in master

Version: 4.5.0.0.alpha0+
Build ID: c106f83da16726506962e19bcbc3d4c25415b81a
Locale: fr_


The only way to get the record navigation toolbar to display is to set window to full screen then back again.
For some reason, the record navigation toolbar does not get redrawn correctly when the ODB form window is drawn. It is also a regression (will have to check which version).
Comment 5 Alex Thurgood 2015-02-01 14:15:16 UTC
I'm wondering whether this is linked in some way to the incorrect default window size bug on OSX ?
Comment 6 Alex Thurgood 2015-02-01 14:16:03 UTC
I'd also be tempted to put this in the MAB as it is really annoying to have to fullscreen then rescale the window
Comment 7 tim 2015-02-01 14:45:04 UTC
I was just about to raise the same fault in Base, on ubuntu 14.04 and xubuntu 14.04 with 4.4.0.3, when I found this duplicate.

The icons are invisible but the tooltips still show.

Note that is is about the additional navigation bar control. I use this quite a lot with subforms.
Comment 8 Julien Nabet 2015-02-01 21:15:38 UTC
On pc Debian x86-64 with 4.3 sources some days ago, I don't reproduce this whereas I could reproduce this 4.4 sources.
So definitely a regression.
Increase a bit importance since it's in all OS.
Comment 9 Julien Nabet 2015-02-02 21:05:19 UTC
2 evenings to try to understand all this by diving in this kind of bt:
#0  ImplImageTree::doLoadImage (this=0x2559fb0, name="cmd/sc_absoluterecord.png", style="tango", bitmap=..., localized=true)
    at /home/julien/compile-libreoffice/libreoffice/vcl/source/gdi/impimagetree.cxx:168
#1  0x00002aaab1d1369d in ImplImageTree::loadImage (this=0x2559fb0, name="cmd/sc_absoluterecord.png", style="tango", bitmap=..., localized=true, loadMissing=false)
    at /home/julien/compile-libreoffice/libreoffice/vcl/source/gdi/impimagetree.cxx:125
#2  0x00002aaab1cf574a in ImageAryData::Load (this=0x2d879e0, rPrefix="cmd/sc_") at /home/julien/compile-libreoffice/libreoffice/vcl/source/gdi/image.cxx:387
#3  0x00002aaab1cf6b0f in ImageList::GetImage (this=0x2dc4bd0, rImageName="absoluterecord.png") at /home/julien/compile-libreoffice/libreoffice/vcl/source/gdi/image.cxx:570
#4  0x00002aaac66dced9 in framework::CmdImageList::getImageFromCommandURL (this=0x282d4f0, nImageType=0, rCommandURL=".uno:AbsoluteRecord")
    at /home/julien/compile-libreoffice/libreoffice/framework/source/uiconfiguration/imagemanagerimpl.cxx:286
#5  0x00002aaac66dd257 in framework::GlobalImageList::getImageFromCommandURL (this=0x282d4f0, nImageType=0, rCommandURL=".uno:AbsoluteRecord")
    at /home/julien/compile-libreoffice/libreoffice/framework/source/uiconfiguration/imagemanagerimpl.cxx:327
#6  0x00002aaac66e063f in framework::ImageManagerImpl::getImages (this=0x2c8e910, nImageType=0, aCommandURLSequence=uno::Sequence of length 19 = {...})
    at /home/julien/compile-libreoffice/libreoffice/framework/source/uiconfiguration/imagemanagerimpl.cxx:895
#7  0x00002aaac66f2b0e in framework::ModuleImageManager::getImages (this=0x2c90970, nImageType=0, aCommandURLSequence=uno::Sequence of length 19 = {...})
    at /home/julien/compile-libreoffice/libreoffice/framework/source/uiconfiguration/moduleimagemanager.cxx:128
#8  0x00002aaad4c0fff3 in frm::DocumentCommandImageProvider::getCommandImages (this=0x2f680c0, _rCommandURLs=uno::Sequence of length 19 = {...}, _bLarge=false)
    at /home/julien/compile-libreoffice/libreoffice/forms/source/helper/commandimageprovider.cxx:138
#9  0x00002aaad4c76d5c in frm::NavigationToolBar::implUpdateImages (this=0x2fa5a60)
    at /home/julien/compile-libreoffice/libreoffice/forms/source/solar/control/navtoolbar.cxx:375
#10 0x00002aaad4c768fc in frm::NavigationToolBar::implInit (this=0x2fa5a60) at /home/julien/compile-libreoffice/libreoffice/forms/source/solar/control/navtoolbar.cxx:340
#11 0x00002aaad4c75c40 in frm::NavigationToolBar::NavigationToolBar (this=0x2fa5a60, _pParent=0x2c12300, _nStyle=0, _pImageProvider=
  boost::shared_ptr {_vptr.ICommandImageProvider = 0x2aaad510b390 <vtable for frm::DocumentCommandImageProvider+16>}, _pDescriptionProvider=
  boost::shared_ptr {_vptr.ICommandDescriptionProvider = 0x2aaad510b310 <vtable for frm::DefaultCommandDescriptionProvider+16>})
    at /home/julien/compile-libreoffice/libreoffice/forms/source/solar/control/navtoolbar.cxx:144

and nothing found, I give up :-(
Comment 10 Julien Nabet 2015-02-04 22:01:18 UTC
fdo#88836 is even more general and some interesting information are given by Matthew Francis.

*** This bug has been marked as a duplicate of bug 88836 ***