Bug 89051 - Paragraph justification not working for pdf exports
Summary: Paragraph justification not working for pdf exports
Status: CLOSED DUPLICATE of bug 88941
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: Other macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-02 16:39 UTC by Chris Tapp
Modified: 2015-02-02 21:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Test case (12.39 KB, application/vnd.oasis.opendocument.text)
2015-02-02 16:39 UTC, Chris Tapp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Tapp 2015-02-02 16:39:05 UTC
Created attachment 113056 [details]
Test case

The attached Writer file contains four paragraphs, all of which are justified. They show correctly in Writer (edit and print preview modes), but the text is unjustified when the document is exported as a pdf.

As shown in the third and fourth paragraphs, the behaviour for export is also affected by the inclusion of character styles within the text. It appears as if the additional spacing required to justify the text is all being inserted in the spaces between the unstyled and styled text rather than across all of the spaces on the line.

This problem was not present when using the 4.3.5 release.
Comment 1 Jean-Baptiste Faure 2015-02-02 20:28:12 UTC
Seems to be a duplicate of bug 88941 (OSX only).

Feel free to reopen if I am wrong.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 88941 ***
Comment 2 Chris Tapp 2015-02-02 21:12:01 UTC
Thanks, that does indeed look like the same issue.

I'll close this one and keep an eye on the other one instead ;-)