Bug Hunting Session
Bug 88941 - Writer/Calc/Draw/Impress lose formatting for justified text when exporting to PDF on OS X builds
Summary: Writer/Calc/Draw/Impress lose formatting for justified text when exporting to...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha2
Hardware: x86-64 (AMD64) Mac OS X (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard: noRepro:4.5.0.0alpha+:Win7 noRepro:4....
Keywords: bibisected, bisected, regression
: 89051 89569 89587 89876 91164 91402 91589 92790 92901 93026 95817 (view as bug list)
Depends on:
Blocks: mab4.4
  Show dependency treegraph
 
Reported: 2015-01-30 13:57 UTC by DeepFlight5
Modified: 2016-12-13 20:20 UTC (History)
33 users (show)

See Also:
Crash report or crash signature:


Attachments
PDF formatting of LO 4.3 and LO 4.4 (144.80 KB, image/png)
2015-01-30 13:57 UTC, DeepFlight5
Details
testfile, justified text, bigger spaced text (33.23 KB, application/vnd.oasis.opendocument.text)
2015-01-30 15:25 UTC, DeepFlight5
Details
test.pdf shows excessive gaps before superscripted words (25.49 KB, application/pdf)
2015-06-19 12:24 UTC, Iandol
Details
Illustration that right margin justification is faulty in 4.3.7.1 as well (222.19 KB, application/pdf)
2015-11-16 14:07 UTC, uwehob
Details

Note You need to log in before you can comment on or make changes to this bug.
Description DeepFlight5 2015-01-30 13:57:31 UTC
Created attachment 112954 [details]
PDF formatting of LO 4.3 and LO 4.4

After converting a Writer document with LO 4.4 to PDF some text formatting is lost. I returned to LO 4.3 since PDF exporting is crucial to me. See attached image.
Comment 1 Alex Thurgood 2015-01-30 14:33:40 UTC
Your screenshot show width justified text in 435 and left justified text in 440 - just checking, but I take it that the paragraph attributes weren't changed in between in the actual ODT ?

In order for us to be able to test this, we would need your document, or a similar reduced size one that displays the odd behaviour.

Setting to NEEDINFO, if information requested is provided, please set back to UNCONFIRMED
Comment 2 DeepFlight5 2015-01-30 15:25:31 UTC
Created attachment 112962 [details]
testfile, justified text, bigger spaced text
Comment 3 Jean-Baptiste Faure 2015-01-31 23:01:37 UTC
Not reproducible for me with version 4.4.1.0.0+ built at home under Ubuntu 14.10 x86-64.

Best regards. JBF
Comment 4 V Stuart Foote 2015-02-01 02:49:48 UTC
Can not reproduce on Windws 7 sp1, 64-bit en-US with
Version: 4.4.0.3
Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7
Locale: en_US

or with
Version: 4.5.0.0.alpha0+
Build ID: 4b9a9ce8a0e5e0716dad9a9ec87d16237e534dc2
TinderBox: Win-x86@39, Branch:master, Time: 2015-01-31_09:49:44
Locale: en_US

Correctly formatted gs based print to PDF, and correct formatting on Export to PDF
Comment 5 retired 2015-02-01 10:23:21 UTC
Confirmed > NEW
OSX 10.10.2, LO latest nightly from 2015-01-31

Open test file, use LO's own pdf export. Open exported PDF, both issues can be confirmed. Alignment of text on right side is not justified and spacing in mail address is gone.
Comment 6 Jean-Baptiste Faure 2015-02-02 20:28:12 UTC
*** Bug 89051 has been marked as a duplicate of this bug. ***
Comment 7 marcosgdf 2015-02-14 14:17:50 UTC
Confirmed in LO 4.4 Mac OS Yosemite

Versión: 4.4.0.3
Id. de compilación: de093506bcdc5fafd9023ee680b8c60e3e0645d7
Configuración regional: es_
Comment 8 Chris Tapp 2015-02-14 22:00:00 UTC
Note that I originally saw this under Mavericks.
Comment 9 bubu 2015-02-24 00:50:45 UTC
I confirm the bug
Comment 10 Alex Thurgood 2015-02-25 14:31:41 UTC
*** Bug 89569 has been marked as a duplicate of this bug. ***
Comment 11 Alex Thurgood 2015-02-25 14:33:15 UTC
*** Bug 89587 has been marked as a duplicate of this bug. ***
Comment 12 vincefn 2015-02-27 18:24:58 UTC
The bug is still present in LibreOffice 4.4.1, Mac OS X version :
Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale : fr_
Comment 13 Robinson Tryon (qubit) 2015-03-05 20:13:24 UTC Comment hidden (obsolete)
Comment 14 DeepFlight5 2015-03-06 10:48:04 UTC
(This is NOT an automated message.)

If the LO team is not interested in their own Bugzilla, why then reporting bugs anyway? On the other hand LO 4.3 runs well on OSX. So anyone relying on the PDF feature (like I do) should stay with 4.3 and be happy. LO 4.3 should run problem free the next 10 years on all upcoming OSX versions.
Comment 15 Tim Rieck 2015-03-06 10:54:29 UTC
(In reply to deepflight5 from comment #14)
> (This is NOT an automated message.)
> 
> If the LO team is not interested in their own Bugzilla, why then reporting
> bugs anyway? On the other hand LO 4.3 runs well on OSX. So anyone relying on
> the PDF feature (like I do) should stay with 4.3 and be happy. LO 4.3 should
> run problem free the next 10 years on all upcoming OSX versions.

There's a simply workaround for this bug, try to use OSX own pdf printer instead. Just press cmd+p for the printer dialog and choose save as pdf.
Comment 16 Chris Tapp 2015-03-06 11:09:54 UTC
But that's a very feature-deprived workaround as the export doesn't then include things like a table of contents, active links for cross-references, etc.
Comment 17 DeepFlight5 2015-03-06 11:17:07 UTC
I do a weekly newsletter that includes SVG vector graphics. Exported via the OSX Quartz engine all SVG ends up as garbage in Apple's Preview. Exported via the GhostScript of LibreOffice all SVG is in Preview just fine. So this workaround is not really working for me and my readers. (In Adobe Acrobat Reader the OSX exported PDF just looks perfect, but many readers of my newsletter are OSX users and rely on Preview.)
Comment 18 bubu 2015-03-06 16:57:03 UTC
This bug is very annoying. Could some devemopers try to resolve it ASAP ?

Regards
Comment 19 Alex Thurgood 2015-03-08 21:02:49 UTC
*** Bug 89876 has been marked as a duplicate of this bug. ***
Comment 20 bubu 2015-03-15 20:39:10 UTC
Hi,

This bug is still present il LO 4.4.2.1 Mac OS X.

Regards
Comment 21 DeepFlight5 2015-03-18 09:18:47 UTC
Experience with similar PDF/GhostScript problems in former incarnations of OOo/LO teaches, that this bug might be around for a very long time. So better stick to LO 4.3 on OSX since this is the last version working correctly. Except from the newly designed buttons and minor fixes you will miss nothing of importance. LO 4.3 runs just fine. Only update to 4.4+ on your Windows and Linux computers.
Comment 22 Robinson Tryon (qubit) 2015-03-18 16:41:24 UTC
(In reply to deepflight5 from comment #21)
> Experience with similar PDF/GhostScript problems in former incarnations of
> OOo/LO teaches, that this bug might be around for a very long time. So
> better stick to LO 4.3 on OSX since this is the last version working
> correctly.

Keyword -> regression
Whiteboard -> bibisectRequest (**NOTE: If someone wants to track this down with existing OSX bibisect work. For further information, someone could git-bisect this bug directly!)
Comment 23 Adolfo Jayme 2015-03-24 11:23:57 UTC
Removing “Blocks 42082”. See bug 42082 comment 14 for why.
Comment 24 Adolfo Jayme 2015-03-24 11:26:37 UTC
(In reply to deepflight5 from comment #14)
> If the LO team is not interested in their own Bugzilla, why then reporting
> bugs anyway?

Who ever said we’re not interested? You’re right. NOBODY. You’re just reacting like a jerk who can’t even bother to read what the message was about.
Comment 25 Jean-Baptiste Faure 2015-03-24 13:26:31 UTC
It is very surprising that this bug has not already been added to MAB 4.4.
We receive many questions on this subject on our  FR users mailing-list.
Done yet.

Best regards. JBF
Comment 26 Veronika 2015-03-25 14:58:31 UTC
The bug appears also in Draw
Version: 4.4.0.3
Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7
Locale: it_

Osx 10.10.2
Comment 27 V Stuart Foote 2015-03-25 18:06:33 UTC
(In reply to Veronika from comment #26)
> The bug appears also in Draw
> Version: 4.4.0.3
> Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7
> Locale: it_
> 
> Osx 10.10.2

Confirming that "Export to PDF" of text entered in Draw document as justified, looses some of its formatting in the resulting PDF.
Comment 28 M. Schmitt 2015-04-03 08:20:31 UTC
The bug still exists in version 4.4.2.2. :-(
Comment 29 Fiorenzo 2015-04-22 14:43:51 UTC
4.4.3.1 still affected
Comment 30 Alex Thurgood 2015-05-09 14:12:11 UTC
*** Bug 91164 has been marked as a duplicate of this bug. ***
Comment 31 Ben McGinnes 2015-05-16 07:09:32 UTC
I can confirm this bug affects the 64-bit versions of LO 4.4.2.2 and 4.4.3.2 on OS X 10.9.5 (Mavericks).

I cannot, however, provide a copy of the document in question as it relates to an imminent legal matter.

The work-around has been to revert to LO 4.3.7 which works normally (and with less crashes than OOo 4.1.1, as well as less irritation than saving as docbook and converting to pdf with pandoc via LaTeX).
Comment 32 deepjungle.maca 2015-05-18 23:49:31 UTC
This is really serious bug for Mac's users. I don't see we can expect fix in LO 5.0. It is a bad signal for LO reputation. Seriously, the newer LO wouldn't be released without fix of this.
Comment 33 mitja 2015-05-19 06:42:21 UTC
I completely agree with deepjungle.maca!
That is really really annoying bug.
I also had to downgrade to 4.3.
Comment 34 Ben McGinnes 2015-05-19 06:55:59 UTC
In addition to the versions I confirmed in comment 31, we can now add:

Version: 5.0.0.0.alpha1+
Build ID: 2ca7795a6a723c701f295323fcc3f6c52ad37976
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2015-05-18_00:48:47
Locale: en-US (en.UTF-8)
Comment 35 Vossman 2015-05-20 14:38:58 UTC
Attempting to do a version bisection, you too can download old versions here: https://downloadarchive.documentfoundation.org/libreoffice/old/

3.6.7.2(x86): correct formatting!
4.0.0.0(x86): correct formatting!
4.3.7.2: correct formatting!
4.4.0.0beta1: BAD formating
4.4.0.2: BAD formating
4.4.3.2: BAD formating

Unfortunately, the first beta of 4.4 has the bug. So, the bug was introduced between 4.3 and 4.4 making it harder to track down the commit that did it.

Changing version from 4.4.0.3 to 4.4.0.0beta1. I could not find the 4.4 alpha series.
Comment 36 Jean-Baptiste Faure 2015-05-20 19:16:07 UTC
*** Bug 91402 has been marked as a duplicate of this bug. ***
Comment 37 Ben McGinnes 2015-05-21 09:56:12 UTC
Two work-arounds for this ...

First, the easy and obvious one, which we all no doubt already use: keep a copy of 4.3.x handy for exporting to PDF.

Advantage: the output is always what we expect.

Disadvantages: it's a 650MB work-around which needs to be installed somewhere, ideally in a location that won't conflict with 4.4 and may have unintended consequences when accessing user profiles, especially if both are open or active at the same time.

Second, the more fiddly one, which takes a lot of trial and error to get right: it is possible to convert to PDF via Pandoc and LaTeX in a form closer to what was intended.

Requirements: Pandoc (available from pandoc.org), latexdiff (available from macports.org or tug.org), latexmk (available from macports.org or tug.org), texlive-latex (available from macports.org or tug.org), texlive-latex-extra (available from macports.org or tug.org), texlive-latex-recommended (available from macports.org or tug.org).  Alternatively the much smaller BasicTeX package (available from tug.org) can be substituted for a full installation, but it may require additional work to support all available fonts.

Method: save ODF as Microsoft .docx, edit as necessary (at minimum remove footers and page numbering) and then in the Terminal run (in the directory where the file is):

pandoc -f docx -t latex -o file.pdf file.docx

Note: that images are not included, points and bullets lose their content and tables take a bit of fiddling to word wrap correctly (may require faking it with multiple table rows and hiding the borders).  The output will always look like a LaTeX document, noticably different from LibreOffice and other PDFs.  Page numbering is automatic by default with numbers in the centre at the bottom of the page.  Also note that the best results with pandoc were achieved with Microsoft's docx format, both Docbook and HTML conversions resulted in extremely annoying editing challenges before producing the PDF (though a preliminary run using HTML could produce a LaTeX file with the relevant code to insert images to be pasted into another LaTeX conversion from a .docx file).

Advantages: Does not require two versions of LibreOffice, avoids user profile conflicts, saves space from second copy of LibreOffice (if BasicTex used or if LaTeX was installed anyway).

Disadvantages: LaTeX tools and libraries take more space than a second copy of LibreOffice (unless BasicTex is used), requires additional editing specific to producing the PDF, loses pictures (can be restored by exporting to LaTeX .tex first and editing the LaTeX code manually or with a LaTeX editor).

Recommendation: If you don't use LaTeX for anything else already and/or have no familiarity with it, do not use this workaround.  If you have used LaTeX and are cautious with available disk space, try the BasicTex variant of this work-around.  If you are more familiar with LaTeX then you might consider this work-around.

So, which do I use?  Both, with a full LaTeX installation, it depends on the target audience of whatever the document is.  If I don't use LaTeX I have to shutdown LibreOffice 4.4 before launching 4.3.  I've got 4.3.7.2 installed in /Applications/ and 4.4.3.2 installed in $HOME/Applications/ (to apply the language pack I copied the pack's bzipped tarball from the installer into $HOME/Applications/LibreOffice.app/ and extracted it via the Terminal).
Comment 38 deepjungle.maca 2015-05-23 08:41:48 UTC
LO 5.0 beta1 was released and no fix for this issue. Please, can any of LO developers gives us when they want to fix this? Because PDF export has becomes a bit useless function since LO 4.4 for Mac user. For me it is a crucial function.
Comment 39 Adolfo Jayme 2015-05-24 21:18:47 UTC
*** Bug 91589 has been marked as a duplicate of this bug. ***
Comment 40 Vossman 2015-05-27 18:29:27 UTC
I managed to build 4.4.0.0alpha2 and it has the formatting error. 4.4.0.0alpha1 would not compile for me.

Timeline of bug:
20 Nov 2014: 4.4.0.0beta1 tag created (release has bug)
 6 Nov 2014: 4.4.0.0alpha2 tag created (compile has bug)
19 Oct 2014: 4.4.0.0alpha1 tag created (unknown)
13 Oct 2014: 4.4 branch freeze

remember 4.3 branch does not have this bug, so I want to assume the bug was introduced in October 2014.

Possible files involved:
vcl/source/outdev/text.cxx
vcl/source/gdi/sallayout.cxx "To justify a text string, Writer calls OutputDevice::GetTextArray()"
vcl/source/gdi/pdfwriter.cxx
vcl/source/gdi/pdfwriter_impl.cxx

I do not know enough about these files to make a judgement, but there were a lot of changes. I was playing around with git to see the changes between the file and the October 4.3 branch (version 4.3.3.2):

git diff libreoffice-4.4.0.0.alpha2 libreoffice-4.3.3.2 vcl/source/gdi/pdfwriter_impl.cxx
Comment 41 Vossman 2015-05-27 18:44:45 UTC
I just confirmed that this applies to both Calc and Presentation as well. So, perhaps we can remove Writer/Draw from title of bug, but it applies to all justified text.
Comment 42 Iandol 2015-06-19 12:23:48 UTC
An additional rendering glitch concerns italics and superscripted words within justified text, the test.pdf shows gaps before superscripted characters but this also happens with italicised text too.
Comment 43 Iandol 2015-06-19 12:24:58 UTC
Created attachment 116651 [details]
test.pdf shows excessive gaps before superscripted words

see previous comment
Comment 44 Matthew Francis 2015-06-26 08:17:44 UTC
This seems to have been introduced by the below commit.
Adding Cc: to nthiebaud@gmail.com; Could you possibly take a look at this one? Thanks

commit cd3d26b7edbce67805259a71e4118223e02ebdd4
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Fri Jul 18 18:21:12 2014 +0200

    vcl consitent use of long for corrdinate
    
    most of length in vcl are calculated in 'long'
    but array of X position tend to be in sal_Int32.
    As a prep work to be able to support 'double'
    as the base type of Device Coordinate, harmonize
    the use of 'long' for non-float coordinate.
    
    Change-Id: I7cb33301ff6a5e2c62247b36a4e07e168a58a323
Comment 45 Commit Notification 2015-07-04 05:35:22 UTC
Norbert Thiebaud committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ab39f8c213bffa00f2b196c05a23ab3ccda8f901

tdf#88941 Revert "vcl quartz: Add support back for DXArray tweaking"

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 46 Commit Notification 2015-07-04 16:13:11 UTC
Norbert Thiebaud committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e67b3ef2fd38510634106dbf422762af1e4633e9&h=libreoffice-5-0

tdf#88941 Revert "vcl quartz: Add support back for DXArray tweaking"

It will be available in 5.0.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 47 vincefn 2015-07-05 12:47:58 UTC
This seems to be corrected now, at least the 5.1 alpha build of this morning (http://dev-builds.libreoffice.org/daily/master/MacOSX-x86_64@49-TDF/2015-07-05_10.41.24)
correctly justifies the test .odt file when exporting to pdf. (I did not make more tests)

Since 5.x stable may be a bit far off, it would be good to push this back also to the 4.x branch.

Thanks for the patch and finding the bug.
Comment 48 steve -_- 2015-07-05 13:44:17 UTC
verified fix as of comment 47.

thanks so much Norbert, for looking into this bug affecting a lot of OS X users.
Comment 49 bubu 2015-07-05 15:58:17 UTC
Un énorme merci à Norbert Thiebaud qui a corrigé ce bug gênant.

A huge thank you to Norbert Thiebaud who corrected this annoying bug.
Comment 50 bubu 2015-07-05 16:02:19 UTC
Just FYI, here is an interview of Norbert :

https://blog.documentfoundation.org/2010/11/25/developer-interview-norbert-thiebaud/
Comment 51 Iandol 2015-07-05 17:28:43 UTC
The weird gaps before superscripted or italicised words is no longer present either, can confirm fixed here. so I can finally delete 4.3.x! 

It would be good to see this go into 4.4.x too. A thank you to Norbert for taking the time to revert this.
Comment 52 Ben McGinnes 2015-07-07 22:23:53 UTC
Confirmed that this has fixed the errors I was seeing (with the same document referred to originally) in this build:

Version: 5.1.0.0.alpha1+
Build ID: 0251e61640b94094918406b33ee7b05564409feb
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2015-07-06_23:27:49
Locale: en-US (en.UTF-8)

Thanks for the fix, I'm looking forward to a stable deployment later in the year.
Comment 53 V Stuart Foote 2015-07-19 03:53:19 UTC
*** Bug 92790 has been marked as a duplicate of this bug. ***
Comment 54 Alex Thurgood 2015-07-24 07:30:48 UTC
*** Bug 92901 has been marked as a duplicate of this bug. ***
Comment 55 wu.ming2 2015-07-24 10:33:22 UTC
Print to PDF is not a option from Impress because doesn't use native print dialogs and page format is fixed to Portrait.  Impress is generally Landscape.
Comment 56 Alex Thurgood 2015-07-30 15:45:32 UTC
*** Bug 93026 has been marked as a duplicate of this bug. ***
Comment 57 maxx366 2015-07-30 16:27:22 UTC
This problem is still happening through today, July 30th, 2015, so it does not seem to be fixed, at least not for Writer.  I hope this can be fixed in version 5.0, as noted in some of the comments below.  Thank you.
Comment 58 Alex Thurgood 2015-07-30 17:25:01 UTC
(In reply to maxx366 from comment #57)
> This problem is still happening through today, July 30th, 2015, so it does
> not seem to be fixed, at least not for Writer.  I hope this can be fixed in
> version 5.0, as noted in some of the comments below.  Thank you.

@maxx: in which version of 5.0 ? The fix was only supposed to be integrated as from 5.0.0.3, so it should be in rc4 currently available to download. If it isn't then we need to bump this open again, or try and find out why the fix hasn't yet gone into 5.0.x
Comment 59 maxx366 2015-07-30 17:52:19 UTC
(In reply to Alex Thurgood from comment #58)
> (In reply to maxx366 from comment #57)
> > This problem is still happening through today, July 30th, 2015, so it does
> > not seem to be fixed, at least not for Writer.  I hope this can be fixed in
> > version 5.0, as noted in some of the comments below.  Thank you.
> 
> @maxx: in which version of 5.0 ? The fix was only supposed to be integrated
> as from 5.0.0.3, so it should be in rc4 currently available to download. If
> it isn't then we need to bump this open again, or try and find out why the
> fix hasn't yet gone into 5.0.x

Thanks for the quick reply.  I was only perusing the comments with my reference to version 5.0 -- I am not testing it because I'm just a normal user and probably lack the knowledge to best apply the advance releases.  Based on your comment, however, perhaps I will try rc4.  Thanks.
Comment 60 maxx366 2015-07-30 18:00:49 UTC
(In reply to Alex Thurgood from comment #58)
> (In reply to maxx366 from comment #57)
> > This problem is still happening through today, July 30th, 2015, so it does
> > not seem to be fixed, at least not for Writer.  I hope this can be fixed in
> > version 5.0, as noted in some of the comments below.  Thank you.
> 
> @maxx: in which version of 5.0 ? The fix was only supposed to be integrated
> as from 5.0.0.3, so it should be in rc4 currently available to download. If
> it isn't then we need to bump this open again, or try and find out why the
> fix hasn't yet gone into 5.0.x

Perhaps I wasn't clear; sorry.  When I wrote that the problem was still happening through today, I meant with all versions of Libre 4.4, including the one that was released earlier today (4.4.5).  To avoid it, I opted to revert to version 4.3.7 until the bug is fixed.  Thanks.
Comment 61 maxx366 2015-08-05 15:23:27 UTC
(In reply to maxx366 from comment #60)
> (In reply to Alex Thurgood from comment #58)
> > (In reply to maxx366 from comment #57)
> > > This problem is still happening through today, July 30th, 2015, so it does
> > > not seem to be fixed, at least not for Writer.  I hope this can be fixed in
> > > version 5.0, as noted in some of the comments below.  Thank you.
> > 
> > @maxx: in which version of 5.0 ? The fix was only supposed to be integrated
> > as from 5.0.0.3, so it should be in rc4 currently available to download. If
> > it isn't then we need to bump this open again, or try and find out why the
> > fix hasn't yet gone into 5.0.x
> 
> Perhaps I wasn't clear; sorry.  When I wrote that the problem was still
> happening through today, I meant with all versions of Libre 4.4, including
> the one that was released earlier today (4.4.5).  To avoid it, I opted to
> revert to version 4.3.7 until the bug is fixed.  Thanks.

This issue was fixed in today's general release of version 5.0 -- thank you very much!
Comment 62 Iandol 2015-08-05 16:21:19 UTC
Is there a reason this is not being backported — you have a fix for a major platform bug in the 4.4 series yet haven't backported it yet?
Comment 63 Paolo Cesari 2015-09-01 08:09:12 UTC
(In reply to maxx366 from comment #61)
> (In reply to maxx366 from comment #60)
> > (In reply to Alex Thurgood from comment #58)
> > > (In reply to maxx366 from comment #57)
> > > > This problem is still happening through today, July 30th, 2015, so it does
> > > > not seem to be fixed, at least not for Writer.  I hope this can be fixed in
> > > > version 5.0, as noted in some of the comments below.  Thank you.
> > > 
> > > @maxx: in which version of 5.0 ? The fix was only supposed to be integrated
> > > as from 5.0.0.3, so it should be in rc4 currently available to download. If
> > > it isn't then we need to bump this open again, or try and find out why the
> > > fix hasn't yet gone into 5.0.x
> > 
> > Perhaps I wasn't clear; sorry.  When I wrote that the problem was still
> > happening through today, I meant with all versions of Libre 4.4, including
> > the one that was released earlier today (4.4.5).  To avoid it, I opted to
> > revert to version 4.3.7 until the bug is fixed.  Thanks.
> 
> This issue was fixed in today's general release of version 5.0 -- thank you
> very much!

I confirm that the bug was fixed in version 5.0
Thanks!!
Comment 64 Cor Nouws 2015-09-01 11:06:38 UTC
@norbert: could this be backported to 4.4 ?
Comment 65 V Stuart Foote 2015-11-14 13:31:48 UTC
*** Bug 95817 has been marked as a duplicate of this bug. ***
Comment 66 V Stuart Foote 2015-11-16 01:39:13 UTC
*** Bug 95838 has been marked as a duplicate of this bug. ***
Comment 67 uwehob 2015-11-16 12:17:16 UTC
You reply to my bug report 95838 that this is a duplicate of bug 88941. 88941, however, concerns only PDF export. The bug I reported can be seen in LO during text editing as words cut with an invisible right portion.

It is claimed that this bug has been corrected in LO 5.0, however, as I have indicated, it is still there in LO 5.0.1
Comment 68 uwehob 2015-11-16 14:07:46 UTC
Created attachment 120580 [details]
Illustration that right margin justification is faulty in 4.3.7.1 as well
Comment 69 V Stuart Foote 2015-11-16 14:30:41 UTC
(In reply to uwehob from comment #68)
> Created attachment 120580 [details]
> Illustration that right margin justification is faulty in 4.3.7.1 as well

No, that is all correct--this is fixed. The patch for incorrect justification in PDF was not back ported to the LO 4.4 releases.  Your PDF example shows the correct handling of justified text in PDF for 5.0.3 (as patched at 5.0.0.3).

As to issues of bug 95838, agree with Ben M that is a different issue, and closing as duplicate was incorrect. Comments there.
Comment 70 Robinson Tryon (qubit) 2015-12-17 08:45:44 UTC Comment hidden (obsolete)