Bug Hunting Session
Bug 89100 - FILEOPEN: DOCX - File no longer opens in LO 5.0+ (SAXParseException line 2)
Summary: FILEOPEN: DOCX - File no longer opens in LO 5.0+ (SAXParseException line 2)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: highest major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: 79329 89088 89858
  Show dependency treegraph
 
Reported: 2015-02-03 22:46 UTC by Yousuf Philips (jay) (retired)
Modified: 2015-12-15 11:03 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-02-03 22:46:52 UTC
While reviewing attachment 97273 [details] in bug 79329, i noticed that the document is no longer openable in master. Opening it in master gives the following error.

File format error found at Cannot extract an Any(void) to boolean!
SAXParseException: "[word/document.xml line 2]: unknown error" stream "word/document.xml", Line 2, Column 108512(row,col).

Version: 4.5.0.0.alpha0+
Build ID: d1c9bd13ec7af93f5368dfda6d6d3c955f0b0816
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2015-01-28_00:25:56

This is a regression as it opens in 4.4 daily.

Version: 4.4.1.0.0+
Build ID: 2b325c5c009c1a73345520c03ffbf03dc4600eff
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:libreoffice-4-4, Time: 2015-01-22_19:47:54
Comment 1 Buovjaga 2015-02-07 19:41:42 UTC
Confirmed.

Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: 99c00b090533da9818444be2831b8da0e713e5f9
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-02-04_06:38:53
Locale: fi_FI
Comment 2 Matthew Francis 2015-02-16 10:32:49 UTC
In vmiklos' 45 bibisect tree:
commit 2c90961ee3f99eff4168c9756bc2124239314022
Author: Miklos Vajna <vmiklos@collabora.co.uk>
Date:   Fri Jan 23 05:58:20 2015 +0100

    2015-01-23: source-hash-5d47b83cef0b2d0486162989722b23e53eb0cdb1


Possibly the following? If so, the "new" failure is more symptom than cause...

commit ebf767eeb2a169ba533e1b2ffccf16f41d95df35
Author: Michael Stahl <mstahl@redhat.com>
Date:   Thu Jan 22 12:50:07 2015 +0100

    writerfilter: DOCX import: better error handling than "catch (...) {}"
    
    If there is a SAXParseException, OOXMLDocumentImpl::resolve() should not
    ignore it, because if it occurs in a substream some end tag handlers may
    not have been run and the DomainMapper may be in an inconsistent state,
    so continuing to parse the outer document is probably not a good idea.
    
    Also add some exception mangling so sfx2 can present a useful error
    dialog.
    
    Change-Id: I169ba6db25f2ae264af08a64edf76a6bf6757f85
Comment 4 Matthew Francis 2015-05-06 13:54:49 UTC
Confirmed that it was ebf767eeb2a169ba533e1b2ffccf16f41d95df35 where the visible error started, though as mentioned the commit probably only uncovered another pre-existing issue

Adding Cc: to mstahl@redhat.com; Any thoughts on this one?
Comment 5 tommy27 2015-05-24 07:46:30 UTC
file can be opened in LibO 4.4.1.2 and can't be opened in LibO 5.1.0.0.alpha1+
Build ID: 83eb114394879cbfd073322a51c47d02553c1fcf
TinderBox: Win-x86@39, Branch:master, Time: 2015-05-22_06:33:51
Locale: en-US (it_IT)

this is the error message I receive, hope this can help.

File format error found at Cannot extract an Any(void) to boolean!
SAXParseException: '[word/document.xml line 2]: unknown error', Stream 'word/document.xml', Line 2, Column 108512(row,col).
Comment 6 Timur 2015-06-01 10:30:47 UTC
Similar problem with attachment 116217 [details] from Bug 79639.
Comment 7 Timur 2015-08-04 12:43:41 UTC
Bug still in 5.0.0.5.
Comment 8 Timur 2015-08-27 13:21:39 UTC
*** Bug 92157 has been marked as a duplicate of this bug. ***
Comment 9 Patricio Stegmann 2015-09-15 14:56:29 UTC
Confirm still bugging on Version: 5.0.1.2
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Locale: en-US (en_US)
Windows 10 64 bits
Comment 10 Mike Kaganski 2015-11-12 11:56:30 UTC
Cannot reproduce anymore with Version: 5.1.0.0.alpha1+
Build ID: 86043a2f57a9f50cabe689dd5e9f8db0dbd16f80
Locale: ru-RU (ru_RU)
under Win10x64
Comment 11 Buovjaga 2015-11-12 12:12:32 UTC
Yep, no I could open both attachment 97273 [details] and attachment 116217 [details]. Closing as WFM.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: b216cc1b8096eb60c27f67e8c27b7cd756c75e38
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-11-12_00:06:20
Locale: fi-FI (fi_FI)
Comment 12 Timur 2015-11-12 15:45:15 UTC
Attachments from bugs 79329 77374 79639 89858 can be open with master, but not with 5.0.3.2. 
Attachments from bugs 91061 80175 still can't be open, so I'm removing references to them.
Comment 13 Robinson Tryon (qubit) 2015-12-15 11:03:28 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]