Bug 89108 - Crash when using pivot table and two delete keys pressed on Available Fields
Summary: Crash when using pivot table and two delete keys pressed on Available Fields
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: Other All
: high major
Assignee: Caolán McNamara
URL:
Whiteboard:
Keywords:
: 89117 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-02-04 07:06 UTC by grofaty
Modified: 2015-02-04 16:48 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description grofaty 2015-02-04 07:06:52 UTC
Tested in LibreOffice 4.3.5.2 Calc on Windows 7.

1. Type in text in fields:
A1: London
A2: Berlin
B1: 100
B2: 100
2. Mark fields A1:B2.
3. Data | Pivot Table | Create.
4. Select Source window opens. Click on OK to accept default.
5. Pivot Table Layout appears.
6. Click on member "100" from within Available Fields.
7. Press Delete to delete "100" member. It is deleted.
8. Press Delete to delete "London" member. It is deleted.
9. Now press one more time Delete key and LibreOffice crashes.

This is very similar problem to: https://bugs.documentfoundation.org/show_bug.cgi?id=88455 that was already fixed few days ago, so maybe fix can be very similar.
Comment 1 raal 2015-02-04 07:42:33 UTC
I can reproduce crash with 4.4.0.3
ID build: de093506bcdc5fafd9023ee680b8c60e3e0645d7
win7
Comment 3 Caolán McNamara 2015-02-04 16:48:20 UTC
*** Bug 89117 has been marked as a duplicate of this bug. ***