Bug 89240 - Upgrade Should Take Place Within Software - No Need to Download/Install Separately
Summary: Upgrade Should Take Place Within Software - No Need to Download/Install Separ...
Status: RESOLVED DUPLICATE of bug 54242
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-08 23:05 UTC by Jason Hartley
Modified: 2015-02-09 07:48 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Hartley 2015-02-08 23:05:49 UTC
Situation:
A new version of LibreOffice is available.  An alert is given asking user to download the upgrade.

Current behavior:
 - Click in-app link for download
 - Redirected to website
 - Click download link
 - Downloads new version of .dmg (TIME CONSUMING STEP #1)
 - Double-click/mount the .dmg
 - Install new version by copying app into Applications folder (TIME CONSUMING STEP #2)
 - Select "Replace" when warned about copying over old version
 - Convince self that with annoying behaviour will eventually be fixed
 - Restart app

Expected behavior:
 - Click in-app link for download
 - Updated code downloads in-app
 - Restart app
Comment 1 Joel Madero 2015-02-08 23:17:40 UTC
we know that the updater needs work and this is likely a dupe but I'll mark it as a valid enhancement request. Affects all platforms.
Comment 2 Joel Madero 2015-02-08 23:18:18 UTC
FWIW this is unlikely to be resolved any time soon. A volunteer will have to accept looking into the code - it's been broken for years and no one seems terribly interested in fixing it. If you or someone you know would like to file a patch, that would be fantastic.
Comment 3 V Stuart Foote 2015-02-09 03:46:16 UTC
Sorry. Not an issue with the updater--which at best will indicate that an updated release exists. 

Simply put, there is no functional way to achieve the requisite incremental upgrades with our cross platform code base--and frankly a clean install over an existing installation is the most reliable way to deliver the application. That is how the project is designed and maintained.

With upgrade, user configuration is isolated and transitions with few issues. But even then profiles are easily cleared to ensure functional upgrade.

Incremental upgrades would be a horrible user experience and a configuration/development nightmare.

No sense to even asking for this--won't happen. Can't happen.

Resolving Wontfix.
Comment 4 Joel Madero 2015-02-09 05:17:21 UTC
I've heard a different opinion from some experienced developers...are you 100% sure that it's completely not possible? Our bar for enhancement requests is quite low - if it's possible and sensible, we leave it open, even if it'll never get implemented.
Comment 5 Joel Madero 2015-02-09 05:22:23 UTC
See also bug 74934
Comment 6 Jason Hartley 2015-02-09 06:18:41 UTC
An excellent example of the expected behavior is the IntelliJ IDE.  Here's how they did it: https://github.com/JetBrains/intellij-community/tree/master/updater/src/com/intellij/updater

Software development is not driven by what is easy for the developer, it's driven by what's easy for the user.  As a developer, I empathize with you not wanting to rewrite the installer.  But as a user of LibreOffice, I'm telling you this behavior is infuriating and embarrassingly antiquated.  Little details like this are all it takes to turn users off from ever again wanting to use the software.
Comment 7 Joel Madero 2015-02-09 06:20:28 UTC
@Jason - of course patches are welcome...we are a community of volunteers, as a developer I hope you take the time to contribute the much needed developer time to implement this.
Comment 8 Jason Hartley 2015-02-09 06:24:23 UTC
@Joel, I'm a Java dev.  I looked at your source-- I don't even remotely have the skills to write anything other than Hello World in C++.  The most I can do for now is complain.  :-/
Comment 9 Adolfo Jayme 2015-02-09 07:48:00 UTC
(In reply to V Stuart Foote from comment #3)
> Incremental upgrades would be a horrible user experience and a
> configuration/development nightmare.
> 
> No sense to even asking for this--won't happen. Can't happen.

Nonsense.

> Resolving Wontfix.

Wrong resolution.

Incremental updates are desirable, and are an absolute improvement in user experience, since we update frequently and users should not have to download hundreds of MB all the time, not everybody lives in a “first-world” country and have fast, unmetered Internet connections.

So yes, this is a duplicate…

*** This bug has been marked as a duplicate of bug 54242 ***