Bug 89381 - ValueSet has rendering issues in RTL interface
Summary: ValueSet has rendering issues in RTL interface
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.0 target:5.0.2 target:4.4.6
Keywords: bibisected, bisected, regression
: 88973 91148 91853 93939 (view as bug list)
Depends on:
Blocks: RTL-CTL Gallery
  Show dependency treegraph
 
Reported: 2015-02-14 20:23 UTC by yousifjkadom
Modified: 2016-10-23 21:17 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
file.1 (80.55 KB, image/jpeg)
2015-02-27 11:01 UTC, yousifjkadom
Details
file.2 (47.67 KB, image/jpeg)
2015-02-27 11:03 UTC, yousifjkadom
Details
file.3 (82.27 KB, image/jpeg)
2015-02-27 11:04 UTC, yousifjkadom
Details
file.4 (118.90 KB, image/jpeg)
2015-02-27 11:04 UTC, yousifjkadom
Details
file.5 (121.36 KB, image/jpeg)
2015-02-27 11:05 UTC, yousifjkadom
Details
file.6 (119.12 KB, image/jpeg)
2015-02-27 11:05 UTC, yousifjkadom
Details
screencast (1.31 MB, video/webm)
2015-02-27 12:18 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description yousifjkadom 2015-02-14 20:23:37 UTC
Hi. I test version 4.4.0.3 & note the following:
If UI in English no problem. But if switch to Arabic then some contents malpositioned with wrong orientation & lebal. For ex: Bullets & numbering, font color & highlighting ...... .
   When I enter font color & try to chose then choice sequar appear in malposition & color that I chose for ex: red not appear but appear green!!

--------------------------
   Also I note that compatiblity with Microsoft Office created documents downgraded also in regard for alignment even if document in English !!
Comment 1 Adolfo Jayme 2015-02-14 20:32:31 UTC
Screenshot?
Comment 2 yousifjkadom 2015-02-15 18:08:01 UTC
 Hi. Sorry for dely in reply. Unfortuantly I have no screenshoot program available to me on my PC. 
 You can test bug by yourself. Just switch UI to Arabic & try font color & you will see it very obvious.
 Best.
Comment 3 Buovjaga 2015-02-24 05:57:35 UTC
(In reply to yousifjkadom from comment #2)
>  Hi. Sorry for dely in reply. Unfortuantly I have no screenshoot program
> available to me on my PC. 
>  You can test bug by yourself. Just switch UI to Arabic & try font color &
> you will see it very obvious.
>  Best.

If you are on Windows, you can press the PrtScn (Print Screen) button on your keyboard and then open Windows Paint and paste your screenshot there. Save as .jpg and attach here.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the screenshot.
Comment 4 yousifjkadom 2015-02-27 11:01:36 UTC
Created attachment 113739 [details]
file.1
Comment 5 yousifjkadom 2015-02-27 11:03:40 UTC
Created attachment 113740 [details]
file.2
Comment 6 yousifjkadom 2015-02-27 11:04:15 UTC
Created attachment 113741 [details]
file.3
Comment 7 yousifjkadom 2015-02-27 11:04:45 UTC
Created attachment 113742 [details]
file.4
Comment 8 yousifjkadom 2015-02-27 11:05:25 UTC
Created attachment 113743 [details]
file.5
Comment 9 yousifjkadom 2015-02-27 11:05:54 UTC
Created attachment 113745 [details]
file.6
Comment 10 yousifjkadom 2015-02-27 11:06:23 UTC
These screenshot taken using version 4.4.1.2
Comment 11 Yousuf Philips (jay) (retired) 2015-02-27 12:03:24 UTC
Confirmed on 4.4 daily the problem with the color drop down.

Confirmed on 4.4 daily the bullets dialog problem that isnt there in 4.3.5. I believe the changes made by maxim in bug 85804 may have contributed to this.
Comment 12 Yousuf Philips (jay) (retired) 2015-02-27 12:18:34 UTC
Created attachment 113746 [details]
screencast

Testing the same issue on linux, it seems like there is some visual corruption in all of these places, including the bullet drop down as well.

None of this happens when i'm in the english UI.
Comment 13 yousifjkadom 2015-08-05 17:44:36 UTC
Bug is still esisting without any fix on version 5.0.0.5!! This is just UI bug & still not fixed till now! Version 5 become available & this bug not fixed!! This disapointing.
Comment 14 Maxim Monastirsky 2015-08-05 19:29:53 UTC
*** Bug 91853 has been marked as a duplicate of this bug. ***
Comment 15 Maxim Monastirsky 2015-08-05 19:30:18 UTC
*** Bug 91148 has been marked as a duplicate of this bug. ***
Comment 16 Maxim Monastirsky 2015-08-05 19:40:49 UTC
All the affected controls are ValueSet based, and I can confirm this in other ValueSet based controls as well, so probably there is some shared problem in it. Increasing importance to high-major, because it makes several key features unusable with RTL interface.

Tip for QA: You don't need RTL langpack for this. It's enough to export SAL_RTL_ENABLED=1 before starting LO.
Comment 17 Maxim Monastirsky 2015-08-11 11:22:40 UTC
*** Bug 88973 has been marked as a duplicate of this bug. ***
Comment 18 Maxim Monastirsky 2015-08-23 12:08:40 UTC
Well, this is the bad commit:

commit 28effca640fff262866d1d3ada6e51a3821a6725
Author: Chris Sherlock <chris.sherlock79@gmail.com>
Date:   Sat Nov 15 17:05:11 2014 +1100

    vcl: SalGraphics::mirror() - always use GetGraphicsWidth()
    
    There's never a case where we need to get the width from VirtualDevice,
    we really should only get it from the SalGraphics instance. This vastly
    simplifies matters.
    
    Change-Id: I8bae9c163fcb0ce5d064d802c2783437124ebcb2
    Reviewed-on: https://gerrit.libreoffice.org/12473
    Reviewed-by: Chris Sherlock <chris.sherlock79@gmail.com>
    Tested-by: Chris Sherlock <chris.sherlock79@gmail.com>

Reverting it fixes the bug, without any visual side effects.
Comment 19 Maxim Monastirsky 2015-08-23 13:03:43 UTC
I submitted the revert to gerrit:

https://gerrit.libreoffice.org/17937/

I'm not familiar with this code, so I'll wait for someone who is familiar to review the patch.
Comment 20 Yousuf Philips (jay) (retired) 2015-08-23 14:15:02 UTC
CCing Chris to see if he can give his input on this.
Comment 21 Commit Notification 2015-08-24 12:16:36 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d2c09305084c218facdd282c3232a9929b81e342

tdf#89381 Revert "vcl: SalGraphics::mirror() - always use GetGraphicsWidth()"

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2015-08-24 12:17:51 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=287aaa33c27a651ace5c37ed71f1dad4f1b28379&h=libreoffice-5-0

tdf#89381 Revert "vcl: SalGraphics::mirror() - always use GetGraphicsWidth()"

It will be available in 5.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 23 Yousuf Philips (jay) (retired) 2015-08-24 15:22:26 UTC
Cherry-picked it for 4.4 and 5.0.1.
Comment 24 Commit Notification 2015-08-24 19:56:54 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=df3b4a1604339eadab2f320eaf0e79ba8f4b6806&h=libreoffice-4-4

tdf#89381 Revert "vcl: SalGraphics::mirror() - always use GetGraphicsWidth()"

It will be available in 4.4.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 25 Maxim Monastirsky 2015-09-05 19:07:05 UTC
*** Bug 93939 has been marked as a duplicate of this bug. ***
Comment 26 yousifjkadom 2015-09-26 16:40:21 UTC
I test version 5.0.2 This bug is fixed. Thank you.
Comment 27 Robinson Tryon (qubit) 2015-12-17 08:46:48 UTC Comment hidden (obsolete)