Bug Hunting Session
Bug 89473 - When exporting to PDF get black squares instead of images (workaround: Right-click "Compress Graphic" and "Calculate")
Summary: When exporting to PDF get black squares instead of images (workaround: Right-...
Status: RESOLVED DUPLICATE of bug 103833
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pdf, preBibisect, regression
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2015-02-19 15:20 UTC by Eugene Saenko
Modified: 2017-02-09 00:25 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
The problem source file (54.75 KB, application/vnd.oasis.opendocument.text)
2015-02-19 15:20 UTC, Eugene Saenko
Details
Test image (49.77 KB, image/png)
2017-02-08 22:53 UTC, Jan Lachnitt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Saenko 2015-02-19 15:20:04 UTC
Created attachment 113502 [details]
The problem source file

When exporting sertain document (it is attached) to PDF or printing this document using 
"Printer Language=PDF" 
in printer settings I get black squares instead of images. 
If printing with "Printer Language=PostScript" images are OK.
On print preview images are OK.
Comment 1 Buovjaga 2015-02-24 11:55:59 UTC
Tested with Export to pdf.

Only reproducible on Linux, even 3.5.0.
Not reproducible with 3.3.0, but we can't bibisect older than 3.5.

Win 7 Pro 64-bit, LibO Version: 4.4.0.3
Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7
Locale: fi_FI

Ubuntu 14.10 64-bit Version: 4.5.0.0.alpha0+
Build ID: 6b3aa0fe4094e87290bd33a30bd6cd99ee78ce38
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-02-16_21:52:18
Locale: en_US

Version: 4.4.0.3
Build ID: 40m0(Build:3)
Locale: en_US

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735

Version: 4.2.0.4
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71
Comment 2 Robinson Tryon (qubit) 2015-03-05 18:46:19 UTC Comment hidden (obsolete)
Comment 3 Jan Lachnitt 2015-03-09 15:03:14 UTC
I am getting exactly the same problem with another image.

LibreOffice 4.4.1.2, build ID 40m0(Build:2), locale cs_CZ
Linux Mint 17 64-bit
Comment 4 Robinson Tryon (qubit) 2015-12-10 01:26:43 UTC Comment hidden (obsolete)
Comment 5 Xisco Faulí 2016-09-14 22:14:53 UTC
Replacing keyword 'notBibisectable' by 'preBibisect' as this bug is outside the bibisect range
Comment 6 Timur 2016-11-10 18:09:10 UTC
Another example, this time in Windows: attachment 76865 [details] from Bug 38619 now prints with black square instead of WMF. So I change Linux to All.

As in Bug 77525, workaround is:
1. Right click on the image and select "Compress Graphic"
2. In the Compress Graphic dialogue click "Calculate"

As in Bug 103833, I ask: should this be done automatically on fileopen?
Comment 7 Timur 2016-12-05 11:37:47 UTC
This should be tested with and without OpenGL set in Tools-Options-LO-View (restart LO after change).
After driver reinstallation for AMD Radeon 6450, I have OpenGL blacklisted and I can't reproduce this, only if I force OpenGL.
Comment 8 V Stuart Foote 2017-02-07 16:40:30 UTC
(In reply to Jan Lachnitt from comment #3)
> I am getting exactly the same problem with another image.
> 
> LibreOffice 4.4.1.2, build ID 40m0(Build:2), locale cs_CZ
> Linux Mint 17 64-bit

Could you please post that as a test document, or possibly extract the image and post it. Thus far we only have the one set of problem PNG images from the document attached in comment 0 above.

Would be helpful to narrow the types of images that cause this problem.
Comment 9 V Stuart Foote 2017-02-07 16:55:40 UTC
@Jan Lachnitt, the NEEDINFO is to you, if you would please and then set back to NEW.  Thanks!
Comment 10 Jan Lachnitt 2017-02-08 22:53:19 UTC
Created attachment 131025 [details]
Test image

Test image is attached, simply insert it in a document and export as PDF. No matter if HW acceleration or OpenGL is enabled or not, the image renders as a black rectangle in the PDF file. However, if OpenGL is enabled, it renders as a black rectangle even in LO!

LO 5.1.4 (build 1:5.1.4-0ubuntu1) on 64-bit Linux Mint 18 Cinnamon. PDF viewer: Xreader 1.0.8.
Comment 11 V Stuart Foote 2017-02-08 23:54:10 UTC
@Jan,

(In reply to Jan Lachnitt from comment #10)
> Created attachment 131025 [details]

Thank you for posting. Your image confirms our issues is of handling "bilevel" PNG as in bug 103833

Closing this as duplicate of that but will list your attachment there.

*** This bug has been marked as a duplicate of bug 103833 ***
Comment 12 Jan Lachnitt 2017-02-09 00:13:35 UTC
IMHO, Bug 103833 should be marked as a duplicate of this bug, because this one was reported earlier. Moreover, I don't understand how PDF export or printing is related to OpenGL rendering. However, I am not a LO developer, so you decide.
Comment 13 V Stuart Foote 2017-02-09 00:25:55 UTC
(In reply to Jan Lachnitt from comment #12)
> IMHO, Bug 103833 should be marked as a duplicate of this bug, because this
> one was reported earlier. Moreover, I don't understand how PDF export or
> printing is related to OpenGL rendering. However, I am not a LO developer,
> so you decide.

Doing the QA admin for clear duplicates we generally will use the earliest instance.

Here though, the PDF export and the OpengGL rendering are crossing paths. This initially was about the mishandling for PDF export--but the root cause in the VCL source will most likely be the same.  The newer bug in this instance was more on point, the "bilevel" PNG having been split from other image handling issues.

Either way--thank you for contributing.