Download it now!
Bug 89758 - UI for the crop image function is now wrong the result looks like resizing instead of cropping
Summary: UI for the crop image function is now wrong the result looks like resizing in...
Status: RESOLVED DUPLICATE of bug 86329
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.1.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.0.0
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-01 17:22 UTC by Andy
Modified: 2015-04-24 17:32 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Here I am dragging to re-enlarge the cropped image on the left side. You can see the original image in the back, as well as the dotted rectangle which is too big (35.62 KB, image/jpeg)
2015-03-01 17:22 UTC, Andy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andy 2015-03-01 17:22:11 UTC
Created attachment 113797 [details]
Here I am dragging to re-enlarge the cropped image on the left side. You can see the original image in the back, as well as the dotted rectangle which is too big

the crop image function in Draw, Impress is working but its interface while performing the crop is now misleading.
How to get see the problem:
- Create a new draw document;
- import any bitmap image;
- click on the crop image tool; larger handles will show up, telling you are in the "crop" mode;
- now drag one of the handles placed in the middle of any of your picture edges
- while you drag, the preview shows a dotted rectangle that suggests a proportional resizing action, NOT a crop of the image on the side you are dragging. This is misleading and confusing, since you are brought to believe there is something wrong or that you've selected the wrong operation
- the result you get when you stop dragging the handle is correct, however. Simply it does nor correspond to what the program was showing you while dragging.
- if you have cropped an image, and now drag again to recover some or all of the cropped part, The dotted rectangle suggests that your image will get bigger on all sides, but again this does not really happen and only the side you are dragging will enlarge.
So the regression (this did not happen in earlier versions) is not a functional problem, but an interface problem.
Comment 1 Roman Kuznetsov 2015-03-01 18:01:04 UTC
confirm this bug

the dotted line is really misleading, showing change the image in all directions.
Comment 2 Gerry 2015-04-23 15:52:21 UTC
I can confirm this bug in LO 4.4.2.2.

Interactive cropping actually crops on all sides (like resizing by keeping the aspect ratio). This is a wrong behavior, because the user wants to crop just one of the sides at time.

The bug does not occur when holding the SHIFT-key (in Windows).

-> I am almost sure this bug was introduced with the with 4.3 change in proportional image scaling. Hence, I link this bug with 83808
Comment 3 tmacalp 2015-04-24 05:30:52 UTC

*** This bug has been marked as a duplicate of bug 86329 ***
Comment 4 Commit Notification 2015-04-24 17:32:22 UTC
Trent MacAlpine committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=18a592a5bfc3c4592b7118cceae774fcc00ae94d

tdf#89758 Interactive crop preview shouldn't scale proportionally

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.