Bug 89780 - Any text placed on a slide is NOT shown when starting the slideshow from that slide
Summary: Any text placed on a slide is NOT shown when starting the slideshow from that...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.4.1.2 release
Hardware: Other Windows (All)
: highest major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: mab4.4
  Show dependency treegraph
 
Reported: 2015-03-02 15:24 UTC by Andy
Modified: 2015-12-17 08:47 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Slide WITHOUT hardware accel (233.31 KB, image/jpeg)
2015-03-07 11:31 UTC, Andy
Details
Slide WITH hardware accel (191.57 KB, image/jpeg)
2015-03-07 11:31 UTC, Andy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andy 2015-03-02 15:24:26 UTC
Open a new Impress document.
Place any text object in it, in the first or any subsequent page
Now start the slideshow from any page: text instead in the age you're starting with is NOT SHOWN AT ALL.
Text in the following slides is shown correctly.
If you start with a slide, then move to the second one, then go back to the first, text in the first slide, which did not show at the beginning, is now visible.
I have tried a lot of fonts, stiles, colors etc. but the problem is always there.

This is a regression which has an easy workaround (start from a slide, then very rapidly go the the 2nd and back to the first before beginning your presentation); however if you're not aware of it you can easily panic in public presentation situations where it could be very annoying.
Comment 1 Cor Nouws 2015-03-02 19:43:10 UTC
(no problem on Ubuntu)
Comment 2 Andy 2015-03-03 11:55:36 UTC
Do you mean that the problem does not show up on Ubuntu?
Perhaps it is a Windows-only problem.
To be precise, I am experiencing it on Windows 7 64bit.
I will try it on an older WINDOWS XP system as well and let you know if things are different there this afternoon.
Comment 3 Andy 2015-03-03 12:18:05 UTC
I have now installed 4.4.1.2 on a Win XP service pack 3 system, replacing 4.3.2.

I can confirm that the problem is present here as well: the first slide you show in a presentation does not display the contained text. 

Text in the following slides is shown correctly. 

And if you go forward to the second slide and then back to the first slide in presentation mode, now text is visible on the first slide as well. 

However if you stop the presentation and restart it from any slide, the first slide you show has no text visible, not even in tables if there are any.

Please notice that 4.3.2 did NOT have the problem.
Comment 4 Buovjaga 2015-03-05 13:39:26 UTC
Problem is observed only in Win 4.4.1, not 4.5 or Ubuntu.

Lowered severity as this is not a crash https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI

Version: 4.5.0.0.alpha0+ (x64)
Build ID: 5a009a4387a84a36d2e3418c7e7b097cb10c3f5a
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-03-04_15:00:21
Locale: fi_FI

Ubuntu 14.10 64-bit
Version: 4.4.1.2
Build ID: 40m0(Build:2)
Locale: en_US
Comment 5 Andy 2015-03-05 16:35:42 UTC
Yes, there is no dataloss or crash or similar here;
however today I had to give a presentation coping with this bug and I can assure you that it was a nightmare: if you go over and over on this and that slide during a discussion with your audience, the problem is there ALL THE TIME and you have to be continuously alert not to make things unmanageable. You end up being more alert on this than on the topic you're duscussing...

Please have a look at this, it is probably easy to solve... at least I hope...
Comment 6 skiani 2015-03-06 21:24:53 UTC
Installed 4.4.1.2 and brought up presentation in front of two dozen people and first slide came up blank. Major scramble to get another computer, total pain. Seems like a pretty major bug. Downgrading till fixed.

Windows 7 64bit
Comment 7 Andy 2015-03-06 23:57:08 UTC
Yes, that is what I meant: even if not disruptive, bugs that show up patently in Impress during presentation mode are critical since you are actually showing them to a vast public. As anybody can easily understand, this can cause huge damage to the perception of LO as a quality product.
Comment 8 Jean-Baptiste Faure 2015-03-07 10:37:13 UTC
Not reproducible for me with LibreOffice 4.4.2.0.0+ built at home under Ubuntu 14.10 x86-64.

What about if you disable hardware acceleration (menu Tools > Options > LibreOffice > View) ?

Best regards. JBF
Comment 9 Andy 2015-03-07 11:29:08 UTC
Yes you're right. So this how thing seem to be at the moment:

- the bug is windows related, not present on Ubuntu (other SO??)

- if you disable Hardware acceleration the problem disappears under windows as 
well

- Since I have tried it on 3 different PCs snd 2 windows releases, and it is always there, however, I would guess this is not hardware specific (i.e. linked to some specific video card driver or similar)

- unfortunately, disabling hardware acceleration causes other problems to emerge: most built in gradients in presentation mode are shown with annoying white stripes all along, which do not appear with hardware accel. 
To see what I mean, check the images I am attaching, which show a screen capture of the same slide with and without hardware accel.
Comment 10 Andy 2015-03-07 11:31:31 UTC
Created attachment 113948 [details]
Slide WITHOUT hardware accel
Comment 11 Andy 2015-03-07 11:31:55 UTC
Created attachment 113949 [details]
Slide WITH hardware accel
Comment 12 Laurent BP 2015-03-07 15:48:46 UTC
Seem duplicate or at least very similar to bug 88111
Comment 13 David F Smith 2015-03-12 15:26:23 UTC
I encountered this yesterday, before a public presentation.  (Fortunately I had enough time to fix it.)

I'm using version 4.4.1.2 under Windows 7 Pro SP1.

Here's another workaround.
Select the text (text box, callout, whatever), then add it as a Custom Animation to Appear With Previous.  That seems to make the text work.
Comment 14 Andy 2015-03-12 19:47:28 UTC
Yes, that is another clever trick, which is practical when you are sure to start always from the first slide, and thus it is enough to add animation to text objects in it.
If you have a 40 slides presentation ad you need to be able to start anywhere, however, adding animation to ALL text objects is really too much time.

Regarding the other workaround, i.e. disabling hardware acceleration (which is what I am doing at the moment, even if gradients are defective as I wrote), I discovered another problem.
You could think that with nowadays, ultra-powerful PCs, animations in a slide presentation would not really need hardware acceleration.... or so at least thought I.
Alas today I realized that the "fade in" animation type that I often use, and works flawlessly WITH hardware accel, looks jerky and awful without HW acceleration. 
I had to frantically change all animations of this type in a presentation because they would have looked totally awkward.
I had no time to check a large number of animation types, though. Maybe the fade in/out are the worst cases.
And this is on an Intel Core i7 machine with 10 GB ram, quite a mean machine as far as I know.
Comment 15 Laurent BP 2015-03-13 22:19:02 UTC
Bug 88111 is fixed in LibO 4.4.2.1. Could you try this RC version if it also solved your problem?
Comment 16 David F Smith 2015-03-13 23:52:37 UTC
I installed 4.4.2.1 on Windows 7 Pro SP1, and it appears that this bug is fixed, along with the related bug 89981.

Well done, developers.  Thanks.
Comment 17 Andy 2015-03-14 11:44:50 UTC
YESSS. The bug is gone for good in 4.4.2.1.
Thanks to everybody involved.
Comment 18 Laurent BP 2015-03-14 12:25:54 UTC
Set as resolved "Works for me" as we don't which commit exactly fixed the bug
Comment 19 Robinson Tryon (qubit) 2015-12-17 08:47:46 UTC
Migrating Whiteboard tags to Keywords: (bibisectrequest)
[NinjaEdit]