Bug Hunting Session
Bug 89809 - LibreOffice 4.4 GTK2 menus don't show checkboxes correctly
Summary: LibreOffice 4.4 GTK2 menus don't show checkboxes correctly
Status: RESOLVED DUPLICATE of bug 62816
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.1.1 rc
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-03 18:03 UTC by S.
Modified: 2015-03-03 23:09 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
checkboxes for selected items are not displayed (99.17 KB, image/png)
2015-03-03 18:04 UTC, S.
Details
at mouseover, the checkbox appears on selected items (99.65 KB, image/png)
2015-03-03 18:05 UTC, S.
Details
EOG image viewer is also GTK3, checkboxes display correctly (31.43 KB, image/png)
2015-03-03 18:05 UTC, S.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description S. 2015-03-03 18:03:52 UTC
Hi,

I'm running LibreOffice 4.4.1.2 from the LibreOffice:Factory repo on openSUSE 13.2, in the Cinnamon desktop environment.

It appears that LibreOffice 4.4 started using GTK3 widgets. It is not fully compatible with my GTK3 theme. (http://gnome-look.org/content/show.php?content=168011) The checkboxes of selected items in the menus are not displayed until mouseover. I will attach screenshots.

This bug is NOT present with some other GTK3 themes like Greybird and Adwaita. However, LibreOffice is the only GTK3 program I have that doesn't work right with my GTK3 theme. I am attaching screenshots of a GTK3 apps that works correctly with my existing theme.

Thanks for looking into this!
Comment 1 S. 2015-03-03 18:04:39 UTC
Created attachment 113858 [details]
checkboxes for selected items are not displayed
Comment 2 S. 2015-03-03 18:05:18 UTC
Created attachment 113859 [details]
at mouseover, the checkbox appears on selected items
Comment 3 S. 2015-03-03 18:05:52 UTC
Created attachment 113860 [details]
EOG image viewer is also GTK3, checkboxes display correctly
Comment 4 Adolfo Jayme 2015-03-03 23:01:36 UTC
> It appears that LibreOffice 4.4 started using GTK3 widgets.

Incorrect. Your screenshots demonstrate you’re still running the GTK+2-based widgets.
Comment 5 Adolfo Jayme 2015-03-03 23:09:35 UTC

*** This bug has been marked as a duplicate of bug 62816 ***