Download it now!
Bug 89844 - LibO crashes when opening a .xls file, amdocl [Hard to reproduce]
Summary: LibO crashes when opening a .xls file, amdocl [Hard to reproduce]
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2015-03-05 12:23 UTC by Alessandro
Modified: 2015-05-22 09:06 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
This is the file that caused the crash. Pretty simple indeed; 13 tabs and some data validation rules. (358.50 KB, application/vnd.ms-excel)
2015-03-05 12:23 UTC, Alessandro
Details
The backtrace of the action that causes the application crash (9.48 KB, text/plain)
2015-04-09 12:38 UTC, Alessandro
Details
OpenCL info screenshot (97.82 KB, image/jpeg)
2015-05-05 08:26 UTC, Alessandro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alessandro 2015-03-05 12:23:27 UTC
Created attachment 113910 [details]
This is the file that caused the crash. Pretty simple indeed; 13 tabs and some data validation rules.

I found a Major misbehavior in LibreOffice 4.4.x,
when I try to open an .xls file (created with MS Excel), which I always was able to manage and modify using earlier versions of LibreOffice, the program crashes triggering the file recovery procedure.
The file recovery procedure also hangs, entering in an infinite loop in which I can only choose to discard the recovered file to get out.

I'm attaching the file that produced this behavior.

Alessandro
Comment 1 raal 2015-03-05 13:39:56 UTC
No crash with  4.4.1.2, win7. I can open file without problem.

No crash with Version: 4.5.0.0.alpha0+
Build ID: a2fa9e2468aa5c4fd4b610c5d0ebc8959e87a072
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-02-23_02:34:05

Please test with LO 4.4.1.2
http://www.libreoffice.org/download/libreoffice-fresh/
Comment 2 Alessandro 2015-03-05 18:37:33 UTC
I can confirm (I just tested it) that version 4.3 can open the file without problems.
Comment 3 Alessandro 2015-03-05 18:40:40 UTC
So sorry, I added my previous comment without noticing the request!

I also tested with the latest stable version, 4.4.1, on a Windows 7 32bit - and it still crashes.

So I had to rollback to the 4.3.5.2 version, that works for me
Comment 4 Joel Madero 2015-03-06 04:05:03 UTC
Ubuntu 14.10 x64
LibreOffice 4.4.1.2 release

Opens with no problems. Please try with a fresh profile: https://wiki.documentfoundation.org/UserProfile
Comment 5 tommy27 2015-03-07 09:00:02 UTC
no crash under Win8x64 using LibO 4.4.1.2

@Alessandro
please reset user profile like Joel suggested and tell if it fixes things.

set status to NEEDINFO waiting for feedback
Comment 6 Alessandro 2015-03-31 08:36:54 UTC
I reset the user profile adding the -OLD suffix to the "user" folder found in C:\Users\MYUSERNAME\AppData\Roaming\LibreOffice\4 ,

but the issue still isn't fixed. 

I have LO version  4.4.1.2, on Windows 7 32 bit


Alessandro
Comment 7 raal 2015-03-31 10:20:42 UTC
If possible, please follow the instructions provided at this link < https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg > and submit a backtrace. That way a developer can look into the underlying reason of the crash.
Comment 8 Robinson Tryon (qubit) 2015-03-31 17:14:04 UTC
Summary -> (hard to repro)
Comment 9 Buovjaga 2015-04-08 17:26:17 UTC
Adding to the "no repro" pile.

Win 7 Pro 64-bit, Version: 4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6
Locale: fi_FI

Version: 4.5.0.0.alpha0+
Build ID: 8c3cf9dd48e40604867d3a28bddaccd65142df17
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-03-27_15:15:18
Locale: fi_FI
Comment 10 Alessandro 2015-04-09 12:29:12 UTC
(In reply to raal from comment #7)
> If possible, please follow the instructions provided at this link <
> https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg > and
> submit a backtrace. That way a developer can look into the underlying reason
> of the crash.


I (maybe) have finally managed to get a backtrace: I'm attaching the .txt

Hope this helps

Alessandro
Comment 11 Alessandro 2015-04-09 12:38:19 UTC
Created attachment 114695 [details]
The backtrace of the action that causes the application crash
Comment 12 Matthew Francis 2015-04-24 15:55:59 UTC
Linked bug 90483 which also seems related to OpenCL and "amdocl"
Comment 13 Matthew Francis 2015-04-24 16:13:13 UTC
Adding Cc: to michael.meeks@collabora.com - moggi suggested I ping you about this one. Taken together with bug 90483, it's possible an OpenCL blacklist entry may be needed
Comment 14 Michael Meeks 2015-04-24 17:47:54 UTC
Alessandro - this is most interesting; is there any chance of getting some information about your OpenCL setup ?

Either the output of running 'clinfo.exe' on the windows console; or going to:

Tools->Options->OpenCL

and getting a screenshot of that; I guess it'd be interesting to switch to another CL implementation to see if that affects things. Needless to say it works fine for my OpenCL / Linux machine so we may need to tweak white/black lists here.

Thanks !
Comment 15 Alessandro 2015-05-05 08:26:55 UTC
Created attachment 115337 [details]
OpenCL info screenshot
Comment 16 Alessandro 2015-05-05 08:33:48 UTC
Hello Michael,

I've added the screenshot you required (the clinfo.exe command crashed every time i tried to run it...)

Hope it helps!

Alessandro
Comment 17 Michael Meeks 2015-05-05 13:00:40 UTC
> I've added the screenshot you required (the clinfo.exe command
> crashed every time i tried to run it...)

If the most simple 'clinfo.exe' command crashes on run; then (somehow) you have mis-configured your system horribly, and the OpenCL stack is broken - which is outside of LibreOffice's control ? Can you try fiddling with that, to the point that clinfo.exe works again ? =)

Beyond that, your screen is rather odd I guess. No idea why the string "Linux" appears in that dialog on Windows =)
Comment 18 Alessandro 2015-05-07 16:34:00 UTC
Hello Michael,

well I have no clue as of how the system has been setup (it is my office desk PC)
but I will try and investigate the matter. 
Happy it's not Libreoffice's fault, I'm trying to fiddle a bit and update you in case I find something new 


Thank you for your great work, guys!

Alessandro
Comment 19 Timur 2015-05-22 08:44:23 UTC
Not reproduced on Windows 7 64-bit with the same "OpenCL info screenshot".
I'll close this one, but feel free to reopen with some new info.
Please update the computer and solved the clinfo before.
Comment 20 Timur 2015-05-22 09:06:32 UTC
http://support.amd.com/en-us/download