Bug Hunting Session
Bug 89958 - Data->Filter->Standard Filter, condition "does not end with" does filter too much
Summary: Data->Filter->Standard Filter, condition "does not end with" does filter too ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.8.2 release
Hardware: Other All
: medium normal
Assignee: Eike Rathke
URL:
Whiteboard: target:4.5.0 target:4.3.7 target:4.4.2
Keywords:
: 94702 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-03-11 17:00 UTC by Björn Michaelsen
Modified: 2015-10-02 17:54 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
test documeny (34.52 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-03-11 17:00 UTC, Björn Michaelsen
Details
fix backported to 4-2 (2.92 KB, patch)
2015-03-20 12:10 UTC, Eike Rathke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Michaelsen 2015-03-11 17:00:16 UTC
Created attachment 114043 [details]
test documeny

Steps to reproduce:
1/ Open attached document
2/ Select column A
3/ Menu: Data->Filter->Standard Filter ...
4/ Field Name "Column A", Condition "Does not end with", Value: "CTORS"

Expected behaviours:
A2 is not filtered as it does not end with "CTORS".

Actual behaviour:
A2 is filtered (and a lot of other row not ending in CTORS are).

Tested with 4.2.8.2 from Ubuntu PPA on Ubuntu 14.04 and 4.3.5.2 on gentoo.
Comment 1 Björn Michaelsen 2015-03-11 17:01:21 UTC
NEW as it happens on too machines with different distros and LibreOffice versions.
Comment 2 Julien Nabet 2015-03-11 23:33:51 UTC
After some gdb, here's a code pointer:
http://opengrok.libreoffice.org/xref/core/sc/source/core/data/table3.cxx#2503
Comment 3 Eike Rathke 2015-03-14 23:59:37 UTC
Hey Julien, thanks for sorting out :-)
Comment 4 Commit Notification 2015-03-20 11:21:42 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9e2e9453cbca9399e1c670b354cfc3c23d70307f

Resolves: tdf#89958 filter ends with / does not end with correction

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Eike Rathke 2015-03-20 11:53:55 UTC
Pending review
https://gerrit.libreoffice.org/14921 for 4-4
https://gerrit.libreoffice.org/14922 for 4-4-2
https://gerrit.libreoffice.org/14923 for 4-3
Comment 6 Commit Notification 2015-03-20 12:05:35 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a2b58dc798bf3cca9a24b7c41a616dc7c3d75f3e&h=libreoffice-4-3

Resolves: tdf#89958 filter ends with / does not end with correction

It will be available in 4.3.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2015-03-20 12:05:46 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=53fd20770d7f425ca99e807bb4b45eafa9b47aad&h=libreoffice-4-4

Resolves: tdf#89958 filter ends with / does not end with correction

It will be available in 4.4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Eike Rathke 2015-03-20 12:10:38 UTC
Created attachment 114208 [details]
fix backported to 4-2
Comment 9 Commit Notification 2015-03-21 21:28:42 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7519a534eedc588a1118acacb8d7b5af1950da89&h=libreoffice-4-4-2

Resolves: tdf#89958 filter ends with / does not end with correction

It will be available in 4.4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Eike Rathke 2015-10-02 17:54:35 UTC
*** Bug 94702 has been marked as a duplicate of this bug. ***