Bug 94702 - FILTER - Using AutoFilter -> Standard Filter -> Condition "Ends With". If value of filter has 7 chars long, then cells with 6 chars long are not filtered.
Summary: FILTER - Using AutoFilter -> Standard Filter -> Condition "Ends With". If val...
Status: CLOSED DUPLICATE of bug 89958
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-02 14:12 UTC by Matias Lopez
Modified: 2015-10-02 17:54 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
Values used to reproduce the error. (312.72 KB, application/zip)
2015-10-02 14:12 UTC, Matias Lopez
Details
The version tested. (55.60 KB, image/png)
2015-10-02 14:17 UTC, Matias Lopez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matias Lopez 2015-10-02 14:12:39 UTC
Created attachment 119204 [details]
Values used to reproduce the error.

Hi,

FILTER - Using AutoFilter -> Standard Filter -> Condition "Ends With". If value of filter has 7 chars long, then cells with 6 chars long are not filtered.

Replication scenario:

Go to A1 and paste the following cells vertically (should fill range a1:a8)

col
a12345
b1234567
C__1234567
D____1234567
e1234
f123
g12345

Then select the range a1:a8, go to Data->Filter->AutoFilter.
When autofilter is set, pull down the filter and select "Standard Filter...".
On "Field name" set "col" (the value at a1 cell), on "Condition" set "Ends With", on Value set "1234567" (a 7 char prefix that should filter some values on the sample table), then click "OK" button to apply the filter.
You will see that cells a2 and a8 (both are 6 chars long) will remain unfiltered even the fact that they don't fit the filter condition.

I use this option a lot, please let me know if I can contribute somehow to fix this issue for next release.

Regards,
Matias Lopez.
Comment 1 Matias Lopez 2015-10-02 14:17:45 UTC
Created attachment 119205 [details]
The version tested.
Comment 2 Matias Lopez 2015-10-02 14:18:31 UTC
I forgot to mention the:
  Version: 4.3.4.1
  Build ID: bc356b2f991740509f321d70e4512a6a54c5f243
That I'm using.
Comment 3 Eike Rathke 2015-10-02 17:49:51 UTC
Can reproduce in 4.3.5 and 4.3.6, but not in 4.3.7
Also reproduced in 4.4.0 and 4.4.1, but not in 4.4.2 or later versions.
Please upgrade.
Comment 4 Eike Rathke 2015-10-02 17:54:35 UTC

*** This bug has been marked as a duplicate of bug 89958 ***