Bug 89970 - Large fonts not shown if antialiasing is off
Summary: Large fonts not shown if antialiasing is off
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-12 16:07 UTC by istvanabadszarka
Modified: 2016-06-03 06:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description istvanabadszarka 2015-03-12 16:07:56 UTC
I am using Xubuntu 14.04.2 LTS, 64 bit
Libre Writer: 4.4.0.3 (Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7)

Problem:
----------
If antialiasing is turned off some large fonts are not shown.
This is present in Writer but also in Calc, Impress...

Description:
--------------
I prefer fonts with no antialiasing (headache otherwise).
If I write something in Writer and zoom in, some letters disappear.
No problem until a certain percent (~160%) then some letters disappear, and OK again from ~440%. 

Can there be a solution to this?

writer 160%: http://postimg.org/image/wnd2n809b/
writer 200%: http://postimg.org/image/4jxwjobtf/
writer 280%: http://postimg.org/image/or2p8ve2x/
writer 440%: http://postimg.org/image/uvop626a7/
Comment 1 istvanabadszarka 2015-03-12 16:10:12 UTC
Libreoffice View settings: http://postimg.org/image/9548zs8c7/
Comment 2 Buovjaga 2015-03-23 07:59:36 UTC
I tried with your settings in a VM with Xubuntu 14.10 64-bit, Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: en_US
.. but could not reproduce with Ubuntu font.

For some reason your settings screenshot has anti-aliasing turned ON instead of OFF, so I tried that too, but could not reproduce.
Comment 3 istvanabadszarka 2015-03-23 12:17:39 UTC
Hi,

Thanks a lot for having a look at this problem.
I think, I have figured it out actually.

It looks to me that Libreoffice does not care too much about its own "View" settings if there is a fonts.conf in the ~\.config\fontconfig folder.

There (fonts.conf) I have made an adjustment for anti-aliasing:

<!--
    1) general anti-alias: OFF
-->
 <match target="font">
  <edit mode="assign" name="antialias">
   <bool>flase</bool>
  </edit>
 </match>
<!--
    2) size dependent anti-alias: ON
-->
 <match target="font">
  <test compare="more_eq" name="pixelsize" qual="any">
   <double>42.7</double>
  </test>
  <edit mode="assign" name="antialias">
   <bool>true</bool>
  </edit>
 </match> 

In addition, previously in my XFCE settings I have turned OFF anti-aliasing ( http://imgur.com/AcY43ob ). I have it turned ON now.

At the moment all anti-aliasing turned OFF in Libreoffice's "View" ( http://imgur.com/yjnvwir ), but still large letters get anti-aliasing when zooming in, hence do not disappear.

I am using Version: 4.4.1.2, Build ID: 40m0(Build:2)
Comment 4 istvanabadszarka 2015-03-23 12:19:12 UTC
Hi,

Thanks a lot for having a look at this problem.
I think, I have figured it out actually.

It looks to me that Libreoffice does not care too much about its own "View" settings if there is a fonts.conf in the ~\.config\fontconfig folder.

There (fonts.conf) I have made an adjustment for anti-aliasing:

<!--
    1) general anti-alias: OFF
-->
 <match target="font">
  <edit mode="assign" name="antialias">
   <bool>flase</bool>
  </edit>
 </match>
<!--
    2) size dependent anti-alias: ON
-->
 <match target="font">
  <test compare="more_eq" name="pixelsize" qual="any">
   <double>42.7</double>
  </test>
  <edit mode="assign" name="antialias">
   <bool>true</bool>
  </edit>
 </match> 

In addition, previously in my XFCE settings I have turned OFF anti-aliasing ( http://imgur.com/AcY43ob ). I have it turned ON now.

At the moment all anti-aliasing turned OFF in Libreoffice's "View" ( http://imgur.com/yjnvwir ), but still large letters get anti-aliasing when zooming in, hence do not disappear.

I am using Version: 4.4.1.2, Build ID: 40m0(Build:2)
Comment 5 istvanabadszarka 2015-03-23 12:54:06 UTC
Comment 3 and 4 are the same, sorry.

All-in-all, fonts and letters work very fine with the these settings: http://imgur.com/B5QP5yW
Comment 6 Buovjaga 2015-03-24 06:29:53 UTC
(In reply to istvanabadszarka from comment #5)
> Comment 3 and 4 are the same, sorry.
> 
> All-in-all, fonts and letters work very fine with the these settings:
> http://imgur.com/B5QP5yW

Thanks for testing. As you seem to be happy now and this was a combined settings issue and not really a bug, I will close this as INVALID.