Bug 95547 - Text rendering at large font sizes doesn't render all characters with antialiasing off
Summary: Text rendering at large font sizes doesn't render all characters with antiali...
Status: RESOLVED DUPLICATE of bug 94531
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.4.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-03 16:45 UTC by Alan Ott
Modified: 2016-06-12 19:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Single-slide, simple ODP presentation showing the issue (11.91 KB, application/vnd.oasis.opendocument.presentation)
2015-11-03 16:45 UTC, Alan Ott
Details
Video showing the issue with the attached file (5.54 MB, video/ogg)
2015-11-03 16:47 UTC, Alan Ott
Details
Video demonstrating the issue coming on and off with antialiasing (2.58 MB, video/ogg)
2015-11-04 17:15 UTC, Alan Ott
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alan Ott 2015-11-03 16:45:35 UTC
Created attachment 120231 [details]
Single-slide, simple ODP presentation showing the issue

At certain font sizes at certain window sizes, text gets rendered with letters missing. Changing the size of the window will push the problem around (different letters will be missing) and sometimes hide the problem.

This is a problem I have seen for a couple of years on various versions of Linux and LibreOffice. I'm sorry I didn't report it before. I always figured it was because of my font settings or something and never investigated it.

I have attached a sample ODP file and a video showing the problem.

In the video, notice that the headline text loses letters as the window is resized, then the letters "lost" change when the font size of the headline text is changed. Then notice that the main text loses letters when the window size is increased, and again, the letters "lost" change when the font size is changed.

This is on the latest Xubuntu release (15.10), but I've also seen it on Debian, and on previous Xubuntu (maybe even Kubuntu) releases. The About window says:

    Version: 4.4.2.2
    Build ID: 40m0(Build:2)
    Locale: en_US

Thanks for having a look at this.

Alan.
Comment 1 Alan Ott 2015-11-03 16:47:32 UTC
Created attachment 120232 [details]
Video showing the issue with the attached file
Comment 2 Alan Ott 2015-11-04 17:13:46 UTC
Hi,

I see that Adolfo Jayme added the "see 89970." Thanks for pointing that out.

That bug was closed because the reporter found a combination of settings that worked for them. Their settings come out to turning antialiasing on at certain font sizes.

Like the reporter in 89970, I had antialiasing turned off in an /etc/fonts/ file. Turning it back on, I see the fonts in LibreOffice rendering properly. Furhter, after turning it back on in /etc/fonts/ I can control it from the XFCE Font window. Toggling the AA setting from that window, the problem is easily demonstrated. I have uploaded another video showing this.

I want to run my system with AA off, and feel like this should work like it does with other applications. Like many others, AA hurts my head. I will change the title of this bug report to reflect the new information.

Thanks!

Alan.
Comment 3 Alan Ott 2015-11-04 17:15:32 UTC
Created attachment 120265 [details]
Video demonstrating the issue coming on and off with antialiasing
Comment 4 Buovjaga 2016-06-12 19:59:02 UTC

*** This bug has been marked as a duplicate of bug 94531 ***