Bug 90063 - duplicated attribute names in svx/source/items/svxitems.src
Summary: duplicated attribute names in svx/source/items/svxitems.src
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.0.0.0.beta4
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-17 14:39 UTC by Andras Timar
Modified: 2015-06-14 18:35 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andras Timar 2015-03-17 14:39:37 UTC
In svx/source/items/svxitems.src there is the StringArray RID_ATTR_NAMES. There are some attributes that share the same en-US label. 

        < "Indent"      ;               SID_ATTR_PARA_LRSPACE ; > ;
        < "Indent"      ;               SID_ATTR_LRSPACE ; > ;

        < "Spacing"     ;               SID_ATTR_PARA_ULSPACE ; > ;
        < "Spacing"     ;               SID_ATTR_ULSPACE ; > ;

        < "Blinking"    ;               SID_ATTR_CHAR_AUTOKERN ; > ;
        < "Blinking"        ;           SID_ATTR_FLASH ; > ;

        < "Scale"       ;               SID_ATTR_CHAR_SCALEWIDTH ; > ;
        < "Scale"           ;           SID_ATTR_ZOOM ; > ;

The l10ntools extract strings from this file, these duplicates result in identical entries in the .pot file, which makes the .pot file invalid. This could be fixed in l10ntools.

On the other hand, isn't it a problem on its own, that we have the same labels for different attributes? This StringArray is used in Search dialog, where the labels are deduplicated. So when the user searches for e.g. "Blinking", what does LibreOffice do? Does it search for SID_ATTR_CHAR_AUTOKERN, or SID_ATTR_FLASH, or both? 

I think that different attributes should have different names. But I don't know what the difference is between the different attributes with the same labels.
Comment 1 Martin Srebotnjak 2015-06-10 21:30:49 UTC
Because of this error Slovenian strings in po files were not pulled and English strings remained in UI. This must be fixed, because pot files are technically invalid.
Comment 2 Commit Notification 2015-06-14 18:34:18 UTC
Zolnai Tamás committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f4b44a81fad83a4c3c8c4dd5f962ad52fd57a2b2&h=libreoffice-5-0

tdf#90063 Avoid duplicated attribute names in RID_ATTR_NAMES

It will be available in 5.0.0.0.beta4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.