Bug 91982 - LO43&50b3: Unlocalizable strings in Find&Replace subdialog
Summary: LO43&50b3: Unlocalizable strings in Find&Replace subdialog
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
5.0.0.0.beta1
Hardware: Other All
: medium normal
Assignee: Andras Timar
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-10 11:25 UTC by Martin Srebotnjak
Modified: 2015-06-10 21:27 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
The unlocalizable content of Attributes window (99.15 KB, image/png)
2015-06-10 11:27 UTC, Martin Srebotnjak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Srebotnjak 2015-06-10 11:25:44 UTC
Hi, attached is the screenshot from Slovenian LO50b3 on OSX (applies also to Slovenian LO43 on OS X) where unlocalizable strings in the

Edit ... > Find & Replace ... > Other options > Attributes ...

window are seen. Since Slovenian is 100 % localized these strings are obviously not localizable.
Comment 1 Martin Srebotnjak 2015-06-10 11:27:03 UTC
Created attachment 116438 [details]
The unlocalizable content of Attributes window
Comment 2 Andras Timar 2015-06-10 11:59:01 UTC
We need to check why StringArray RID_ATTR_NAMES translations are not
merged in case of Slovenian. I have a test build of en-US, hu, ja, sl,
and translations are merged for hu and ja.
Comment 3 Andras Timar 2015-06-10 12:09:08 UTC
So, in svx/source/items.pot the attribute names are keyed with their en-US string, e.g.:

#: svxitems.src
msgctxt ""
"svxitems.src\n"
"RID_ATTR_NAMES\n"
"Do not split paragraph\n"
"itemlist.text"
msgid "Do not split paragraph"
msgstr ""

In Slovenian po the attribute names are keyed with a number:

#: svxitems.src
msgctxt ""
"svxitems.src\n"
"RID_ATTR_NAMES\n"
"28\n"
"itemlist.text"
msgid "Do not split paragraph"
msgstr "Ne razdeli odstavka"

This is the reason why merge is not successful. Martin, can you please check your tools?
Comment 4 Martin Srebotnjak 2015-06-10 20:39:59 UTC
Thanks for locating the error, Andras, I prepared now the corrected svx/source/items.po file.
As far as I can check - this is the only discrepancy between the pot files and the Slovenian po files with this "numbering" in comments.