Bug 90086 - Heading Numbering is Incorrect
Summary: Heading Numbering is Incorrect
Status: RESOLVED DUPLICATE of bug 90832
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-18 17:20 UTC by actionmystique
Modified: 2015-07-13 07:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description actionmystique 2015-03-18 17:20:39 UTC
New Heading1 added at the end of the document 
Right-click: continue previous numbering

Number is the same as previous haeding1

Document: https://drive.google.com/file/d/0B6XxNd5c3zV_N291elVIMGhNQmc/view?usp=sharing
Comment 1 Buovjaga 2015-03-21 15:25:49 UTC
I can achieve:
8.8  Verification Commands
VPN
9  testi

..but if I got to the very last line and Continue prev. numb., I get a bullet as there was a bulleted list before.

I'll ask other QA members before setting to NEW as I'm not sure, if this is a bug or some glitch in the document.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI
Comment 2 actionmystique 2015-03-22 09:06:28 UTC
Testing this issue in a different environment leads to a ... different result.
Comment 3 Jean-Baptiste Faure 2015-07-11 07:41:37 UTC
can't access the file.
Comment 4 actionmystique 2015-07-11 08:00:07 UTC
The file has changed since the first post, so adding a heading at the end of the document will show only another issue because there is no bulleted list between it and the previous heading. (the other issue is that you need to perform a "Continue previous numbering" to get the right number).

To experience the current issue, you need to add a heading after any bulleted list anywhere in the document and check that the number can never be corrected: if you try ("Continue previous numbering"), you'll get a "bulleted heading".

The document is now available here: https://drive.google.com/file/d/0B6XxNd5c3zV_c2NqZ2VQZ0EzYnc/view?usp=sharing
Comment 5 Buovjaga 2015-07-11 08:48:44 UTC
(In reply to Jean-Baptiste Faure from comment #3)
> can't access the file.

Really? I can access the old document fine. https://docs.google.com/uc?id=0B6XxNd5c3zV_N291elVIMGhNQmc&export=download for the download screen.
Comment 6 Jean-Baptiste Faure 2015-07-11 17:00:10 UTC
(In reply to Beluga from comment #5)
> (In reply to Jean-Baptiste Faure from comment #3)
> > can't access the file.
> 
> Really? I can access the old document fine.
> https://docs.google.com/uc?id=0B6XxNd5c3zV_N291elVIMGhNQmc&export=download
> for the download screen.

Maybe the "problem" is a spying script restriction on my side. Too bad for Google Docs.

Best regards. JBF
Comment 7 Buovjaga 2015-07-12 09:56:37 UTC
(In reply to Jean-Baptiste Faure from comment #6)
> (In reply to Beluga from comment #5)
> > (In reply to Jean-Baptiste Faure from comment #3)
> > > can't access the file.
> > 
> > Really? I can access the old document fine.
> > https://docs.google.com/uc?id=0B6XxNd5c3zV_N291elVIMGhNQmc&export=download
> > for the download screen.
> 
> Maybe the "problem" is a spying script restriction on my side. Too bad for
> Google Docs.
> 
> Best regards. JBF

Hopefully this has less spies: http://www43.zippyshare.com/v/KH4l3u88/file.html
Comment 8 Jean-Baptiste Faure 2015-07-12 16:23:06 UTC
(In reply to Beluga from comment #7)
[...]
> Hopefully this has less spies:
> http://www43.zippyshare.com/v/KH4l3u88/file.html

Thank you, I got the file ;-)

Hmm, this file seems to have a long history, it comes from a MS-Word format document, see the names of the numbering styles which starts with WW.

To repair the outline numbering, I would do the following:
1/ remove all WW... numbering styles. The quicker way is to decompress the .odt, edit the styles.xml and remove all corresponding nodes, the recompress the folder.
2/ Apply Tools > Outline numbering
3/ for each heading paragraph reapply the correct heading style: move the cursor in the paragraph, ctrl+0 to apply Text Body style then ctrl+n (type n in the numeric pad) to apply heading_n style.

It is clear that this is easy to do just after importing from MS-Word and before to add many chapters to the text.

Note: after step 3, the correct outline numbering works correctly again. You can test that by doing step 3 for all heading 1, and then add a new heading 1 at the end of the file, it takes the number 9.

Good luck.

Best regards. JBF
Comment 9 actionmystique 2015-07-13 06:53:36 UTC
Thanks for taking the time to propose this, but that's way too much hassle for working around a bug.
Comment 10 actionmystique 2015-07-13 07:12:24 UTC

*** This bug has been marked as a duplicate of bug 90832 ***