Download it now!
Bug 90176 - Undocked sidebar won't dock on either side by dragging and dropping
Summary: Undocked sidebar won't dock on either side by dragging and dropping
Status: RESOLVED DUPLICATE of bug 92122
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.1.2 release
Hardware: x86-64 (AMD64) All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sidebar-UI-UX
  Show dependency treegraph
 
Reported: 2015-03-23 15:36 UTC by Theo Hopman
Modified: 2019-11-02 13:46 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing inability to dock sidebar on left (90.99 KB, image/png)
2015-03-23 15:36 UTC, Theo Hopman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Theo Hopman 2015-03-23 15:36:32 UTC
Created attachment 114275 [details]
Screenshot showing inability to dock sidebar on left

Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: en_CA

When I undock the sidebar, I cannot re-dock it on the left. This seems to happen in all applications, whether the window is maximized or not. As the attached screenshot shows, the outline of the the floating sidebar doesn't turn grey when dragged to the left (or right) side.

This worked in previous versions of LO, even with all the redraw problems caused by having the sidebar on the left.
Comment 1 raal 2015-03-23 19:16:54 UTC
I can not confirm with LO 4.4.1.2,ID build: 45e2de17089c24a1fa810c8f975a7171ba4cd432, win7
Comment 2 Theo Hopman 2015-03-23 19:42:06 UTC
Docking works properly for me on a Win7 virtual machine. It does not on my Win8.1 machine, even with a clean profile.
Comment 3 A (Andy) 2015-03-23 22:44:04 UTC
I see it on the screenshot, but unfortunately I can not reproduce it with LO 4.4.1.2, Win 8.1
Comment 4 Buovjaga 2015-03-25 17:58:48 UTC
Reproduced.

If I first undock the sidebar by ctrl-double click, I can't dock it anywhere.

I *can* move it from the right to the left by simply grabbing the grey area of the docked sidebar and dragging to either side until the dashed frame appears.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI

Ubuntu 14.10 64-bit 
Version: 4.4.1.2
Build ID: 40m0(Build:2)
Locale: en_US
Comment 5 Theo Hopman 2015-03-25 18:18:54 UTC
I didn't know that one could move the sidebar by dragging on the grey area. Thank you for this useful workaround. (It is also inconsistent with toolbar behaviour -- they have handles to move them, while dragging on a grey area does nothing.)
Comment 6 V Stuart Foote 2015-05-10 15:43:30 UTC
Not a bug, changing this to enhancement.

As noted Sidebar is not a toolbar and has different behavior regards drag to a re-dock position.

Rather, Sidebar has two states docked or undocked--and two docking positions, either aligned right (default) or aligned left (set default for RTL).

Once in docked state, the widget will respond to drag and attach left or right. 

But while undocked, mouse action can only move the dialog window. A Dock menu button action is provided to return the dialog to its docked state. As noted, it can then be dragged to opposite edge.

Enhancement would be to provide an additional accelerator/mouse action (to overide the undocked Sidebar's simple movement) to be able to dock the dialog window to the opposite alignment and change its docked state.  Or possibly to more completely replicate the Toolbar widget movements.
Comment 7 Telesto 2017-01-06 13:09:33 UTC
*** Bug 104299 has been marked as a duplicate of this bug. ***
Comment 8 Olivier R. 2017-01-06 14:44:37 UTC
This bug seems to occur when you have disabled in your OS the option “Display the content of the windows while dragging them” (I’m not sure of what is the real name of this option in English).

A simple workaround to re-dock the sidebar:
Key Ctrl + Double click on a empty area of the sidebar.
Comment 9 patheticcockroach 2019-04-12 14:01:46 UTC
(In reply to Olivier R. from comment #8)
> This bug seems to occur when you have disabled in your OS the option
> “Display the content of the windows while dragging them” (I’m not sure of
> what is the real name of this option in English).
> 
> A simple workaround to re-dock the sidebar:
> Key Ctrl + Double click on a empty area of the sidebar.

I'm using LibO 6.2.2.2 x64 in Windows 10. “Display the content of the windows while dragging them” isn't disabled (I haven't actually found the setting and I'm not sure it even exists in Win 10, but when I move my windows the contents move).

Ctrl + Double click on a empty area of the sidebar doesn't let me dock the sidebar. Nor does the "Dock" item in the sidebar's contextual menu.

Someone with a similar issue was advised to solve it by resetting their user profile... https://ask.libreoffice.org/en/question/187250/cant-dock-sidebar/ That's really not something I want to do, but the undocked sidebar is a major impairment to me.
Comment 10 V Stuart Foote 2019-04-12 15:41:57 UTC
(In reply to patheticcockroach from comment #9)
> Someone with a similar issue was advised to solve it by resetting their user
> profile... https://ask.libreoffice.org/en/question/187250/cant-dock-sidebar/
> That's really not something I want to do, but the undocked sidebar is a
> major impairment to me.

Then run in safe mode: Help -> "Restart in Safe Mode" -> "Continue in Safe Mode" to temporarily bypass your profileleaving it intact.

Or, install a current daily or release build in parallel--modify the bootstrap.ini to use its own profile. Test there. You'll be able to tell if it is your OS settings, or a configuration issue with LibreOffice.

https://wiki.documentfoundation.org/Installing_in_parallel

Personally, I've had no issues with this on Windows builds--but launch of the "Adjust the appearance and performance of Windows" to access the System Advanced Settings -> Performance Options -> Visual Effects tab. The checking/unchecking the "Show windows contents while dragging" does toggle the behavior.
Comment 11 patheticcockroach 2019-04-12 16:51:03 UTC
(In reply to V Stuart Foote from comment #10)
> 
> Then run in safe mode: Help -> "Restart in Safe Mode" -> "Continue in Safe
> Mode" to temporarily bypass your profileleaving it intact.

I did that, and undocking/docking worked in safe mode. Then I went back to my normal profile, and this time docking worked... Quite weird, but I guess at least it's "fixed", for now.
Comment 12 V Stuart Foote 2019-04-12 17:01:33 UTC
Going to close this out => WFM

Additional enhancements would be nice, but Drag & Drop repositioning Left edge or Right edge does work.

There are some occasions (or os/DE configuration) when the ability to target the drop goes wrong, but nothing actionable.
Comment 13 V Stuart Foote 2019-11-02 13:46:58 UTC

*** This bug has been marked as a duplicate of bug 92122 ***