Bug Hunting Session
Bug 104299 - UX: Snapping corner to attach/detach the sidebar
Summary: UX: Snapping corner to attach/detach the sidebar
Status: RESOLVED DUPLICATE of bug 92122
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: easyHack, needsDevEval
Depends on:
Blocks: Panel-Docking
  Show dependency treegraph
 
Reported: 2016-11-30 22:29 UTC by Telesto
Modified: 2019-11-06 23:55 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2016-11-30 22:29:23 UTC
Description:
I always try the re-dock the sidebar by moving it to the corner waiting for a 'snap'. It doesn't. 

Steps to Reproduce:
-

Actual Results:  
No snapping corner(s)

Expected Results:
Snapping corner(s)


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Buovjaga 2016-12-03 19:46:03 UTC
Well yeah, docking is pretty frustrating. Luckily we can always click the sidebar settings button and duck/undock.
Comment 2 Heiko Tietze 2017-01-02 15:21:45 UTC
Cannot reproduce the issue. The snap ping area is there at the left and the right edge of the main window. Its size is like for every normal toolbar. Even the Navigator works under Windows (you can always press shift+ctrl+F10 to dock/undock the focused sidebar or Navigator, which is relevant on Linux). It would be a good idea to show the shortcut in the context menu with the undock/dock entry.

Setting as easyHack (just add the text to the context menu) and needsDevEval for the code pointers.
Comment 3 Telesto 2017-01-06 13:09:33 UTC

*** This bug has been marked as a duplicate of bug 90176 ***
Comment 4 V Stuart Foote 2019-11-02 13:47:19 UTC

*** This bug has been marked as a duplicate of bug 92122 ***
Comment 5 Jim Raykowski 2019-11-02 23:39:21 UTC
(In reply to Heiko Tietze from comment #2)
> (you can always press shift+ctrl+F10
> to dock/undock the focused sidebar or Navigator, which is relevant on
> Linux). It would be a good idea to show the shortcut in the context menu
> with the undock/dock entry.
> 
> Setting as easyHack (just add the text to the context menu) and needsDevEval
> for the code pointers.

Code pointers:
/sfx2/source/sidebar/SidebarController.cxx:CreatePopupMenu
SetAccelKey for docking and un-docking menu items
Comment 6 V Stuart Foote 2019-11-03 00:04:04 UTC
@Jim, how would that help wanting to move Sidebar dock from R -> L edge? Issue is changing the docking target--multiple locations in the UI.  E.g. Sidebar deck, floating F5 Navigator, Slide sorter in Impress.
Comment 7 Jim Raykowski 2019-11-03 03:09:32 UTC
(In reply to V Stuart Foote from comment #6)
> @Jim, how would that help wanting to move Sidebar dock from R -> L edge?
> Issue is changing the docking target--multiple locations in the UI.  E.g.
> Sidebar deck, floating F5 Navigator, Slide sorter in Impress.

Hi Stuart,

The code pointers given are for displaying the shortcut keys next to the Dock and Undock menu items in the Sidebar tab bar configuration popup menu. It won't solve the problem of sometimes not being able to drag dock. I have also experienced this but at the moment can not repro. I will make an enhancement report and give the code pointers there and these comments that don't directly pertain to the solution can be hidden if that would be better. Please advise.
Comment 8 V Stuart Foote 2019-11-03 05:14:43 UTC
OK, I think maybe Heiko misunderstood the OP's issue and as it worked for him, he called for an easy hack and code pointers to add the re-dock control.

Issue is valid, bug 92122 (Windows) -- bug 64438 (Linux, KDE for sure) -- and recently bug 128543 (macOS)

Maxim had some ideas on refactoring the docking frames for Windows specifically but maybe in general which may resolve the issue on KDE. Not clear what --if anything-- is happening with compositing the frames for qt5 and gtk3

=-ref-=

[1] https://bugs.documentfoundation.org/show_bug.cgi?id=92122#c14