Bug 128543 - Unable to dock Navigator window to the LibreOffice's main window side.
Summary: Unable to dock Navigator window to the LibreOffice's main window side.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: All macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Navigator Panel-Docking
  Show dependency treegraph
 
Reported: 2019-11-02 08:59 UTC by Roman Kuznetsov
Modified: 2019-11-06 16:48 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Mouseover activation at lower edge (33.08 KB, image/png)
2019-11-05 14:57 UTC, trainman75
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2019-11-02 08:59:37 UTC
Description:
Unable to dock Navigator window to the LibreOffice's main window side.

Version: 6.4.0.0.alpha1+
Build ID: 706afd3e765e98489a2b43934a259626f9f0be01
CPU threads: 4; OS: Mac OS X 10.15; UI render: default; VCL: osx; 
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

don't repro in

Версия: 6.3.2.1
ID сборки: db810050ff08fd4774137f693d5a01d22f324dfd
Потоков ЦП: 4; ОС:Mac OS X 10.15; Отрисовка ИП: по умолчанию; VCL: osx; 
Локаль: ru-RU (ru_RU.UTF-8); Язык интерфейса: ru-RU
Calc: threaded

so it's a regression

Steps to Reproduce:
1. Open Writer
2. Press F5 => Opens float Navigator window
3. Drag it to left side of main LO window => it happens nothing


Actual Results:
Unable to dock Navigator window to the LibreOffice's main window side.

Expected Results:
Can to dock Navigator window to the LibreOffice's main window side.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 V Stuart Foote 2019-11-02 13:58:11 UTC
@Roman, does the same happen with the Sidebar? The F5 floating Navigator uses the same object framework. So, when you undock the Sidebar, you should be able to drag it to the left edge of the frame and get a mouseover activation of the docking target.

And, if that also is not happening, it could be a DE object issue.

An issue for sure on Windows builds, see also bug 92122 for when the 'Show window contents while dragging' DE feature is not enabled. And some suggestion in bug 104299 that Linux DE are affected as well. No reason to expect that macOS is not also affected--only question is how DE other than Windows
Comment 2 V Stuart Foote 2019-11-04 14:34:37 UTC
@Alex, *

Could you check behavior on macOS as here, and with some of the other undocked panels:

Full Sidebar 
F5 instance of Navigator
Elements pane in Math, 
Page pane in Draw
Slide pane in Impress

Once undocked are you able to dock them by dragging their frame to the edge of the main LibreOffice frame. The GUI cursor is the focus of the drop, should trigger as it passes over the edge of the parent frame.
Comment 3 Ahmad Haris 2019-11-05 13:48:49 UTC
Hi Roman Kuznetsov,

I reproduce your step, it's happen when Writer window not in full screen. But in full screen, it's worked.

Could you retest on full screen?

Thanks
Comment 4 Ahmad Haris 2019-11-05 13:55:58 UTC
I'm doing with:

Version: 6.4.0.0.alpha1+
Build ID: d2b5ab3498a78c6d164a15b3bf2b947553ea2743
CPU threads: 8; OS: Mac OS X 10.15; UI render: default; VCL: osx; 
Locale: en-ID (en_ID.UTF-8); UI-Language: en-US
Calc: threaded
Comment 5 Xisco Faulí 2019-11-05 14:29:44 UTC
I can't reproduce it in

Version: 6.4.0.0.alpha1+
Build ID: 27fcc9a3465c62901955c822f596c98e4dcc0f66
CPU threads: 8; OS: Mac OS X 10.14.6; UI render: default; VCL: osx; 
Locale: en-US (en_ES.UTF-8); UI-Language: en-US
Calc: threaded

could it be a more recent regression ?
@Roman, did you clean your user profile ?
Comment 6 trainman75 2019-11-05 14:57:56 UTC
Created attachment 155535 [details]
Mouseover activation at lower edge

Just tried on the 5 Nov daily build, and the mouseover activation works, but only for the last few pixels at the bottom of the main window. 
It is not window size dependent. 
I couldn't get a screen cap showing the exact location including the pointer, but this shows the navigator window 1 px above where the mouseover activates. Mouse pointer was roughly vertically centered within the title bar.
Comment 7 trainman75 2019-11-05 15:18:03 UTC
Forgot to add, MacOS10.15 Catalina.
Comment 8 Alex Thurgood 2019-11-06 06:58:28 UTC
Testing against 
Version: 6.4.0.0.alpha1+
Build ID: 2af494822da31ccadfc96f59d61493cae63d60d7
CPU threads: 4; OS: Mac OS X 10.15.1; UI render: default; VCL: osx; 
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded

F5 Navigator window can be docked and undocked against left frame border of main app Writer window. The pooint at which docking gets permitted is dependent on the mouse cursor position. WFM.

Sidebar - same result as for Navigator window
Math formular sidebar - same result as for Navigator window
Page pane in Draw - same result as for Navigator window
Slide pane in Impress - same result as for Navigator window

This all seems to WFM with my latest master build (about 1 weel old).
Comment 9 trainman75 2019-11-06 07:26:34 UTC
OK, tried it again now I'm not tired, and docking the navigator window is consistent from 6.3.2.2, and right through the bibisect tree to 6.4 latest.
I'm using MacOS Catalina 15.1 beta, and LO en-AU locale.
Would be useful to get other confirmation, but looks to me like it works as intended. 
The docking option only shows up while the pointer is over the border, on my screen it's the left hand 20 pixels.
Comment 10 Xisco Faulí 2019-11-06 10:36:00 UTC
Hi Roman,
Please try again with a more recent master build...
Comment 11 Roman Kuznetsov 2019-11-06 16:35:58 UTC
(In reply to Xisco Faulí from comment #10)
> Hi Roman,
> Please try again with a more recent master build...

don't repro in

Version: 6.4.0.0.alpha1+
Build ID: 188bdbaf19241cd51820832fdb4522747534bec6
CPU threads: 4; OS: Mac OS X 10.15.1; UI render: default; VCL: osx; 
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

let's close it as WFM

hm... I see updated version of macOS 10.15.1, may be it's matter?
Comment 12 Xisco Faulí 2019-11-06 16:40:19 UTC
(In reply to Roman Kuznetsov from comment #11)

> hm... I see updated version of macOS 10.15.1, may be it's matter?

I haven't updated to Catalina yet, so I don't think so
Comment 13 Roman Kuznetsov 2019-11-06 16:48:20 UTC
(In reply to Xisco Faulí from comment #12)
> (In reply to Roman Kuznetsov from comment #11)
> 
> > hm... I see updated version of macOS 10.15.1, may be it's matter?
> 
> I haven't updated to Catalina yet, so I don't think so

They can broken it in 10.15 and then fux it in 10.15.1.